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Introduction

1.1 About this manual

This manual is the TOPSPIN Installation Guide for Microsoft Windows XP and
describes the installation of the TopSpin 2.1 under Microsoft Windows XP.

It is available: 

• as a hard copy Installation Guide for TOPSPIN 2.1: Windows XP

• as pdf file on the toplevel of the TOPSPIN DVD

• as TOPSPIN Online Help: click Help → manuals → Installation Guide

• as the up to date version on the Bruker web-server:

http://www.bruker-biospin.com/documentation_nmr.html

• Note that this manual does not contain the TOPSPIN Release letter. That is a
separate document which is not available as a hard copy but delivered as
pdf and text files on the TOPSPIN DVD and also on the Bruker web-
server (you can find it at the same URL as the Installation Guide) 

http://www.bruker-biospin.com/documentation_nmr.html

This manual is subdivided into an introduction and three main parts. It depends on
your local demands which of these are necessary for you at the moment.

http://www.bruker-biospin.com/documentation_nmr.html
http://www.bruker-biospin.com/documentation_nmr.html
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The first part shows how to install and configure TOPSPIN and some essential addi-
tional software packages. It is recommended to follow the instructions step by
step.
DONE INDEXPart two describes the scratch installation of Windows XP and some configuration
steps for Windows XP, the network and printers. If you want to install Bruker
BioSpin TOPSPIN on a PC which is already in use, you can skip this part.

In the last part, you can find some additional information for working with Win-
dows XP and TOPSPIN and also some tips for troubleshooting.

Note that all text-messages and graphics shown in this book are taken from the
current version of the respective software products. Small differences to other ver-
sions are possible but generally speaking they should be very similar.

If you have any comments or suggestions, or if you find any errors in this manual,
please do not hesitate to contact us at:

nmr-software-support@bruker-biospin.de

1.2 Conventions

Bold-Courier: Windows XP commands to be entered from the keyboard

Bold-Times: Windows XP commands, applications or buttons to be clicked with
the mouse

Bold-Courier-Italics: TOPSPIN commands to be entered from the key-
board

Bold-Times-Italic: TOPSPIN commands to be clicked with the mouse

Courier: a file name or directory name

Courier Small Italics: response of the system

Courier Small: the contents of a file

Times italics: any name which is not a file name e.g. hostnames, usernames etc. 

< >: place holder
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1.3 Safty Regulations

In order to work safety in laboratries with NMR-spectrometers all users have to
DONEINDEX
follow the safety regulations for magnetic, electrical, cryogenic and chemical
safety. For detailed information please refer to the safety instructions in the Begin-
ners Guide Manual provided on the TOPSPIN DVD.

1.4 Hardware and software requirements for TOPSPIN

1.4.1 Operating system requirements

TOPSPIN 2.1 on spectrometer computers is supported for:

• Windows XP Professional

• Windows Vista (Business Edition)

• Linux Red Hat Enterprise WS 3 and WS 4

All operating system updates (hot fixes and service packs) at the time TOPSPIN 2.1
was released have been tested and are supported. TOPSPIN 2.1 on Datastations is
supported for:

• Windows 2000

• Windows XP Professional

• Linux Red Hat Enterprise WS 3, WS 4 and WS 5

Although not officially supported by Bruker, users reported that TOPSPIN is also
running and is used for data processing, respective as storage unit,

• on other Linux systems
and

• on Windows XP Home Edition.

Bruker BioSpin does not recommend these systems for the use TOPSPIN. Please
note, the usage of not supported operating system is at one’s own risk!

1.4.2 Special PC Hardware requirements

To run TOPSPIN 2.1 we recommend the following computer hardware:

• PC 1 with CPU Clock ≥ 1 GHz
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• Memory ≥ 512 MB (Windows Vista: ≥ 1 GB)

• Video (graphics)-card memory: 64 MB 1
DONE INDEX
• Ethernet card (to control a spectrometer, it is essential to have a second eth-

ernet card)

• Mouse with 3-button possibilities

• DVD device 2

If your hardware does not meet these requirements, TOPSPIN might still run but 
with a much lower performance.

Furthermore, we recommend setting the display resolution to 1280*1024 or higher.

The Installation was tested on a ’hp workstation xw4400’ PC with a ’NVIDIA
Quadro FX560’ graphics card and two ’Broadcom NetXtreme Gigabit Ethernet’
cards.

1.4.3 Spectrometer requirements 

TOPSPIN 2.1 is released for datastations, AVANCE (AV), AVANCE-II
(AV-II) and AVANCE-III (AV-III) spectrometers.

For upgrade possibilities of your spectrometer with TOPSPIN 2.1, please get in
touch with your local Bruker representative.

Hardware components that are TOPSPIN version or operating system dependent are
listed below. Components that are not listed here do not need an upgrade for TOP-
SPIN 2.1. 

If your Avance spectrometer does not meet the above specifications, please get in
touch with your local Bruker representative for your upgrade options.

1.  TOPSPIN 2.1 only runs on x86 based PC’s. It does not support 64bit architecture.
1.  It is recommend not to use shared memory graphics, because in some cases memory problems 

could be observed.
2.  TOPSPIN 2.1 is delivered on DVD’s with "-r" format.
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1.4.3.1 AVANCE and AVANCE-II spectrometers (AQS based)

• CCU
DONEINDEX

• FCU 3  

LINUX, independent of the TOPSPIN Version

CCU required minimum EC level

CCU 10
(part # H9503) EC level 00 to 19

06

CCU 10
(part # H9503) EC level > 19

22

CCU 11 1

(part # H9503V1)

1. Note that CCU 11 also exists for AQX/AQR spectrometers.

00 (recommended 01)

Windows, independent of the TOPSPIN Version

CCU required minimum EC level

CCU 10
(part # H9503)

requires no specific EC level

CCU 11 1

(part # H9503V1)

1. Note that CCU 11 also exists for AQX/AQR spectrometers.

00 (recommended 01)

FCU 3 required minimum EC level

part # H5822
(64k memory)

04 (recommended 07)

part # H9598
(256k memory)

02 (recommended 05)
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• FCU 4  

FCU 4 required minimum EC level
DONE INDEX

• RCU

part # H9727 requires no specific EC level

part # H9773 requires no specific EC level

RCU 1

1.  AVANCE (AV) spectrometers ony

required minimum EC level

RCU 1/2 (part # Z003678) requires no specific EC level

RCU 1/3 (part # Z022488) requires no specific EC level

Multiple Receiver RCU 1

1. AVANCE (AV) spectrometers ony

required minimum EC level

RCU 1/2 (part # Z052488) requires no specific EC level

RCU 2/4 (part # Z062488) requires no specific EC level

RCU 3/4 (part # Z072488) requires no specific EC level

RCU 4/4 (part # Z082488) requires no specific EC level

RCU 1/5 (part # Z003206) requires no specific EC level

RCU 2/5 (part # Z003207) requires no specific EC level

RCU 3/5 (part # Z003208) requires no specific EC level

RCU 4/5 (part # Z003209) requires no specific EC level
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• TCU 3 

TCU 3 required minimum EC level
DONEINDEX

• RX22 

1.4.3.2 AVANCE III spectrometers

• IPSO 19" 

part # H5813
with EC level between 00 to 19

09 (recommended 12)

part # H5813
with EC level > 20

28 (recommended 31)

part # H5813V1 any (recommended 01)

part # H5813F2 any (recommended 01)

part # H5813F3 any (recommended 01)

RX22 required minimum EC level

part # Z002810 any (recommended 08)

part # Z012810 any (recommended 02)

part # Z032810 any (recommended 01)

IPSO 19" H9987 required minimum EC level

Baseboard
part # H12519

03

TX-board (F-/T-/G-Ctrl)
part # H12538F1

01

TX-board (F-/T-/G-Ctrl)
part # H12538F2

requires no specific EC level

RX-board (R-Ctrl)
part # H12532

requires no specific EC level

PCI-board
part # H12524

01
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• IPSO-AQS 

IPSO-AQS H9984 required minimum EC level
DONE INDEX

• DPP1 

1.4.4 Software requirements
• Microsoft Windows Vista, Windows XP (SP2) or Windows 2000 (SP4) 1 for

TOPSPIN > 2.1 2

• on DVD: ’TOPSPIN 2.1’

• TOPSPIN

• Flexlm License Manager [see Chapter 7]

• For spectrometer control the following version must be used:

• Hummingbird NFS Server Version 7.1 3 (CD: TOPSPIN NT Toolkit) [see
Chapter 4]

• For NMR-GUIDE:

IPSO-ACQ host
part # H12547

requires no specific EC level

IPSO-ACQ acq
part # H12549

requires no specific EC level

PCI adapter board
part # H12557

requires no specific EC level

HR-board
part # H12553

requires no specific EC level

FTMS-board
part # H12555

requires no specific EC level

DPP1 required minimum EC level

part # H12513F1 requires no specific EC level

1.  Windows 2000 only for Datastations (for further information see chapter 1.4.1).
2.  TOPSPIN requires a NTFS filesystem on the partition where the Topspin is installed and a 

NTFS filesystem on all partitions where TOPSPIN data are stored [see chapter 14.1].
3.  The NFS Server is only required for AVANCE and AVANCE-II spectrometers.

!
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• Internet Explorer > 6.x (CD: Microsoft Windows XP)

• For TOPSPIN Online Help and NMR GUIDE
DONEINDEX
• A PDF viewer (e.g. Adobe Acrobat Reader [see Chapter 5])

1.5 Important Windows configurations

This Installation Guide for TOPSPIN refers to the following configurations for Win-
dows XP. Several functions (e. g. Control Panel, Start menu, Windows Explorer)
can be configured in a Classic view-mode or Category view-mode (Windows XP
style). These modes are not only different in style. They can be different in the
way commands are entered.

1.5.1 Configure the Start Menu

For this manual the Start Menu is configured in the Windows XP style.

• Click the RIGHT mouse button on the Taskbar → click Properties

• Click Start Menu → click Start Menu → click OK 

1.5.2 Configure the Control Panel and the Windows Explorer

For this manual the Control Panel and the Windows Explorer are configured in the
Classic View style.
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• Click on the left side on Switch to Classic View 
DONE INDEX
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Express Installation and 
Configuration of TOPSPIN

2.1 About this chapter

This chapter gives a brief description of how to install Bruker BioSpin’s TOPSPIN.

This chapter is directed to users who would like to install TOPSPIN 2.1 on a PC, on
which XWIN-NMR or a version of TOPSPIN is already installed and configured cor-
rectly. Therefore this chapter provides an overview and provides not information
on all aspects of configuring Windows XP and TOPSPIN.

For more details on the installation see chapter 6.4.

For more details on the TOPSPIN commands like cf, expinstall, etc. please
refer to the description of this command in the Acquisition Reference manual. 

2.2 Installing TOPSPIN

The main decision you have to make during installation is where do you want to
install the new TOPSPIN version. If you a have previous NMR SUITE or TOPSPIN

installation on this PC available, you can either:
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• install the new version in parallel to the previous one
(e.g. old in C:\Bruker\TopSpin1.3 and new in
C:\Bruker\TopSpin2.1)
DONE INDEX
or

• install the new version in the same directory as the previous one
(e.g. old in C:\Bruker\TopSpin and new in C:\Bruker\TopSpin)

The installation in parallel has the advantage, that the previous version remains
unchanged. After a parallel installation you can start working with the new version
and if you want to go back to the previous version for whatever reasons you can
just start and reuse it.

The installation of TOPSPIN 2.1 offers an automatic import of your individual con-
figuration of a previous version, so that there is no advantage to install the new
version in the same directory as the old one.

1. Log in as a Local Administrator

2. Close ALL WINDOWS on the desktop

3. Insert the DVD ’TOPSPIN 2.1’.

4. Start of the installation

• If the automatic start of the DVD is enabled, the window described in the
next step appears automatically, go to step 5

• If this window of the next step does not appear automatically, autorun is
probably switched off (see chapter 10.3) or open the Windows Explorer, go
to the DVD device and double-click install.cmd 1.

5. The windows Welcome to the TOPSPIN Setup will appear: → Click Next

6. A window Release Letter TOPSPIN will appear: 

a) Please read the NMR Release letter! You can find there all information
about news and bug fixes of the current version.

b) Close the Release Letter by clicking the X button in the upper right corner

• Select the destination directory for TOPSPIN. 

a) Accept the default destination

b)  or browse to another destination.

1.  Please note that there is also a file called ‘install’ on the DVD. This file is the installation 
script for Linux, under Windows you have to click on the file ‘install.cmd’
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• Enter an installation path which does not exists so far, e. g.
C:\Bruker\topspin2.1

• or browse to another existing installation path.
DONEINDEX
• Click OK

• Click Next

7. A window Select the setup type will appear:

a) Select the setup type. Do one of the following:

• Select Data Processing, Acquisition and Automation if you want to use
TOPSPIN for spectrometer control. This will install Diskless automati-
cally.

• Select Data Processing if you want to use TOPSPIN for data processing.

• Customized setup (allows components selection) if you want to install
selected programs only.

A window ’Product selection’ will appear. Select the packages which you
want to install (note that DISKLESS is only required if your PC controls a
spectrometer or you want to configure it like this. 

b) Click Next

8. A window ’Question’ will appear if Windows XP Service Pack 2 is installed
and enabled on your system. If you click Yes on the installation configure the

firewall 1 for you 2.

9. A window ’Select Components’ will appear. You can either import no spec-
trometer configuration, or browse for a spectrometer configuration or select one

of the configurations you get offered within this window 3.

• Click Next

10. A window ’Set NMR Super User’ will appear:

a) Do one of the following: 

• Accept the default NMR Superuser (Administrator) or 

• Enter a special user for this purpose, e.g. named nmrsu or 

1.  The firewall must be configured to enable spectrometer access.
2.  If you click on No an Administrator can do it any time later, running <topspin-

home>\prog\bin\Utilities\Miscellaneous\setfirewal.cmd (see chapter 8.9).
3.  The installation process will offer all configurations which are available in the TOPSPIN / 

XWIN-NMR installation that are defined in the registry.
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• Enter any other user

Under Windows the username must be the name of an existing user. For fur-
ther details check chapter 6.2.
DONE INDEXb) Click Next

11. A window ’Password Input’ will appear 1 (for more details about this feature
see chapter 6.2):

a) Do one of the following: 

• Type in the NMR ADMINISTRATION PASSWORD

• Re-enter the NMR ADMINISTRATION PASSWORD

b) Click Next

→ The installation of TOPSPIN will start now.

12. A window ’Setup is complete’ will appear:

• You will be asked if you want to restart the computer: 

a) Click Yes I want to restart my computer now

b) Click Finish (to reboot the computer)

13. After the PC has booted up, press the reset button on the CCU or turn it on with
the key if it was switched off. Don’t forget to execute cf and expinstall
(if necessary; see chapter 2.3).

The following information is for the Customized setup:

• It is strongly recommended to accept the default path for the flexLM installa-
tion: ’C:\flexlm’ ! If you choose a user defined path, it may cause some
problems with other applications using the FlexLM.

2.3 Configuring TOPSPIN

The idea of this chapter is to give you some guidelines to configure TOPSPIN for
using it on a workstation for data processing, or for operating a spectrometer. We
do not discuss the commands in detail here. For a full description refer to the TOP-

1.  Certain commands like cf and expinstall ask for the NMR ADMINISTRATION PASS-
WORD.

!



Express Installation and Configuration of TOPSPIN 25

INDEX

SPIN manuals.

Start TOPSPIN:
DONEINDEX
• Click the icon TOPSPIN on the desktop, or

• Click Start → All Programs → Bruker TOPSPIN → TOPSPIN<vers.>

After the first startup of TOPSPIN a window ’LICENSE’ will appear:

a) Please read the license agreement for Bruker TOPSPIN !

b) If you agree, please click I Accept.

After the first startup of TOPSPIN a window ’Configuration check’ will appear. 

You have the possibility to configure the software (depending upon the hardware
of your spectrometer). If you do this, you are probably in one of five situations:

1. You want to configure a processing-only-PC with a default configuration on a
datastation → go to chapter 2.3.1 (see also chapter 8.1.3)

2. You have just installed the software in a new directory and the old spectrometer
configuration of the software is still known to the new version → go to chapter
8.1.1

3. You want to configure a processing-only-PC like your spectrometer-PC, so you
have the spectrometer configuration on another computer → go to chapter 8.1.2

4. You have to configure the software on a new hard disk without a backup of the
spectrometer configuration, so you have no configuration files → go to chapter
8.1.4

5. You have a new spectrometer hardware component, so you have no configura-
tion file → go to chapter 8.1.5

If you would like to take over the configuration of an existing XWIN-NMR or TOP-
SPIN installation into TOPSPIN 2.1, please check chapter 8.2.

2.3.1 If you want to use a default configuration on a datastation

A default configuration can be used on a PC that is used for processing only. It is
automatically performed (no cf required) during the installation of TOPSPIN on a
new computer, a new disk or in a new TOPSPIN installation directory. The default
configuration names are Bruker_default_av500 (corresponds to an Avance 500
MHz spectrometer) and Bruker_default_avanceII300 (corresponds to an Avance II
300 MHz spectrometer).
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For data processing, the automatic default configuration is sufficient. If, however,
you want to use AU programs, you must execute expinstall and select Instal-
lation for Datastation (Default). 
DONE INDEXFor further details please refer to the respective chapters (see chapter 8.1.2).

2.3.2 If your PC controls a spectrometer:

1. Be sure that the spectrometer is booted (see chapter 6.4 and also 15.5.3)

2. Open a dataset

• Type new and create a new dataset.

• You can also select a dataset (e.g. exam1d_1h) acquired with another TOP-
SPIN or XWIN-NMR version

3. Enter cf (The command cf now configures the software according to the
hardware of your spectrometer.)

a) A window will appear:
Password request. Please enter the NMR administration
password

Type in the NMR ADMINISTRATION PASSWORD. Click OK.

b) A window will appear:
Spectrometer configuration: ...

Most likely you will select an existing configuration and press Edit to
confirm this configuration.

c) A window will appear:
Edit configuration. ...

The selected configuration is displayed. Choose whether to configure it as
a spectrometer or datastation. Choose the type of your spectrometer e.g.
AVANCE → ENTER. Check or type in the 1H frequency of the magnet
e. g. 500.13 → ENTER. Use the debug mode only in case of trouble-
shooting.

d) If a mod hconfserver information window appears:

• your spectrometer has not a BSMS rack with ECLB board: you may
ignore this warning. Nevertheless please check the Configuration sum-
mary (uxnmr.info file) if all units are listed.

• your spectrometer has a BSMS rack with ECLB board: please check if
the DHCP server is running. If you cannot start the Bruker DHCP ser-
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vice please see chapter 15.6.
e) A window will appear:

Specify the channel to which external devices are con-
DONEINDEX
nected. The RS232/485 channel for external devices-

Table appears.

Check if the tty-numbers of the hardware components are set correctly.

f) A window ’Additional configuration’ will appear:
Security check. Enable peak power check (POWCHK).

• Choose the options if you want to use this security options. Powchk
and Pulchk require special probes and cortab. If in doubt contact your
local Bruker representative, please.

Sample changer configuration. Should the Sample Chang-

er control the Lift? (yes/no) 

• The answer depends on how the air flow is connected, normally you
will answer: yes → ENTER

Delay between SX and next command [sec]? 

• Type in the length of the delay e. g. 10 → ENTER
g) The nuclei-table appear

Check if the frequency of the nuclei are set correctly. If in doubt click Re-
store then click Save

h) A window ’Edit spectrometer configuration’ will appear:
Check if the preamplifier connections are set correctly and click Save..

i) The results of cf appears in a text window. Check this list carefully and
compare the result with an list from an earlier configuration (if available)
click Print and store the paper output with your other spectrometer
documentation, then click OK. These data are saved in
<TOPSPINHOME>/conf/instr/<spect>/uxnmr.info.

If during ’cf’ an error message occurs that invites you to do a firmware 
update check chapter 8.6

After finishing cf the window ’config’ will appear showing a list of configura-
tion steps. You will be asked for the NMR ADMINISTRATION PASSWORD
several times: 

• Continue with expinstall 

a) Type in the NMR ADMINISTRATION PASSWORD and ENTER

!
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b) Click Next if you either have not modified Bruker BioSpin Parameter files,
AU-programs and Pulse-programs or if you have archived them in a differ-
ent directory. Your individual Parameter files, AU-programs and Pulse-pro-
DONE INDEX
grams etc. that are named different to the original Bruker BioSpin files will
not be destroyed during the installation.

c) A window appears: Check Installation for Spectrometer → Click Next 

d) In the appearing window: Check the required system → Click Next

e) In the appearing dialog box: Select the spectrometer configuration name →
Click Next

f) In the appearing dialog box: Check the items you want to install or, accept
the default selection → Click Next

g) In the appearing dialog box: Select the default printer and plotter and the
desired paper format → Click Next

h) In the appearing window: Enter the desired spectrometer frequency, acquisi-
tion mode and pre-scan-delay or, accept the default values → Click Next

i) In the appearing information box: Check the configuration selection and, if
it is correct → Click Finish
While Expinstall will be executed, you can configure the next configuration
programs.

• Continue with edsolv

Check the list of lock solvents → click Save if it is correct → Click Close

• Continue with edhead

Select the current probe → click Define as current probe → Click Exit

A window ’Edit Spectrometer Parameter’ will appear:
Check if the connections between preamplifier and probe are set correctly →
click Save if it is correct → Click Close

• Continue with edprosol

Check the parameters for your observed nuclei, and if necessary change
and/or recalculate them → Click Save to store to disk → Click Exit

• Continue with edlock

Check the lock table values (field, lock phase, ...), change them and click
Save if necessary, otherwise click Abort

• Continue with edscon
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Check the spectrometer constants, change them and click Save if necessary,
otherwise click Cancel

• After finishing the configuration a window cron check appears. Click on
DONEINDEX
Automatic backup to set up an periodically backup.

After cf, expinstall,... have finished insert a sample and make sure that you
can lock on the lock solvent. Type ii and read with rpar a standard Bruker
BioSpin parameter file (e. g. 'rpar PROTON all'), type getprosol, rga and

wobb and collect a normal 1H NMR spectrum.

2.3.3 If you want to configure a processing-PC like your spectrometer-PC:

If the PC does not control a spectrometer but is used in connection with a particu-
lar spectrometer, e.g. for setting up experiments, processing and or plotting, you
should configure it as that spectrometer (see chapter 8.1.2).
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General Installing Information

3.1 Installation order

A complete new installation on a PC connected to a spectrometer involves the fol-
lowing steps: 

1. Installing Windows XP (see chapter 11.1) 

2. Installing Windows XP Service Pack (see chapter 11.2)

3. Installing the Graphics driver (see chapter 11.3) 

4. Configuring the network (see chapter 13) 

5. Installing a printer (see chapter 14)

6. Installing a PDF viewer (see chapter 5)

7. Installing NFS Server (see chapter 4.3) 1, 2

8. Installing TOPSPIN (see chapter 6.4) 

9. Configuring NFS Server (see chapter 6.6) 2

1.  Note for Windows XP SP2 users with enabled firewall: If you have installed the NFS server 
after TOPSPIN, you have to execute setfirewall.cmd again (see chapters 4.5 and 8.9)!

2.  The NFS Server is only required for AVANCE and AVANCE-II spectrometers.
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10. Installing TOPSPIN license (see chapter 7.2)

11. Configuring of TOPSPIN for spectrometer control (see chapter 8.1.1) 
DONE INDEX
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Installing NFS Server

The NFS Server is only required for AVANCE and AVANCE-II spectrometers.If
your PC is used as a datastation, no NFS is needed.Furthermor AVANCE-III spec-
trometers do not need the NFS Server anymore, the bootparam process is not
required anymore and can be disabled in the list of services (Click Start → Con-
trol Panel → Administrative Tools; Double-click Services; A window ’Services’
will appear: Select the service: bootparam; Right-mouse-click on this service
and select Stop).

4.1 TOPSPIN NT Toolkit CD

The Bruker BioSpin TOPSPIN NT Toolkit-CD (for Windows XP) contains the Hum-
mingbird NFS Server 7.1.

The version of the NFS Server for Windows XP that is currently supported is 7.1.
If this is already installed, you can skip this chapter.

The NFS Server is available on the TOPSPIN NT Toolkit-CD that can be ordered
from Bruker BioSpin, part number H9437W0.

Please contact your sales representative for the price of the NFS Server. Alterna-

tively, you can contact NFS manufacturer Hummingbird 1 for information on how

1.  See www.hummingbird.com

http://www.hummingbird.com
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to obtain NFS 7.1 or how to upgrade from an earlier version.

4.2 Preparing for the TOPSPIN NT Toolkit installation

DONE INDEX

The NFS Server 7.1 (!) is required if your PC controls a spectrometer; it makes the
DISKLESS package available for the CCU.

Before you install the NFS Server: 

• Click Start → All Programs → Accessories → Command Prompt 

• Enter ipconfig /all

and check if the network is installed. If it is not, install the network as described in
chapter 13.

4.3 Installing NFS Server

IMPORTANT: 

• before installing NFS you must configure TCP/IP (see chapter 13.1)

• If your installation fails with following error message:

CreatThisService::Createservice:Error # [997]

Your network-adapter has no link to the network. Establish a link to the net-
work or install the

NWlink IPX/SPX/NetBIOS Compatible Transport Protocol:

a) Click Start → Control Panel → Network Connections → Right-click
Local Area Connection xxx

b) Click Properties → Install... → Protocol → Add

c) The Select Network Protocol-menu will appear after some sec-
onds. → Click NWlink ... → OK

d) After some seconds the Properties-menu will reappear: → Click Close

If another version is installed, remove it according to chapter 10.2, reboot the com-
puter and install a newer version. 

If you have the Hummingbird NFS Maestro CD be aware of the following. An
Evaluation CD, will only work for a limited amount of time. Please check if your

!
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delivery contains another NFS Maestro CD. If it does, this is probably the full ver-
sion. If it does not, you probably ordered an Evaluation CD. Please use the full ver-
sion if you have one! Now insert the NFS Maestro CD.
DONEINDEX4.3.1 Installing NFS 7.1 from the Bruker BioSpin TOPSPIN NT Toolkit-CD

1. Log in as a Local Administrator

2. Insert the CDROM TOPSPIN NT Toolkit

3. Double-click the icon My Computer

4. A window ’My Computer’ will appear:

• Double-click the CDROM icon

5. A window showing the contents of the CDROM will appear: 

• Double-click the icon setupNFS or setupNFS.cmd

6. A window ’Hummingbird Master Setup’ will appear: 

• Click Install NFS Maestro Server

This window will change to the subtitle ’Installation Type’

• Click Personal Installation

• A window ’Chose Setup Language’ will appear:

• Choose English (USA) (this description is written for the English one)
• Click OK

• A window ’Hummingbird Setup Wizard’ will appear and display several
progress bars. Finally it shows:

The Hummingbird Setup Wizard will install Hummingbird NFS Maestro
Server on your computer ...

• Click Next
• A window ’License Agreement’ will appear:

• Click I accept ... → Click Next
• A window ’Customer Information’ will appear. Insert the appropriate

information or leave the information unchanged (it is important that this
application will be installed for anyone who uses this computer):

• Click Next
• A window ’Destination Folder’ will appear:

• Click Next
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• A window ’Setup Type’ will appear:

• Click Typical → Click Next
• A window ’Ready to Install the Program’ will appear:
DONE INDEX• Click Install
• A window ’Installing Hummingbird NFS Maestro Server’ will appear

showing a progress bar

• A window ’Hummingbird Setup Wizard Completed’ will appear:

• Click Finish
• Back in the window ’Hummingbird Master Setup’: 

• Click Back → Click Exit
7. Remove the CDROM

The certificate ’Proof of license’ is delivered with each TOPSPIN NT Toolkit CD. It
proves that you have an official copy of the Hummingbird NFS Server. Please
keep this certificate!

4.4 Configuring the NFS Server for spectrometer control

Before you can configure the NFS Server 1 (described in chapter 6.6) you must
first install packages on the TOPSPIN DVD, particularly the DISKLESS package
(see chapter 6.4).

4.5 Firewall configuration for the NFS Server

If you have enabled the firewall under Windows XP SP2, you have to configure
the firewall for the NFS Server. This can be done automatically during the
TOPSPIN installation or later while executing the setfirewall.cmd (<topspin-
home>\prog\bin\Utilities\Miscellaneous\setfirewal.cmd) (see chapter 8.9).

Note: If you have installed the NFS Server after the TOPSPIN installation, you have
to configure the firewall again!

1.  The NFS Server is only required for AVANCE and AVANCE-II spectrometers.
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Installing a PDF viewer.

5.1 When do I need a PDF viewer?

A PDF viewer is required for displaying the TOPSPIN Online Help and for parts of
the NMR-GUIDE. A PDF viewer is not installed automatically as a part of TOPSPIN.
Bruker BioSpin recommends to use the Adobe Acrobat Reader. The Acrobat
Reader is available from Adobe as a download:

http://www.adobe.com

The English version of the Acrobat Reader is available as a download under the
following address:

http://www.adobe.com/products/acrobat/readstep2.html

http://www.adobe.com/products/acrobat/readstep2.html
http://www.adobe.com
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Installing TOPSPIN

6.1 Preparing for the TOPSPIN installation 

Before you install TOPSPIN:

1. TOPSPIN can only be installed on a NTFS filesystem, not on a FAT file sys-
tem. However, you can convert FAT to NTFS as described in chapter 12.1.2.

2. Before you proceed, make sure you are logged in as a Local Administrator.
If you are not sure about this, press Ctrl-Alt-Del (just as for a logon). The
popup screen tells you the current user-id. If you are indeed logged in as a
Local Administrator, click Cancel. Otherwise click logoff and then log on
as an Administrator.

3. Click Start → All Programs → Accessories → Command Prompt

enter: ipconfig /all

and check if the local network is configured. If it is not, configure the net-
work as described in chapter 13.

If your PC controls a spectrometer: 

1. Click Start → All Programs

and check if you see the entry NFS Maestro. If it does not appear, install NFS
Maestro Server as described in chapter 4.3. 1
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2. Click Start → All Programs → Accessories → Command Prompt

enter: ipconfig /all
DONE INDEX
and check if the second Ethernet adapter is configured. If it is not, configure it
as described in chapter 13. 

6.2 NMR SUPERUSER and NMR ADMINSTRATION 
PASSWORD

TOPSPIN offers password check for the configuration tools of TOPSPIN. During the
TOPSPIN installation, you are prompted to define:

1. The username for the so called NMR SUPERUSER. If you choose an NMR
SUPERUSER other than Administrator make sure that this user exists. The
NMR SUPERUSER can be Administrator (this is the default) or any other user
(can also be a Domain account). We recommend installing a special user for
this purpose, e.g. a user named nmrsu (see chapter 9.1). This user does not need
any special permissions under Windows; standard access permissions are suffi-
cient.

• After the installation, the NMR SUPERUSER is the owner of all TOPSPIN

program files. Logging in as this user allows you to remove these files,
change file permissions etc. The name of the NMR SUPERUSER will be
stored in the file: <TOPSPINHOME>/conf/nmrsuperuser

2. the NMR ADMINISTRATION PASSWORD to be used for TOPSPIN configura-
tion commands. This password can be freely chosen and is not connected to any
user. It is asked for by TOPSPIN commands like cf, expinstall etc. The
encrypted NMR ADMINISTRATION PASSWORD is stored in the file:

<TOPSPINHOME>/conf/nmradminpassword

Note: The NMR SUPERUSER login password and the NMR ADMINISTRATION
PASSWORD have different purposes and are totally independent. Changing one of
them does not affect the other.

With the information about the NMR ADMINISTRATION PASSWORD and
NMR SUPERUSER TOPSPIN is ready to be configured. The NMR ADMINIS-
TRATION PASSWORD will be asked for every time a configuration type com-

1.  The NFS Server is only required for AVANCE and AVANCE-II spectrometers.

!
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mand is entered. If this password is typed in correctly, the command will be
executed independent of which user is logged in the operating system. As a result
all newly created configuration files will be owned by the user that was logged in
DONEINDEX
at the time the configuration command was executed. Any other user can modify
the configuration during his login session, just by knowing the correct NMR
ADMINISTRATION PASSWORD. This is possible because all configuration files
are read- and writeable for everybody, but TOPSPIN will not write them without the
correct NMR ADMINISTRATION PASSWORD!

TOPSPIN also offers a so-called Security Mode. With this feature all configuration
files are only read- and writeable for the NMR SUPERUSER.

6.2.1 How to change the NMR ADMINSTRATION PASSWORD

The installnmr script can be used to change the NMR ADMINISTRATION PASS-
WORD and the NMR SUPERUSER. If it is called with the option ’-secure’, it
changes the permissions in a way, that only the NMR SUPERUSER can execute
the configuration commands and the resulting files are readable and writable only
for him, all other users have read-only permissions.

To change the NMR ADMINISTRATION PASSWORD, you have to:

1. Login as NMR Superuser or Administrator 

2. Double click on the icon Bruker Utilities on the desktop. A window Bruker
Utilities will appear

3. Double click on the command prompt 

Note: It is not possible to use a ’normal’ windows command prompt, because in
this ’special’ command prompt of ’Bruker Utilities’ there are several parameters
and path entries defined.

4. Type in: 

perl\bin\perl prog\bin\installnmr <TOPSPINHOME> <NMRSUPERUSER>

If you installed TOPSPIN in the default directory and you want to use the user
’nmrsu’ as NMR SUPERUSER, you have to type in

perl\bin\perl prog\bin\installnmr C:\Bruker\TopSpin nmrsu

5. Enter the old password and new password as requested.
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6.2.2 How to define a new NMR ADMINSTRATION PASSWORD

To define a new NMR ADMINISTRATION PASSWORD, for example because 
you have forgotten it, you have to:
DONE INDEX1. Login as the Administrator

2. Open a Windows Command Prompt

3. Delete the file <x>\conf\nmradminpassword

4. Enter:

perl\bin\perl prog\bin\installnmr <TOPSPINHOME> <NMRSUPERUSER>

5. Enter new password as requested.

6.3 Packages on the TOPSPIN DVD

1. TOPSPIN: Acquisition and processing software

• TOPSPIN PLOT EDITOR: Object oriented WYSIWYG plot editor 1

• GNU TOOLS: System tools required by TOPSPIN 1

2. ICON-NMR: Icon-driven interface for Routine Spectroscopy and Automation

3. NMR-SIM: Program for numerical simulation of NMR experiments

4. NMR-GLP: Program for ’Good Laboratory Practice’ tests (requires separate
license) 

5. NMR-GUIDE: Web-browser based teaching and training program

6. NMR-DATA: example data sets

7. DISKLESS: Spectrometer CCU operating system

8. AURELIA-AMIX-Viewer: multiple object viewer (requires a separate license)

9. Auremol: nD spectrum analysis (requires separate license)

10. Perch: Shift prediction and Modeling Tools (requires separate license)

11. SBASE: Spectra base for AMIX (requires separate license)

12. FLEXLM: License manager required for starting TOPSPIN programs. 

1.  automatically installed as part of the TOPSPIN package
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6.4 Installing TOPSPIN

This chapter describes the installation of the TOPSPIN as a local Administrator,
DONEINDEX
using a local NMR Superuser account. Chapter 13.6 describes additional steps
which must be taken if you want to install the TOPSPIN in a Domain.

The main decision you have to make during installation is where do you want to
install the new TopSpin version. If you have a previous NMR SUITE or TOPSPIN

installation on this PC available, you can either:

• install the new version in parallel to the previous one
(e.g. old in C:\Bruker\TopSpin1.3 and new in
C:\Bruker\TopSpin2.1)

or

• install the new version in the same directory as the previous one
(e.g. old in C:\Bruker\TopSpin and new in C:\Bruker\TopSpin)

The installation in parallel has the advantage, that the previous version remains
unchanged. After a parallel installation you can start working with the new version
and if you want to go back to the previous version for whatever reasons you can
just start and reuse it.

The installation of TOPSPIN 2.1 offers an automatic import of your individual con-
figuration of a previous version, so that there is no advantage to install the new
version in the same directory as the old one.

1. Log in as a Local Administrator

2. Close ALL WINDOWS on the desktop

3. Insert the DVD ’TOPSPIN 2.1’.

4. Start of the installation

• If the automatic start of the DVD is enabled, the window described in the
next step appears automatically, go to step 5

• If this window of the next step does not appear automatically, autorun is
probably switched off (see chapter 10.3) or open the Windows Explorer, go
to the DVD device and double-click install.cmd 1.

5. The windows Welcome to the TOPSPIN Setup will appear: → Click Next

1.  Please note that there is also a file called ‘install’ on the DVD. This file is the installation 
script for Linux, under Windows you have to click on the file ‘install.cmd’

!



46 Installing TOPSPIN

INDEX
DONE INDEX

6. A window Release Letter TOPSPIN will appear: 

a) Please read the NMR Release letter! You can find therein all information
about news and bug fixes of the current version.

b) When you have finished reading the Release Letter, close the Release Letter
by clicking the X button in the upper right corner.



Installing TOPSPIN 47

INDEX

7. A window Choose Destination Location will appear:
DONEINDEX

• Select the destination directory for TOPSPIN. 

a) Accept the default destination

b)  or browse to another destination.
Enter an installation path which does not exists so far, e. g.
C:\Bruker\topspin2.1

• or browse to another existing installation path.
• Click OK

• Click Next

8. A window Select the setup type will appear:

a) Select the setup type. Do one of the following:

• Select Data Processing, Acquisition and Automation if you want to use
TOPSPIN for spectrometer control. This will install Diskless automati-
cally.
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• Select Data Processing if you want to use TOPSPIN for data processing.

• Customized setup (allows components selection) if you want to install
selected programs only. If you have selected the following window will
DONE INDEX
appear:

Select the packages which you want to install (note that DISKLESS is only
required if your PC controls a spectrometer or you want to configure it e.g.
like this:

• TOPSPIN: Acquisition and Processing Modules
• ICON-NMR: Automation Module
• DISKLESS: CCU operating system
• NMR-SIM: Experiment Simulator
• NMR-GUIDE: NMR Guide and Encyclopedia
• NMR-Data: NMR Example Data Sets
• AURELIA-AMIX-Viewer: Viewer of 2D/3D/4D NMR data (requires

separate license)
• NMR-GLP: Spectrometer Validation Tool (requires separate license)
• Auremol: nD Spektrum Analysis Tool (requires separate license)
• Perch: Shift prediction & Modeling (requires separate license)

b) Click Next

9. A window ’Question’ will appear if Windows XP Service Pack 2 is installed
and enabled on your system. If you click Yes on the installation configure the
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firewall 1 for you.
DONEINDEX

10. A window ’Select Components’ will appear. You can either import no spec-
trometer configuration, or browse for a spectrometer configuration or select one

of the configurations you get offered within this window 2.

The configurations that are shown in this picture are just an example. On your
PC this list could look different.

• Click Next

1.  The firewall must be configured to enable spectrometer access.
2.  The installation process will offer all configurations which are available in the TOPSPIN / 

XWIN-NMR installation that are defined in the registry.
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11. A window ’Set NMR Super User’ will appear:
DONE INDEX

a) Do one of the following: 

• Accept the default NMR Superuser (Administrator) or 

• Enter a special user for this purpose, e.g. named nmrsu or 

• Enter any other user

Under Windows the username must be the name of an existing user. If you
choose an NMR Superuser other than Administrator, and this user does not
exist yet:

• Press the keys CTRL+ESC (to open the Start menu)
• Install a user as described in chapter 9.

b) Click Next

12. A window ’Password Input’ will appear 1 (for more details see chapter 6.2):

a) Do one of the following: 

1.  Certain commands like cf and expinstall ask for the NMR ADMINISTRATION PASS-
WORD.
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• Type in the NMR ADMINISTRATION PASSWORD

• Re-enter in the NMR ADMINISTRATION PASSWORD
DONEINDEX
b) Click Next → The installation of TOPSPIN will start now.

• destination directory

c) Click Next

13.  A window ’Setup is complete’ will appear: 

You will be asked if you want to restart the computer: 

a) Click Yes I want to restart my computer now

b) Click Finish (to reboot the computer)

14. After the PC has booted up, press the reset button on the CCU or turn it on with
the key if it was switched off. Don’t forget to execute ’cf’ and ’expinstall’!

The following information is for the Customized setup:

• It is strongly recommended to accept the default path for the flexLM installa-
tion: ’C:\flexlm’! If you choose a user defined path, it may cause some
problems with other applications using the FlexLM.

6.5 Installing TOPSPIN patches

Bruker BioSpin recommends installing the latest TOPSPIN patches available.

TOPSPIN patches are parts of TOPSPIN which contain bug fixes. They are available
on the Bruker www pages. We recommend to install new patches whenever the
patchlevel on your system is older than the one on the WWW. 

Perform the following steps: 

!
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1. Click on the icon Bruker Utilities on the desktop.

2. Click Miscellaneous → Patchlevel
This will show you the patchlevel on your system. 
DONE INDEXor

3. In TopSpin click Help → Version Info 

Now check if the Patchlevel on the Bruker BioSpin web server is higher than on
your system.

Download from WWW server:

1. Log in on a computer which is connected to the internet

2. Open your web browser

3. Go to http://www.bruker-biospin.com/software_nmr.html
or

4. Go to http://www.bruker-biospin.com

5. Click on Service&Support → NMR → Software Downloads and select the
operating system and then the package you want to download

6.6 Configuring NFS Server

If your PC is controlling a spectrometer, you must configure NFS after the installa-
tion of the DISKLESS package (part of TOPSPIN). This configuration requires that
Hummingbird NFS Server is installed (see chapter 4.3). Once this is installed, you
can mount any Windows directory from any UNIX host in your network (see chap-
ter 13.4.4). Basically this chapter finishes the installation started in chapter 4.3.

Note: The NFS Server is only required for Bruker AVANCE and Bruker AVANCE-
II spectrometers. Bruker AVANCE-III spectrometers do not need the NFS Server.

For this configuration it is very important to turn the Simple File Sharing off: 

1. Double-click My Computer on the desktop. 

2. Click on Tools, select Folder Options. 

3. Click the View tab, and then click to select the Use Simple File Sharing
(recommended) check box to enable Simple File Sharing (click to clear this
check box to disable this feature). 

!!!

http://www.bruker-biospin.com
http://www.bruker-biospin.com/software_nmr.html
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1. Click Start → All Programs → Accessories → Windows Explorer

2. Select the directory <TOPSPINHOME>\Diskless and click with right mouse
button.
DONEINDEX3. Select in the upcoming window the entry Properties

4. Choose the folder Security

5. You should see Full Control permissions for Everyone. Correct this if neces-
sary in the following way:

• Click Add

• A window Select Users, Computers, or Groups will pop up

• choose the entry Everyone in the list Names

• Click Add

• Click OK

• Enable in the ’Permissions’ column ’Allow’ Full Control

• Click OK

• In most cases especially if your PC controls a spectrometer some error mes-
sages could appear. A question if you really want do change the permissions
in all the subdirectories of Diskless may also occur. You can click OK in all
these windows 

6.6.1 Configuring NFS Server 7.1

If you have NFS Server 7.1, proceed as follows:

1. Create the user

• ’diskless_user_sys’ (with ’account is disabled’) 1

and the groups (with no members)

• ’diskless_group_root’

• ’diskless_group_other’

• ’diskless_group_sys’

1.  Creation and configuration of the necessary user and groups are most convenient if it is done 
in the user management tool of the management console and not in the user management of 
the control panel. For starting the management console click right on ’My computer’ and 
choose ’manage’. A new window appears where you can choose ’local users and groups’.
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2. Click Start → Control Panel

3. The window ’Control Panel’ will appear:
DONE INDEX
• Double-click the icon Hummingbird NFS Server

4. A window ’NFS Maestro Server’ will appear:

a) Click the Exported File Systems tab

• In the field Exported File System: browse for the location of the DISK-
LESS package (e.g.: C:\Bruker\Diskless\clients\spect)

Important: the Uppercase letters in this path are necessary!

• Select the Allow Access for Root User

• Select Restrict Access to Hosts, enter spect in the field below and click
Add → the name spect will appear in the list ’Restricted Access to Hosts’

• Click Insert → ’spect’ appears in ’Lists of Exported File Systems’



Installing TOPSPIN 55

INDEX

b) Click the Name Mapping tab
DONEINDEX

• Click the arrow to the right of the field Load Names from and select the
local hostname, e.g. \\MYHOST

• Click Reload Names

• Adding a User mapping

• In the field User Name select the user Administrator
• In the field below, that is called ’UID’ type in ’0’ 
• Click Insert

• In the field User Name select diskless_user_sys. 
• In the field below, that is called ’UID’ type in ’2’ 
• Click Insert

• Adding a Group mapping

• Select the Group Name using the arrow button in the field below it,
type in the GID and click Insert

• Map the group diskless_group_root as group with GID 0
• Map the group diskless_group_other as group with GID 1
• Map the group diskless_group_sys as group with GID 3
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c) Click the General tab
DONE INDEX

• Click Server Status

d) A window ’NFS Maestro Server Status’ will appear:

• Click Reload Exports
• Click OK 

5. In the window ’NFS Maestro Server Configuration’ → Click OK

6. If a message about the owner and permissions of spect appears:
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• Click Yes

• A window ’Permissions’ will appear:
DONEINDEX
• Select User: ’Administrator’ and enable Read, Write and Execute per-

missions for this user

• Select Group: ’diskless_group_root’ and enable Read, Write and Execute
permissions for this group

• Be sure that also ’other’ has Read, Write and Execute permissions 

• Click Recursive → Click OK

7. Close the window ’Control Panel’ by clicking the X button.

6.7 Adding a user to the group NmrUser

Every user who wants to run TOPSPIN must be member of the group NmrUser.
Adding users to this group is described in chapter 9.1.3.

6.8 Check if the TOPSPIN installation is correct

Double click the TOPSPIN-icon

If you have an valid license you will get this screen:

and TOPSPIN will start.

Unless you already have a license you will get e.g. this screen (for further details

!
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see chapter 7.2):
DONE INDEX

6.9 Compiling AU programs

TOPSPIN only needs a compiler for the compilation of AU programs. If you do not
use AU programs, you do not need a compiler!

TOPSPIN is delivered with the free GNU gcc compiler 1.

It is installed automatically during installation of TOPSPIN.

6.9.1 Problems with the default GNU compiler

Generally, the GNU compiler works properly with TOPSPIN. However, if you have 
a second copy of cygwin1.dll, apart from the one delivered with TOPSPIN, you 
might run into problems. If this happens you will get the following error message:

You have multiple copies of cygwin1.dll on your system.

Search for cygwin1.dll using the Windows Start -> Find/Search facility and de-
lete all but the most recent version. The most recent version *should* reside in 
x:\cygwin\bin, where 'x' is the drive on which you have installed the cygwin dis-
tribution

If you have a problem like this you can remove the second copy of

1.  If you like to work with the ’vi’ in Bruker’s GNU shell, it is necessary to start it with the com-
mand ’vim’ in this version of the GNU package.
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cygwin1.dll (not the one delivered with TOPSPIN).

6.10 The usage of the NMR-GUIDE
DONEINDEX
NMR-GUIDE 4.1 that comes with TOPSPIN 2.1 uses an own web server and the TOP-
SPIN internal java package. Therefore it is not necessary anymore to have these
packages installed/configured separately!

6.10.1 Requirements for NMR Guide 4.1

The using of NMR-GUIDE 4.1 requires the installation of TOPSPIN 2.1. Also be
sure that the following components are installed:

1. Web browser Microsoft Internet Explorer

2. PDF viewer

NMR-GUIDE offers among other things a lot of PDF documents. To display
these documents it is necessary to install the acrobat reader. For an installation
description see chapter 5.1

3. NMR-GUIDE license (contact license@bruker.de for a three month demo license
or order a official license from your local Bruker representative). Note that the
NMR-GUIDE license is already part of a full or demo TOPSPIN 2.1 license.

The Microsoft Internet Explorer is an official part of the operating system Micro-
soft Windows XP. The WWW browser gets documents from the locally installed
WWW server. The client - server communication is established over a network
socket connection, but the communication partners only use the localhost TCP/IP
host identifier. These pages are shown in the right-hand side window of the
browser.

The WWW browser also gets dynamically created pages from the localhost. These
workstation specific pages are coming from a gserver. This is a platform independ-
ent Java web server written by Bruker BioSpin and acts as a daemon running on
the locally installed JAVA virtual machine. The gserver is included in the NMR
Guide&Encyclopedia package. The table of contents is generated dynamically and
displayed in the left-hand side window of the browser.

TOPSPIN commands can be invoked from the WWW browser. This process is also
managed by the gserver. The gserver is an essential component of the NMR
Guide&Encyclopedia and requires an NMR-GUIDE license.
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6.10.2 Java Requirements for NMR-GUIDE 4.1

For using NMR-GUIDE 4.1 that comes with the TOPSPIN 2.1 version it is not neces-
sary to install/configure a special Java package. NMR-GUIDE uses the TOPSPIN
DONE INDEXinternal Java package that is automatically installed and configured during installa-
tion of TopSpin.

6.10.3 Working with the NMR-GUIDE

In order to work with the NMR-GUIDE, the following procedure must be followed.

• Start up of the NMR-GUIDE

1. Start TOPSPIN and enter the command: ghelp

2. or enter the command (this allows to start a search within NMR-GUIDE:
 help

3. or select from the Help pull-down menu of TOPSPIN the entry:
NMR-GUIDE

Your standard web browser will automatically starts and shows the page:

6.10.4 Configuration of Internet Explorer for the NMR-GUIDE

1. Click Start → All Programs → Internet Explorer

2. A window Microsoft Internet Explorer will appear

3. Click on Tools → Internet Options → Advanced
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4. Ensure that the following Settings are enabled:

• Java console enabled (requires restart)
DONEINDEX
• Java logging enabled

• JIT compiler for virtual machine enabled (requires restart)

5. Restart your computer
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The TOPSPIN license

7.1 Questions and answers about the TOPSPIN license 

1. Which programs need a license? 

TOPSPIN, TOPSPIN PLOT EDITOR, NMR-SIM and NMR-GUIDE need a license.
However, if you order a license for TOPSPIN, you automatically get a license for
all four programs.

If you do not have a license for TOPSPIN, it will start up in an emergency mode
if your PC is connected to a spectrometer. However, NMR-SIM and NMR-GUIDE

will not run without a valid license.

ICON-NMR is always used in connection with TOPSPIN and does not need an in-
dividual license.

 GLP, AMIX, AURELIA, Auremol, MAXENT, PARAVISION and Perch do need
a license which must be ordered for each program separately. 

2. Which license types are available and what programs may be run with each?

There are six different license types, details of each are given in the following
table. For more information please refer to the Bruker license order form in the
help menu of TOPSPIN or on the web server:

https://www.bruker-biospin.com/nmr_license_requests.html

https://www.bruker-biospin.com/nmr_license_requests.html
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or contact your local Bruker BioSpin representative.

 

DONE INDEX

3. What kind of licenses do I need?

If you want to use TOPSPIN 2.x you need a FEATURE line ’TOPSPIN2’ in your
license.dat file. If you have ’TOPSPIN1’ you can only start TOPSPIN 1.x

License type Contents

Full

Acquisition, Processing, Automation (ICON-NMR),
Plotting, Experiment Simulation and NMR-GUIDE

license period: 15 years

no restrictions

Additional

Acquisition, Processing, Automation (ICON-NMR),
Plotting, Experiment Simulation and NMR-GUIDE

license period: 15 years

one Full license has to be available

Demo

Acquisition, Processing, Automation (ICON-NMR),
Plotting, Simulation and NMR-GUIDE

license period: 3 months
Node locked, uncounted, free of charge

Processing-Only
Processing and Plotting
license period: 15 years

no Acquisition, no NMR-SIM, no NMR-GUIDE

Presenter

Viewing and Plotting

license period: 15 years
no Processing, no NMR-SIM, no NMR-GUIDE

Teaching

NMR-SIM and restricted Processing and Plotting
license period: 15 years

TopSpin can only process datasets that are older than 4 weeks or 
datasets created by NMR-SIM. One TopSpin-plot session (without port-

folio editor) can be started, Node locked, count 1.

Developer

Special license for extending TOPSPIN with own functionalities.
Allows viewing of data.
license period: unlimited

no Processing, no Plotting, no NMR-SIM, no NMR-GUIDE, free of charge
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and with ’XWINNMR3’ you can only start XWIN-NMR 3.x.

If more than one license is available, as many copies of the program as are cov-
ered by the license can be started simultaneously.
DONEINDEX4. Which licensing program is used for TOPSPIN? 

The Flexlm license manager is used and is delivered on the TOPSPIN DVD. The
Flexlm package occupies about 3 MByte of disk space. It contains the ’lmgr’ li-
cense manager, the ’lmutil’ program, Help files and example license.dat
file. 

5. What are the requirements for the Flexlm to function:

• your PC must have an Ethernet card

• the network (TCP/IP) must be installed

• the network Service ’NetBIOS Interface’ must be installed 

6. What is a Floating license? 

Floating licenses are licenses that are available for more than one computer in a
network. Floating licenses are issued based on the Host-ID of one particular
computer. This computer becomes the "license server". All computers that can
communicate with this "license server" computer can use the licenses managed
by this computer. For this to work, the same license file must be installed on all
participating computers, including the "license server". The Flexlm license man-
ager software must only run on the "license server" computer.

A Floating license can have just one license for a program like TOPSPIN. In such
a case, the respective program can be started once on one computer in the net-
work. If more than one license is available, as many copies of the program as are
covered by the license can be started simultaneously. For example, if you have
a license file with 5 licenses for TOPSPIN, TOPSPIN can be started 5 times from
any 5 computers in the network.

The number of licenses is stated in the FEATURE for the respective program.

7. What is the difference between 1-Server / 3-Server Licenses?

Floating licenses can be ordered as 1-server or 3-server licenses. In a 1-server
license you have only one license server, and in a 3-server license there are three
license servers defined in the license file.

• The advantage of a 1-server license is that it is only necessary to have one
computer active at a time to make the license available.
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• The advantage of a 3-server license is that any of the three license servers
can be inactive and the license management is then done by the remaining
two servers.
DONE INDEX
• One requirement for the three license servers is that all of them have TCP/IP

active.

• The operating system on the three computers can be the same or can be dif-
ferent (Linux, Windows).

8. What is a Node Locked license? 

A node-locked license allows you to start the respective program only on the
computer with the Host-ID for which that license was generated. Typically, this
license form is used for Demo and Teaching licenses. No other computer can use
the license in the way described above for floating licenses.

9. How do I know if my license is Floating or Node Locked?

You can recognize this from the syntax of the license FEATURES in the li-
cense.dat file:

on PC: 

c:\flexlm\bruker\licenses/license.dat

on Linux:

/usr/local/flexlm/Bruker/licenses/license.dat 

If the entry ’HOSTID=’ appears after the encrypted password, the license is
Node locked and can only be used on the local PC.

FEATURE TOPSPIN2 bruker_ls 0.0 18-oct-2020 3 2B9E60C19A3C2D4F0DFC \
HOSTID=001125323f2b vendor_info=" for hostid(s) : 001125323f2b" ISSUER=...

→ Node locked license for three parallel sessions of TOPSPIN that can be
started on the local PC 

FEATURE TOPSPIN2 bruker_ls 0.0 18-oct-2020 3 2B9E60C19A3C2D4F0DFC \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=... 

→ Floating license for three parallel sessions of TOPSPIN that can be start-
ed on every PC in the local network

10. If I have a Floating license and I have a dual-boot PC (e.g Windows XP and
Linux), can I use the license on both operating systems?

Yes, the license is based on the physical address of the Ethernet card and not on
the operating system. Copy the license file license.dat to:
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Windows:

c:\flexlm\Bruker\licenses\license.dat
DONEINDEX
Linux:

/usr/local/flexlm/Bruker/licenses/license.dat

11. How can I determine the hostid of my PC?

See chapter 7.2.1.

12. How do I install a license (full or demo) on my PC?

See chapter 7.2. 

13. Does a Demo license require SERVER/DAEMON lines in license.dat?

No, a Demo license is Node Locked and therefore only requires FEATURE lines.
If SERVER and/or DAEMON lines exist, they are ignored.

14. I have a Floating license. Must the file license.dat be identical on all
hosts, server and clients? 

Yes, you can install license.dat on the server and then copy it to all clients.

15. Must the Flexlm license manager run on all hosts in the network? 

No, it only needs to run on the license server. If the license manager also runs on
a license client, this is simply ignored.

16. Must the Flexlm license manager run on a host with a Demo license? 

No, it only needs to run on the server for Counted licenses.

17. What can I do if TOPSPIN does not start after I installed the license?

See chapter 15 .

18. How is it possible that TOPSPIN starts even though I do not have a license? 

If you do not have a license for TOPSPIN, it will start up in an emergency mode
if your PC is connected to a spectrometer. Also one TOPSPIN PLOT EDITOR ses-
sion (without portfolio editor) can be started from within TOPSPIN. However,
NMR-SIM and NMR-GUIDE will not run without a valid license.

19. What can I do if TOPSPIN cannot find the license.dat file? 

a) Open the Windows Explorer and go to <Flexlm_Home>\Bruker\ →
Double-click lmtools.exe
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A window ’LMTOOLS’ appears.
DONE INDEX

b) Click the Start/Stop/Reread tab.

c) Click Stop Server → Click Start Server → Click ReRead License file →
Click OK

d) Close the window ’LMTOOLS’ by clicking the X button.

20. What can I do if TOPSPIN cannot find the license server? 

Please try to restart the license server: 

a) Open the Management Console:
My Computer -> right click Manage

b) A window will appear:
Right click Bruker FLEXlm License Server -> right click Properties
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c) A window will appear:
If the Service status is ’Started’ click Stop -> wait and then click Start again
If the Service status is ’Stopped’ click Start
DONEINDEX7.2 Ordering and installing the TOPSPIN license

You can order a license from Bruker BioSpin Germany. Demo licenses are free of
charge.For licenses you must specify:

• the hostid of your PC (see chapter 7.2.1)

• the program for which you want to get a license, e.g. TOPSPIN

• the type of license (full, demo, processing-only, presentation or teaching)

• the number of licenses and your order number (not necessary for demo
license)

Licenses can be ordered from the Bruker BioSpin web pages:

https://www.bruker-biospin.com/nmr_license_requests.html

7.2.1How do I determine the correct hostid

The hostid is a 12-digit hexadecimal number. It is the physical address (also called
Mac address or Node address) of the Ethernet card. After installing TOPSPIN,
including the Flexlm license manager, you can determine the hostid in two ways:

• Start TOPSPIN; a command prompt will pop up, which will list the hostid, if a
correct licence is not yet installed. 

• Click the Bruker Utilities icon on the desktop, then click Miscellaneous →
get_hostid

• Open a Command Prompt and type in:
c:\flexlm\Bruker\lmutil lmhostid

Under Windows XP it is possible to get more than one hostid. Just select
one of them to order the license.

 Some hostid values may indicate problems:

a) If hostid ’2’ occurs: You may run Windows XP and your network-adapters
are disabled.
Click Start → Control Panel → Network Connections

https://www.bruker-biospin.de/NMR/nmrsoftw/licenses/index.html
https://www.bruker-biospin.com/nmr_license_requests.html
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Right-click all Local Area Connection xxx -items and there
click Enable (if it is visible)

b) If hostid ’0’ or ’ffffffff’ occurs: You may run Windows XP and your net-
DONE INDEX
work-adapter has no link to the network.

Establish an link to the network or install the

NWlink IPX/SPX/NetBIOS Compatible Transport Proto-
col:
Click Start → Control Panel → Network Connections
Right-click Local Area Connection xxx 

Click Properties → Install... → Protocol → Add
The Select Network Protocol-menu will appear after some seconds.
Click NWlink ... → OK
After some seconds the Properties-menu will reappear: Click Close
See also

C:\flexlm\Bruker\help\Index.htm

for FlexLM-related problems

7.2.2 Installing a Demo license

A Demo license can be installed as follows:

1. Log in as Administrator

2. Install the Flexlm license manager as described in chapter 6.4.

3. Open a Command Prompt and enter:

• cd /d c:\flexlm\Bruker\licenses

• notepad license.dat

enter the FEATURE lines, save and exit the file

You can also install the license file from the Explorer. We have chosen the Com-
mand Prompt because the Explorer might add the (perhaps hidden) extension
.txt to the file license.dat which makes it unusable (see chapter 16.1.3).

7.2.3 Installing a full license on a license server

The Flexlm license manager must always be installed and run as an Windows XP
service on the license server. It is delivered on the TOPSPIN DVD and can be
installed as described in chapter 6.4. The Flexlm is automatically installed as a
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Windows XP Service which is then automatically started.

On the license server, the file license.dat must contain a SERVER line, a DAE-
MON line and FEATURE lines. An example would be:
DONEINDEXSERVER petzi 001125323f2b 1700
DAEMON bruker_ls c:\flexlm\Bruker\bruker_ls.exe

FEATURE TOPSPIN2 bruker_ls 0.0 18-oct-2020 3 2B9E60C19A3C2D4F0DFC \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE TOPSPIN_1D bruker_ls 0.0 18-oct-2020 3 2B5E00712DB1321F2DDE \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE TOPSPIN_2D bruker_ls 0.0 18-oct-2020 3 6B7E009107D129E4DA95 \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE XWINPLOT bruker_ls 0.0 18-oct-2020 3 9B5E909100892E5F8A76 \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE TOPSPIN_ACQU bruker_ls 0.0 18-oct-2020 3 EBFE503139CA9BE6A280 \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE NMRSIM bruker_ls 0.0 18-oct-2020 3 ABFEA0F14EAFD5A666EC \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE NMRCHECK bruker_ls 0.0 18-oct-2020 3 7B5ED001633AAAB4D12F \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed
FEATURE NMRGUIDE bruker_ls 0.0 18-oct-2020 3 7B7E30D13BDB911F3533 \
vendor_info=" for hostid(s) : 001125323f2b" ISSUER=0002b39766ed

where petzi is the hostname and 001125323f2b the hostid of the computer. Note
that the second part of the FEATURE lines, the vendor_info, does not necessarily
exist. In that case a FEATURE line would look like: 

FEATURE TOPSPIN2 bruker_ls 0.0 18-oct-2020 3 2B9E60C19A3C2D4F0DFC""

To inform Flexlm about the new license proceed as follows:

1. Open the Windows Explorer and go to <Flexlm_Home>\Bruker\ →
Double-click lmtools.exe

2. A window ’LMTOOLS’ appears. Click the Start/Stop/Reread tab → Click
Stop Server → Click Start Server → Click ReRead License file → Click OK

3. Close the window ’LMTOOLS’ by clicking the X button.

7.2.4 Installing a full license on a license client

On a license client, license can be installed in two different ways, as described for
a Demo license chapter 7.2.2. The only difference is that you do not have to setup
a new file license.dat. You can just copy it from the license server which can
be another PC (see question 10 in chapter 7.1). 



72 The TOPSPIN license

INDEX

7.2.5 Modifying the license file

To inform Flexlm about the new license proceed as follows:
DONE INDEX
1. Open the Windows Explorer and go to <Flexlm_Home>\Bruker\ →

Double-click lmtools.exe

2. A window ’LMTOOLS’ appears. Click the Start/Stop/Reread tab → Click
Stop Server → Click Start Server → Click ReRead License file → Click OK

3. Close the window ’LMTOOLS’ by clicking the X button.

7.2.6 Further information

For more information on the Flexlm license manager: 

Click Start → run enter c:\flexlm\Bruker\help\index.htm click OK

If TOPSPIN does not start after installing the license, please check chapter 15.
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Configuration of TOPSPIN

The idea of this chapter is to give you some guidelines to full spectrometer or
workstation configuration. We do not discuss the commands in detail here. For a
full description refer to the TOPSPIN manual.

8.1 Configuring TOPSPIN

There are two ways to start TOPSPIN:

1. Click the icon TOPSPIN on the desktop

2. Click Start → All Programs → Bruker TOPSPIN → TOPSPIN<vers.>

After the first startup of TOPSPIN a window ’License’ will appear:
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a) Please read the License Agreement for TOPSPIN! 

b) When you have finished reading the License Agreement for TOPSPIN and
you can confirm the agreement click on I accept.

After the window ’License’ a window ’configuration check’ appears: 

Please configure the software (depends on the hardware of your spectrometer). If
you do this, you are mainly in one of the four following situations:

• You have just installed the software in a new directory and the old spectrom-
eter configuration of the software is still known to the new version → go to
chapter 8.1.1

• You want to configure a only-processing-PC like your spectrometer-PC, so
you have the spectrometer configuration on another computer → go to chap-
ter 8.1.2

• You have to configure the software on a new hard disk without a backup of
the spectrometer configuration, so you have no configuration files anymore
→ go to chapter 8.1.4
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• You have a new spectrometer hardware component, so you have no configu-
ration file so far → go to chapter 8.1.5

If you would like to take over the configuration of an existing XWIN-NMR/TOPSPIN
DONEINDEXinto TOPSPIN 2.1 please check chapter 8.2.

8.1.1 If your PC controls a spectrometer:

1. Be sure that the spectrometer is booted (see chapter 6.6 and 15)

2. Open a dataset

• Type new and create a new dataset.

• You can also select a dataset (e.g. exam1d_1h) acquired with another TOP-
SPIN or XWIN-NMR version.

3. Enter cf (The command cf now configures the software according to the
hardware of your spectrometer): 

a) A window will appear:
Password request. Please enter the NMR administration
password

Type in the NMR ADMINISTRATION PASSWORD. Click OK.

b) A window will appear:.
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Most likely you will select an existing configuration and press "Edit" to
confirm this configuration.

c) A window will appear:
DONE INDEXThe selected configuration is displayed. Choose if would to configure it
as a spectrometer or datastation. Choose the type of your spectrometer e.g.
AVANCE → ENTER. Check or type in the 1H frequency of the magnet
e. g. 500.13 → ENTER. Use the debug mode only in a case of trouble-
shooting.

d) If this ’mod hconfserver’ information window appears:

• your spectrometer has not a BSMS rack with ECLB board: you may
ignore this warning → ENTER. Nevertheless please check the Con-
figuration summary (uxnmr.info file) if all units are listed.

• your spectrometer has a BSMS rack with ECLB board: please check if
the DHCP server is running. If you are able to start the DHCP server
→ ENTER. If you cannot start the Bruker DHCP service please see
chapter 15.6.
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e) A window will appear:
Check if the tty-numbers of the hardware components are set correctly.
DONEINDEX

• A window for additional configuration will appear:

• Choose the option if you need this security options.

Enable peak power check (POWCHK): (yes/no)

• If you have a sample changer, please select:

Should the Sample Changer control the Lift: (yes/no)

The answer depends on how the air flow is connected, normally you
will answer: yes

Delay between SX and next command [sec]? 

Type in the length of the delay e. g. 10 → ENTER
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f) The nuclei-table appear.
DONE INDEX

Check if the frequency of the nuclei are set correctly and click Save (If
in doubt click Restore then click Save)

g) A window ’Edit spectrometer configuration will appear:
Check if the preamplifier connections are set correctly and click Save..

h) The results of cf appears in a text window. Check this list carefully and
compare the result with an list from an earlier configuration (if available)
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click Print and store the paper output with your other spectrometer
documentation, then click Next..
DONEINDEX

If during ’cf’ an error message occurs that invites you to do a firmware 
update see chapter 8.6

After finishing cf window ’Additional configuration programs’ will appear
showing a list of configuration steps. .

Accept the default selection and click on the buttons (You will be asked for the
NMR ADMINISTRATION PASSWORD a couple of times):

• Continue with expinstall 

!
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a) Type in the NMR ADMINISTRATION PASSWORD and OK 
DONE INDEX

b) Click Next if you either have no modified Bruker BioSpin-Parameterfiles

AU-programs and Pulse-programs or if you have archive them in a different
directory. Your individual Parameterfiles, AU-programs and Pulse-pro-
grams that have different names to the original Bruker BioSpin files will not
be destroyed during the installation

c) In the window that appears → Check Installation for Spectrometer → Click
Next 
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d) In the window that appears → Check e.g. for high resolution NMR High
Resolution Systems → Click Next
DONEINDEX

e) In the dialog box that appears → Select the spectrometer configuration
name → Click Next

In the dialog box that appears → Check the items you want to install or,
accept the default selection → Click Next
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f) In the dialog box that appears → Select the default printer and plotter and
the desired paper format → Click Next 
DONE INDEX

g) In the window that appears → Enter the desired spectrometer frequency,
acquisition mode and pre-scan-delay or, accept the default values
→ Click Next 
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h) In the information box that appears → Check the configuration selection
and, if it is correct → Click Finish 
DONEINDEX

While expinstall will be executed you are able to continue with next configura-
tion program.

• Continue with edsolv

Check the list of lock solvents and click Save if it is correct → Click Close

• Continue with edhead
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Select the current probe, click the button Define as current probe → Click Exit

• A window ’Edit Spectrometer Parameter’ will appear:
DONE INDEX

Check if the connections between preamplifier and probe are set correctly →
click Save if it is correct → Click Close

• Continue with edprosol

Check the parameters for your favorite nuclei, change them and calculate them,
if necessary → Click Save to store to disk → Click Exit
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• Continue with edlock
DONEINDEX

Check the lock table values (field, lock phase, ...), change them. Click Save. To
close the window, click on the X in the right corner.

• Continue with edscon

Check the spectrometer constants, change it and click Save if necessary, other-
wise click Cancel

• After finishing the configuration a window cron check appears. 
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Click on Automatic backup to set up an periodically backup.
DONE INDEX

Click OK to accept the default. This window (cron command) allows you to ex-
ecuted commands periodically at predefined times. Here you can specify the
command to be scheduled, some scheduling options and the starting time and
date.

After cf, expinstall,... have finished insert a sample and make sure that you
can lock on the lock solvent. Type ii and read with rpar a standard proton

parameter file, type getprosol and rga and collect a normal 1H NMR spec-
trum.

8.1.2 If you want to configure a processing-PC like your spectrometer-PC: 

If the PC does not control a spectrometer but is used in connection with a particu-
lar spectrometer, e.g. for setting up experiments, processing and or plotting, you
should configure it as that spectrometer: for example the spectrometer is a AV300
configured with the name 'av300'. Do the following.

a) Copy the configuration directory ’<TOPSPINHOME>/conf/instr
/av300’ from the spectrometer AV300 to the workstation.

b) On the workstation paste this 'av300' directory to ’<TOPSPIN-
HOME>/conf/instr’.

(most likely this is the path:  c:\Bruker\TopSpin\conf\instr)
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You can use the TOPSPIN command nmr_save to transfer the configuration (see
chapter 8.8).
DONEINDEXa) Start TOPSPIN as Administrator.

b) Open a dataset

• Type new and create a new dataset.

• You can also select a dataset (e.g. exam1d_1h) acquired with another TOP-
SPIN or XWIN-NMR version.

c) Enter cf (The command cf now configures the software according to the
hardware of your spectrometer): 

a) A window will appear:
Password request. Please enter the NMR administration
password

Type in the NMR ADMINISTRATION PASSWORD. Click OK.

b) A window will appear:.

Press "Edit" to confirm this configuration.

c) A window will appear:

The selected configuration is displayed. Choose Datastation to configure
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your PC as a datastation.
DONE INDEX

d) The nuclei-table appear.

Check if the frequency of the nuclei are set correctly and click Save (If
in doubt click Restore then click Save)
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e) A window ’Edit spectrometer configuration will appear: click Save..
DONEINDEX

f) The results of cf appears in a text window → click Next..

After finishing cf window ’Additional configuration programs’ will appear
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showing a list of configuration steps. .
DONE INDEX

Accept the default selection and click on the buttons (You will be asked for the
NMR ADMINISTRATION PASSWORD a couple of times):

• Continue with expinstall 

a) Type in the NMR ADMINISTRATION PASSWORD and OK 
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b) Click Next if you either have no modified Bruker BioSpin-Parameterfiles
DONEINDEX

AU-programs and Pulse-programs or if you have archive them in a different
directory. Your individual Parameterfiles, AU-programs and Pulse-pro-
grams that have different names to the original Bruker BioSpin files will not
be destroyed during the installation

c) In the appearing window → Check Installation for Datastation (Customize)
→ Click Next

d) In the appearing window → Check High Resolution Systems → Click Next
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e) In the appearing dialog box → Select the spectrometer configuration name
→ Click Next
DONE INDEX

f) In the appearing dialog box → Select the default printer and plotter and the
desired paper format → Click Next 

g) In the appearing window → Click Next
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h) In the appearing information box → Check the configuration selection and,
if it is correct → Click Finish
DONEINDEX

The installation of the selected items, will start now. Wait until this process has fin-
ished.

For more details on expinstall, please refer to the description of this com-
mand in the Acquisition Reference manual.

After finishing the configuration a window cron check appears. 
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Click on Automatic backup to set up an periodically backup.
DONE INDEX

Click OK to accept the default. This window (cron command) allows you to ex-
ecuted commands periodically at predefined times. Here you can specify the
command to be scheduled, some scheduling options and the starting time and
date.

8.1.3 If you want to use a default configuration on a datastation

A default configuration can be used on a datastation. It is automatically performed
(no cf required) during the installation of TOPSPIN on a new computer, a new disk
or in a new TOPSPIN installation directory. The default configuration names are
Bruker_default_av500 (corresponds to an Avance 500 MHz spectrometer) and
Bruker_default_avanceII300 (corresponds to an Avance II 300 MHz spectrome-
ter).

For manual or interactive data processing, the automatic default configuration is
sufficient. If, however, you want to use AU programs, you must execute expin-
stall once, selecting Installation for Datastation (Default). 

8.1.4  If you do not know the configuration of your spectrometer

If you do not have any spectrometer configuration information, e. g. after a head-
crash, then you have to recreate the configuration information. 

If your spectrometer has a standard configuration, then you can easily do cf and if
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you give the correct information for the ’Type of Spectrometer’ you will get the
correct list of your hardware in the ’RS232 table’. You only have to type in the cor-
rect tty’s of the interfaces.
DONEINDEX8.1.5 If you added a new hardware component to your spectrometer

If you want to add a new hardware component it is recommended to order some-
body of your local Bruker BioSpin office to do this for you. 

8.2 Take over the configuration of XWIN-NMR or TOPSPIN into 
TOPSPIN 2.1

The decision how to install TOPSPIN is very important in case you have already
XWIN-NMR or TOPSPIN installed on the same or another PC. If so, you might will
take over the configuration of XWIN-NMR or TOPSPIN 1.2 / 1.3 / 2.0 into TOPSPIN

2.1 because of:

• in case the XWIN-NMR/TOPSPIN installation was used for controlling a spec-
trometer there are very important configuration files like the spectrometer
configuration, shim files, your own pulse programs, parameter sets, etc.

• if XWIN-NMR/TOPSPIN was used for processing only there can be also very
important configuration files like AU programs, macros, plot layouts etc.

Note: Transferring files could cause permission problems especially if they are
transferred from one PC to another.

8.2.1 Take over the configuration on the same PC

If TOPSPIN 2.1 is installed parallel to TOPSPIN 1.2 / 1.3 / 2.0 or XWIN-NMR, the AU
program nmr_save can be used to take over the configuration of XWIN-
NMR/TOPSPIN.

You can take over the configuration during the Installation of TOPSPIN 2.1 (see
chapter 6.4) or after the installation with the AU program nmr_save.

If you like to get more information about the command nmr_save refer to chap-
ter 8.8.

Insert the TOPSPIN DVD and start installation. You will be asked to define the
installation path. Accept the default or choose another one but not the existing
installation directory. During the installation you will be asked if you want to

!
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import a spectrometer configuration. If you want to take over the configuration
after installation is finished, start TOPSPIN

• and type in the command:
DONE INDEXnmr_save

• or start TOPSPIN and click

Options → Manage Configuration → Save installation specific files

A window ’Password request’ will appear. Please enter the NMR administration
password and click OK.

A window ’NMR_Save’ appears. Please check the ’Location of Backup file’
(default: <TOPSPINHOME>\nmr_backup). Enter the location of the installa-
tion to be saved (e.g. C:\Bruker\XWIN-NMR). Click on Save.

This will create a tar file of all necessary information from the XWIN-NMR installa-
tion. The tar-file is called nmr_backup.tar and will be stored in the directory:

<TOPSPINHOME>\nmr_backup

To take over this information into TOPSPIN, please click on the Restore installaton
files tab, enter the restore destination (e.g. <TOPSPINHOME>) and click on
Restore. 

After this process is finished, execute cf.

8.3 How to use the Bruker Utilities Folder

After a successful installation of the TOPSPIN, you will find a new folder on every
user's desktop named 'Bruker Utilities'. Double click on the folder to see its con-
tents:

or

1. Click Start → All Programs → Bruker TOPSPIN → Bruker TOPSPIN x.y
→ Bruker Utilities
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2. A window ’Bruker Utilities’ appears.

In this Utilities folder, you will find commands and applications that you might
need when running and configuring a spectrometer. You can see the command
DONEINDEXprompt right there: just double click on it to get to the prompt.

The other tools are stored in three categories as shown above. You can double click
on each of the folders to have them opened up to show their treasures:

Each of them (our example here is 'miscellaneous') have a number of batches or
executables, or plain commands that you can run by just double clicking on the
respective icon. For example, to see the system ID of the current PC you can just
double-click on the icon called 'get_hostid'. It will open a text window and deliver
the system ID you need to know when you apply for TOPSPIN license (encircled):

If you press any key, the window will be closed again.

As you can see from the next screen (produced by the command ipconfig
/all in a command prompt) flexlm takes the address of one of the Ethernet cards
in the PC. Which one is used depends on the binding order of the two cards. You
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can check the binding by clicking the icon from the Control Panel.
DONE INDEX

Another interesting tool in the 'miscellaneous' section actually issues commands to
the CCU rather than to the PC. One of the items is 'pwrdwn' in this category that
logs in to CCU and issues the UNIX command that powers down the CCU. All
YOU do is double click on it and watch it do the rest. 

The other categories are Service Tools, Test Tools and Documentation. You can
just double-click the appropriate icon and the command-shell and tool programs
will start up automatically.:
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8.4 Configuring the BSMS-Keyboard

For a full description how to configure the BSMS-Keyboard see your

• hard copy of ’BSMS-User Manual’ or 

• the respective entry on the ’BASH’ CD-ROM’ (Order Number Z36541)

A configuring step that should be done periodically is the spin rate calibration. For
this you have to go into the Menu mode of your BSMS keyboard. Press simultane-

ously 2nd and Y3, then rotate the control knob as long as you see 1.Sample in
the display, press 2nd to go into this directory. The display will show 1.1 Spin
calib. press 2nd to start this process and wait for ~ 3 minutes.
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In this Menu mode, you can also define the helium warning level. If the liquid
helium reaches the critical point, the BSMS-Keyboard starts beeping. A special
password, the so called security code, is required to be able to change the set-
DONE INDEX
ting.For an additional possibility to get a warning about a low helium level see
chapter 21.1. If in doubt about the setting, contact your service representative. 

8.5 How to use the BSMS shuttle

The BSMS shuttle can be used only on spectrometers with BSMS racks with
ECLB board.

8.5.1 Requirements

To work with the BSMS shuttle we recommend the following specifications:

• ShuttlePro V.2

• ShuttlePro V.2 software (The following information refers to the ShuttlePro
software version 2.0.0)

• TOPSPIN 2.1

• Windows XP Professional SP2

• AVANCE console with BSMS rack with ECLB board
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8.5.2 Usage

Standard configuration 1:
DONEINDEX

Note: In general it is possible to change these settings under Windows XP 2, but it
is not recommended to do this:

a) It is a problem for the service engineer to use the shuttle if everything is config-
ured in a complete different way.

b) There is no support form Bruker BioSpin if the customer has an individual con-
figuration and he runs into problems.

8.5.3 Installation of the BSMS shuttle

1. Log in as a Local Administrator.

2. Connect the ShuttlePro V.2 to an USB port.

3. Close ALL WINDOWS on the desktop.

4. Insert the CD ’Contour Software Installation Disk’.

5. Install the ShuttlePro V.2 (The following information refers to the ShuttlePro
V.2 software version 2.0.0).

1.  This picture is available from the Help menu in BSMS display.
2.  It is possible to use your own preferences instead of the standard Bruker configuration. It is 

only possible to have one configuration for the PC. ShuttlePro V.2 does not support user spe-
cific configurations.



102 Configuration of TOPSPIN

INDEX

Note: The current software version can be downloaded from the web pages of
Contour Design Inc..
http://www.contourdesign.com
DONE INDEX
6. After the installation click2.1 right on the ShuttlePro icon close to the time and

date in the lower right corner of your screen and choose Open Control Panel.

7. The window Contour Shuttle Device configuration will appear.

8. Click on Options.

9. Select Import setting in the upcoming context menu.

A browser window will appear.


http://www.contourdesign.com
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10. Go to your TOPSPIN installation directory into the subdirectory
classes/prop. In a default configuration this is:
C:\Bruker\TOPSPIN\classes\prop
DONEINDEX
11. Import the file TopSpin.pref.

12. Click on the arrow to select a different Application setting, scroll down and
select the entry TOPSPIN.

13. Click on Options.

14. Select Change target application in the upcoming context menu. A browser
window will appear.
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15. Go to your TOPSPIN installation directory into the subdirectory jre/bin and
select the file java.exe. In a default installation this is:
C:\Bruker\TOPSPIN\jre\bin\java.exe
DONE INDEX
Now you can enter the TOPSPIN command bsmsdisp and use the buttons for
selecting shims, change values etc.

8.6 Firmware update of the spectrometer hardware

This chapter describes how to update the firmware of spectrometer components.
This is only necessary if the cf command has crashed and popped up a message
window which informs that you have to do a firmware update of a certain compo-
nent.

It is strongly recommended to do the firmware update only in this case,
because the hardware component could become unusable if the update
was done incorrectly.

If you have further questions according firmware updates, please get in contact
with your local Bruker BioSpin office. Adresses of several offices can be found in
chapter 22, for contact information about all Bruker BioSpin office please go to
our web server:

http://www.bruker-biospin.de/NMR/about/offices

8.6.1 Firmware Update for boards without ethernet connection

This chapter describes how to update the firmware for boards without ethernet
connection on the example ’LCB board’.

1. Start the ’Service Tools’ of the ’Bruker Utilities’ to check the firmware version
of your spectrometer hardware.

2. Double click on an icon starts an automatic procedure that opens a command

!

http://www.bruker-biospin.de/NMR/about/offices
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prompt. The following example shows the check of the ’bsms-service tool’
DONEINDEX

3. Type y → ENTER

4. A dialog comes up in the command prompt

5. To check and eventually download a new firmware (from TOPSPIN)

• type 2→ ENTER 
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The check starts and ends for example as shown in the following picture
DONE INDEX

• if there is a problem with a component you get an information to contact
your serviceoffice

• if you need a firmware update you will get a message (A) with the length
of time for the download (B). It is recommended to do the download as
soon as possible.

6. Press y → ENTER to start the download

During the download it is absolutely necessary that spectrometer and
PC are not disturbed! Make sure that no one pulls a cable out of the
spectrometer or uses Windows XP parallel! (Yes, we know this seems
very improbable, but if the download would crash your board might be
unusable afterwards)

• A normal error during downloading the new firmware requires to do the
download once again! 

• If you have done a download of newer firmware, you have to do cf again!

• If you do not need any downloads you can follow the instructions in the
command prompt to end this tool.

8.6.2 Firmware Update for boards with ethernet connection

This chapter describes how to update the firmware for boards with ethernet con-
nection on the example ’ELCB board’.

1. To check which ethernet connected hardware units are available you can use
one of the two commands ha or ethernet-service-tools

A

!
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• Open TOPSPIN and enter in the command line ha. A window appears that
shows several hardware modules.This chapter describes how to update the
DONEINDEX

firmware for boards with ethernet connection on the example ’ELCB
board’.

• Open Command Prompt (Click Start → All Programs → Bruker TOP-
SPIN → Bruker TOPSPIN x.y → Bruker Utilities → Command
Prompt) and enter the commands:

• cd prog/bin

• Click Enter

• ethernet-service-tools 

• Click Enter

A window appears that shows several hardware modules. 
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2. Click on the hardware device to open a browser with a connection to this
device.

3. A window ’BSMS Service Web - Main’ appears. Click on Device Setup.
DONE INDEX

4. The ’BSMS Service Web - Setup’ page appears.

Please click on the button Browse to select the BsmsCheckDownload.txt
file. In a default installation this file is stored in the directory:
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C:\Bruker\TOPSPIN\conf\instr\servtool\bsmscnf\

Note: Selecting Get File BsmsCheckDownload.txt from Bruker ftp server is
DONEINDEX
only necessary if a Bruker Service Engineer recommends to do this.

5. After the selection click on the button Load BsmsCheckDownload.txt.

6. If a difference is displayed between Required Firmware and Loaded Firmware
please click on Load new ELCB firmware.

7. The ’BSMS Service Web - ELCB Firmware Download’ page appears.

Please click on the button Browse to select the firmware version which is men-
tioned in the line Select the file.... In a default installation the file is stored in the
directory:
C:\Bruker\TOPSPIN\conf\instr\servtool\elcb\

8. Please click on the button install firmware.

Note: Selecting Get File elcb_firmware_XXXXXX.gz from Bruker ftp server is
only necessary if a Bruker Service Engineer recommends to do this.

Note: The ELCB firmware releases 06xxxx and up are distributed as *.gz files.
To be able to load this file format to the ELCB the firmware
elcb_firmware_051116.hex or newer has to be running on the ELCB.
If an older firmware is running first download the
elcb_firmware_051116.hex distribution.
The *.gz file has to be downloaded as is, don't unzip it!
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8.6.2.1 ELCB board: Save user configuration

You can save the user specific configuration of the ELCB board in a Text file.
DONE INDEX
1. Please open the ’BSMS Service Web’ page. Click on Service.

2. The ’ELCB Service Web’ page appears. Click under ’Active User Configura-
tion / Parameters’ on Save to Disc.

3. The ’BsmsSaveUsrNvm.txt’ page appears. Click in the Microsoft Internet
Explorer on File → Save as... and choose the directory where the file



Configuration of TOPSPIN 111

INDEX

BsmsSaveUsrNvm.txt should be stored.
DONEINDEX

8.6.2.2 ELCB board: Restore user configuration

1. Please open the ’BSMS Service Web’ page. Click on Service.

2. The ’ELCB Service Web’ page appears. Click under ’Active User Configura-
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tion / Parameters’ on Save to Disc.
DONE INDEX

3. The ’ELCB Service Web’ page appears. Under ’User Level’ you have to enter
the User and Password and click on Login.

Note: To get these two information please get in contact with your local Bruker
BioSpin office. Adresses of several offices can be found in chapter 22, for contact
information about all Bruker BioSpin office please go to our web server:

http://www.bruker-biospin.com/contact_us.html

4. The ’ELCB Service Web’ page will be changed. Under ’Active User Configu-

http://www.bruker-biospin.com/contact_us.html
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ration / Parameters’  click on Load From Disk.
DONEINDEX

5. The ’BSMS Service Web - Load User Configuration File’ appears. Click on
Browse to select the user configuration file (BsmsSaveUsrNvm.txt) to
download. Click on Submit Query.

6. The ’BSMS Service Web - Load User Configuration Status’ appears. Please
check if the ’Status of User Configuration File Load’ is ’New User Settings
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successfully loaded’.
DONE INDEX

8.7 A log of the entire system configuration

The showconf command provides you with various information about your hard-
ware and software, both of the PC and of the spectrometer. Here is how showconf
works: Go to the folder Bruker Utilities → Miscellaneous → double-click on the
showconf icon and wait about 2 minutes until it has finished. After that showconf
has produced a file called confout.txt that contains all you need. Con-
fout.txt is located next to the showconf batch after the first execution and you
edit it from there: 
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Just double click on the confout icon to call the appropriate editor:
DONEINDEX

The easiest way to copy it on a diskette is right from within the miscellaneous-
folder: Right-click on the confout-icon and select 'send to' and then A:

The size of this report is mostly less then 100 kbytes.

DO KEEP A COPY OF THIS FILE IN A SAFE PLACE!
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8.8 Backup of VIFs (=Very Important Files) with nmr_save

It is not only necessary to create some backups for the operating system like Boot
DONE INDEX
Disks and to store the acquired datasets.

it is strictly recommended to create a frequently backup of the ’VIFs’ - the ’Very
Important Files’ of the configuration of TOPSPIN.

There are many reasons like e. g. head crash or theft of the hard disk that makes it
important that a weekly or monthly backup is made of important data, so that you
would be able to restore the spectrometer configuration in a very short time.

TOPSPIN offers the command1 (nmr_save) for saving those important files that
are not delivered by Bruker BioSpin. This command can save and extract user spe-
cific data from a TOPSPIN installation and puts them into an archive file.

8.8.1 How to use nmr_save

nmr_save can be used for saving and restoring configuration information of the
TOPSPIN installation where the command is executed. Furthermore, it is possible to
use nmr_save in one TOPSPIN installation to backup data from another TOPSPIN or
XWIN-NMR installation. 

In fact, if you have several versions of Bruker software installed in parallel, you
should always use the nmr_save command from the highest software version.

If your previous TOPSPIN/XWIN-NMR installation is not located on the same PC,
you can even mount the respective network path on your local PC and tell
nmr_save to take over the necessary information over the network.

8.8.2 How to save information with nmr_save

nmr_save can be started as follows:

• Start TOPSPIN and type in the command:

nmr_save

• or start TOPSPIN and click

Options → Manage Configuration → Save installation specific files

1.  BRUKER also offers a script (xwinnmr.save) which can be used for saving the ’VIF’s (see 
chapter 21.2).

!

!
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A window ’NMR_Save’ will appear. 
DONEINDEX

1. Accept or modify the Location of Backup file 

(default is: <TOPSPINHOME>\nmr_backup). 

2. Enter the location of the Installation to be saved 

(default is: <TOPSPINHOME>).

3. nmr_save will then offer a list of all available spectrometer configurations
which are located in this respective installation. Select the correct configuration
in the field Spectrometer name (spect). In a typical setup your spectrometer
configuration is called spect.

In a typical installation three configuration names will be listed here, your current
instrument name and the two Bruker default configurations,
Bruker_default_avanceII300 and Bruker_default_av500.
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If you are in doubt about the name of your current spectrometer configuration exit
the nmr_save window and enter the TOPSPIN command about. You can find the
name of your current configuration in the upcoming window under Configuration
DONE INDEX
→ Current Instrument.

Start nmr_save again. Now you can select the correct Spectrometer name.

4. Now you can click on Save.

This will create an archive file of all necessary information from the selected
installation/spectrometer configuration. This file is called
nmr_backup_<date>-<time>.tar
e.g.: nmr_backup_20071009-2348.tar
 and is stored in the directory you selected above, typically:

<TOPSPINHOME>\nmr_backup

If you want to execute ’Save installation specific files’ periodically please click on
the button Automatic Backup this will open a window for a command scheduling.
Clicking OK will accept the default values and execute nmr_save once in a
month. 
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The command cron performs command scheduling. It allows you to executed com-
mands periodically at predefined times. It offers full flexibility in time definition,
off-schedule execution and user control. Here you can specify the command to be
scheduled, some scheduling options and the starting time and date. The following
fields are available:

1. Command: The command to be executed.

2. Description: A description of the command.

3. Execution Scope: The scope of the command execution, User of TOPSPIN.
For scope User, the scheduled command will only be executed if TOPSPIN is run
by the same (internal) user that is active during cron definition. If the scope is
TOPSPIN, the scheduled command will be executed for any (internal) user.
Scheduled command with TOPSPIN execution scope can only be defined, can-
celled or modified after entering the Administration password.

4. Off-schedule execution: This flag allows you to executed commands
that were scheduled to run at the time when TOPSPIN was not running. These
commands are executed after TOPSPIN startup. Note that commands that were
scheduled to run multiple times during Topspin downtime are only executed
once. 

The following time scheduling rules exist:

• Minute of the hour: 00 through 59
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• Hour of the day: 00 through 23

• Day of the month: 00 through 31
DONE INDEX
• Month of the year: January through december

• Day of the week: Sunday through Saturday

For each of these fields, you can define an interval by selecting a value in the From
and a value in the To field. Setting the To field to Ignore, schedules the command
for execution only at the time/date selected in the From field. An asterix (*) in the
From field indicated all possible times. Clicking the + button to the right of a field,
adds an extra field of the same type, allowing multiple interval definition. Clicking
the - button removes the extra field.

8.8.3 Which information is stored with nmr_save?

nmr_save archives some directories completely, in some other directories only
specific files. Files that start with an "." are ignored. The internal TOPSPIN database
for pulse and cpd programs, macros and python scripts is saved completely. Which
information is stored with nmr_save can be found below.

The TOPSPIN database is saved completely:

<TOPSPINHOME>/db

contains pulse and cpd programs, macros and python scripts

The following directories are saved completely (hidden files are ignored!):

<TOPSPINHOME>/conf/instr/autoshim/refmaps/

<TOPSPINHOME>/conf/instr/probeheads/

<TOPSPINHOME>/conf/instr/<spect>/prosol/

<TOPSPINHOME>/conf/instr/<spect>/cortab/

<TOPSPINHOME>/conf/instr/<spect>/inmrusers/

<TOPSPINHOME>/conf/instr/topshim/parameters/user

<TOPSPINHOME>/conf/instr/topshim/solvents/user

<TOPSPINHOME>/data/final/nmr/protocolfiles/

<TOPSPINHOME>/exp/stan/nmr/lists/best-nmr/user/subset/fi

<TOPSPINHOME>/exp/stan/nmr/lists/best-nmr/user/subset/lc

<TOPSPINHOME>/exp/stan/nmr/lists/bsms/

<TOPSPINHOME>/exp/stan/nmr/lists/ds/

<TOPSPINHOME>/exp/stan/nmr/lists/eurotherm/corr
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<TOPSPINHOME>/exp/stan/nmr/lists/eurotherm/tcf

<TOPSPINHOME>/exp/stan/nmr/lists/f1/

<TOPSPINHOME>/exp/stan/nmr/lists/group/
DONEINDEX<TOPSPINHOME>/exp/stan/nmr/lists/scm/

<TOPSPINHOME>/exp/stan/nmr/lists/vc/

<TOPSPINHOME>/QTP/

<spect> represents the current spectrometer name or the name specified explic-
itly when nmr_save is started.

From the following directories every file is saved that does not belong to the genu-
ine Bruker BioSpin distribution:

<TOPSPINHOME>/conf/instr/servtool/bsmstool/boss

<TOPSPINHOME>/conf/instr/topshim/spect

<TOPSPINHOME>/conf/instr/topshim/probeheads

<TOPSPINHOME>/exp/stan/nmr/lists/gp/

<TOPSPINHOME>/exp/stan/nmr/lists/wave/

<TOPSPINHOME>/exp/stan/nmr/au/scl/

<TOPSPINHOME>/exp/stan/nmr/au/src/

<TOPSPINHOME>/exp/stan/nmr/par/

<TOPSPINHOME>/exp/stan/nmr/parx/preemp

<TOPSPINHOME>/plot/layouts/

<TOPSPINHOME>/prog/tcl/xwish3_scripts/

Additionally, the following files are also saved:

<TOPSPINHOME>/conf/instr/selpulse.*

<TOPSPINHOME>/conf/instr/probehead

<TOPSPINHOME>/conf/instr/<spect>/2Hlock

<TOPSPINHOME>/conf/instr/<spect>/19Flock

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/CurrPushSolvent

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/hardware.par

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/hardware.src

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/racks.use

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/scanner.src

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/solvents.add

<TOPSPINHOME>/conf/instr/<spect>/best-nmr/solvents.par
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<TOPSPINHOME>/conf/instr/<spect>/best-nmr/solvents.use

<TOPSPINHOME>/conf/instr/<spect>/hardware_list

<TOPSPINHOME>/conf/instr/<spect>/nuclei
DONE INDEX<TOPSPINHOME>/conf/instr/<spect>/rs232_device/best

<TOPSPINHOME>/conf/instr/<spect>/rs232_device/bestscan

<TOPSPINHOME>/conf/instr/<spect>/specpar

<TOPSPINHOME>/conf/instr/<spect>/uxnmr.par

<TOPSPINHOME>/conf/instr/<spect>/uxnmr.info

<TOPSPINHOME>/conf/global/layoutsearchpath

<TOPSPINHOME>/exp/stan/nmr/lists/probeheads

<TOPSPINHOME>/exp/stan/nmr/lists/solvents

<TOPSPINHOME>/prog/logfiles/heliumlog

<TOPSPINHOME>/prog/logfiles/heliumlog.err

<TOPSPINHOME>/prog/server/export.conf

<LM_License_File>1

For safety reasons the tar-file will not be replaced by executing nmr_save once
again. So if you like to use nmr_save several times, you have to move the
nmr_backup.tar file from the directory <TOPSPINHOME>/nmr_backup
on a backup medium (floppy, CD ...) and then start the script once again or you
have to select the ’Overwriting existing backup file’ option.

8.8.4 How to restore information with nmr_restore (nmr_save option)

Note that this will overwrite your complete TOPSPIN configuration plus spectrome-
ter configuration. Restore from a backup file only if you are absolutely sure that
this is necessary. If in doubt do not restore or at least create a backup of the current
state before.

nmr_restore (nmr_save option) offers a field to overwrite an existing con-
figuration. If this is checked the previous configuration is overwritten automati-
cally, if it is not checked, nmr_restore will ask you if you are really sure to
overwrite the existing configuration

Start TOPSPIN and type in the command:

1.  This is the environment variable for the license file, in a default installation this is:
C:\flexlm\Bruker\licenses\license.dat
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nmr_save

and click on the Restore installaton files tab
DONEINDEX
or start TOPSPIN and type in the command:

nmr_restore

or click

Options → Manage Configuration → Restore installation specific files

A window ’NMR_Save’ will appear. Select the tab ’Restore installation files’.

Enter the path where you archive file is stored in the field Location of Backup file 

(default is: <topspinhome>\nmr_backup). 

5. Enter the location of the restore destination

(default is: <topspinhome>)
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6. Click on Restore

A window ’Password request’ will appear. 
DONE INDEX

Please enter the NMR administration password and click OK.

7. Execute the TOPSPIN command cf

8.8.5 The options for nmr_save / nmr_restore

The options for nmr_save and nmr_restore are:

• Location of backup file:
absolute path where backup archive file
nmr_backup.tar will be created (’save
option’) or can be found (’restore option’)

• Overwriting existing backup file:
overwrite existing nmr_backup.tar file

• Installation to be saved or restore destination:
a) absolute path to TOPSPIN/XWIN-NMR installa-
tion that should be saved.
b) absolute path where archive file will be
extracted.

• Spectrometer name (spect):
name of the spectrometer configuration

• Display default information:
display the directories and files which will be
saved

• Display additional information:
display all files which will be saved

8.8.6 Examples for using nmr_save

1. Examples for backing up the current TOPSPIN installation:

a) Default backup directory used:
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• Location of backup file: <topspinhome>\nmr_backup
(e.g.: C:\Bruker\TOPSPIN\nmr_backup)

• Installation to be saved: <topspinhome>
DONEINDEX
(e.g.: C:\Bruker\TOPSPIN)

• Spectrometer name (spect): <spect>
(e.g.: spect)

• Click Save

b) Default backup directory used, but the spectrometer directory spect_org is
saved which is not the default being defined in 
<topspinhome>/conf/instr/curinst

• Location of backup file: <topspinhome>\nmr_backup

• Installation to be saved: <topspinhome>

• Spectrometer name (spect): spect_org

• Click Save

c) /tmp as backup directory:

• Location of backup file: C:\tmp

• Installation to be saved or restore destination: <topspinhome>

• Spectrometer name (spect): <spect>

• Click Save

2. Examples for restoring the backup file

a) Restoring the backup file C:\Bruker\TOPSPIN\nmr_backup\
nmr_backup.tar into the Topspin home directory (default):

• Location of backup file: C:\Bruker\TOPSPIN\nmr_backup

• Restore destination: C:\Bruker\TOPSPIN

• Spectrometer name (spect): <spect>

• Click Restore

b) Restoring the backup file C:\Bruker\TOPSPIN\nmr_backup\
nmr_backup.tar into the directory C:\Bruker\TOPSPIN\tmp:

• Location of backup file: C:\Bruker\TOPSPIN\backup_old

• Restore destination: C:\Bruker\TOPSPIN\tmp

• Spectrometer name (spect): <spect>
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• Click Restore

Note: Do not forget to execute the TOPSPIN command cf.
DONE INDEX8.8.7 How to save information with user_save (nmr_save option)

user_save (nmr_save option) can used to copy user specific files to a differnt
computer or to create a backup of user specific files of an installation.

user_save can be started as follows:

Start TOPSPIN and type in the command:

nmr_save

and click on the Restore installaton files tab

or start TOPSPIN and type in the command:

user_save

or click

Options → Manage Configuration → Save user specific files
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A window ’NMR_Save’ will appear. 
DONEINDEX

• Accept or modify the Location of Backup file 
(default is: <TOPSPINHOME>\nmr_backup). 

If you want to execute ’Save user files’ periodically please click on the button
Automatic Backup this will open a window for a command scheduling. Clicking
OK will accept the default values and execute user_save once in a month.

8.8.8 How to restore information with user_restore (nmr_save 
option)

Note that this will overwrite your user specific files. Restore from a backup file
only if you are absolutely sure that this is necessary. If in doubt do not restore or at
least create a backup of the current state before.

user_restore (nmr_save option) offers a field to overwrite an existing
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configuration. If this is checked the previous configuration is overwritten automat-
ically, if it is not checked, user_restore will ask you if you are really sure to
overwrite the existing configuration
DONE INDEXStart TOPSPIN and type in the command:

nmr_save

and click on the Restore installaton files tab

or start TOPSPIN and type in the command:

user_restore

or click

Options → Manage Configuration → Restore installation specific files

A window ’NMR_Save’ will appear. Select the tab ’Restore installation files’.
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Enter the path where you archive file is stored in the field Location of Backup file 

(default is: <topspinhome>\nmr_backup). 
DONEINDEX
3. Enter the location of the restore destination

(default is: <topspinhome>)

4. Click on Restore

A window ’Password request’ will appear. 

Please enter the NMR administration password and click OK.

8.8.9 How to read the archive file

Although the archive file created by nmr_save is a tar file, it should not be
opened or read with the tar command. It is packed in a special procedure and the
only correct way of extracting the file is the nmr_save command!

If you like to have a look at the content of an archive file or copy just some files
from it, you should extract the archive into a temporary directory, e. g.
C:\tmp\backup-test. Then you can check and copy the extracted files from
there.

8.8.10 Is all information restored in their original places?

No, the license.dat file, the heliumlog file and the heliumlog.err file
are restored in a different directory, because the current ones should not be over-
written. If you want to reuse the restored files you can find them in the restore des-
tination you have chosen, in the subdirectory <topspinhome>\conf\instr
with the extension .backup

All other files are restored in their original places.

8.9 Windows XP SP2 firewall configuration script

Microsoft Windows XP Service Pack 2 (SP2) includes significant changes to Win-
dows networking functionality with regard to security aspects. After installation of
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SP2, Windows displays several informational dialogues about ’blocked compo-
nents’ and possible administrators activities during the start-up of TOPSPIN. Bruker
BioSpin offers a configuration script ’setfirewall.cmd to apply the required
DONE INDEX
settings to the new Windows XP SP 2 firewall.

Windows now includes fully featured firewall technology (’Windows Firewall’,
previously known as ’Internet Connection Firewall’ or ’ICF’). After installation of
SP2, the firewall is activated for all network interfaces by default, blocking net-
work traffic to running applications that is initiated from external network loca-
tions. Bruker BioSpin's TopSpin software (as many other applications on the
market) makes use of network connections for communication activities. Spec-
trometer control and TOPSPIN's ‘remote connection’ feature by design rely on net-
work contacts from outside the local machine. As a result at start of TopSpin,
Windows will bring up several information windows about ‘blocked programs’
recommending an administrator to review firewall settings to allow network com-
munication for designated applications.

It is Microsoft's idea to have Administrators review for which applications net-
work access from outside should be allowed. Those applications should be made
‘known’ to the firewall thus can be done manually using the ‘Windows Firewall’
applet in the Control Panel.

Bruker BioSpin has developed a configuration script ‘setfirewall.cmd’ that applies
all required settings to Windows firewall configuration without user interaction.
The script applies changes to the firewall related to Bruker software only and does
not overwrite or reset entries for non-Bruker applications.

The script is stored in the subdirectory <topspinhome>\prog\bin\utili-
ties\Miscellaneous of your TopSpin installation.

Note: If the script is executed in a wrong directory nothing will happen! Please
note that the firewall is configured to allow ‘Remote Connection’ from local sub-
net addresses only

The script can be used in four different ways:

1. During the Installation of TOPSPIN (if the firewall is enabled) you will be asked
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to configure the firewall.
DONEINDEX

2. Click Start → All Programs → Bruker TOPSPIN → Bruker TOPSPIN x.y
→ Bruker Utilities → Miscellaneous. Double-click the script file: ‘setfire-
wall.cmd’. The script will automatically detect the installation path and register
this installation with the firewall. I.e., if your installation were in
C:\Bruker\TOPSPIN2.1 it would register that and only that!

T

3. Execute the configuration script ‘setfirewall.cmd’ from a Command Prompt.
You will get usage information like the following:

setfirewall INSTDIR SCOPE [DISKLESS_PATH [NFS_PATH]]

where

INSTDIR installation directory of TOPSPIN, e.g. c:\Bruker\TOPSPIN

SCOPE either ALL or SUBNET

to specify whether firewall should allow remote connections
to this installation from any address or local subnet only.

DISKLESS_PATH

installation directory of DISKLESS, e.g. c:\Bruker\Diskless

NFS_PATH installation directory of Hummingbird NFS Server, e.g.

C:\Program Files\Hummingbird\Connectivity\7.10\NFSServer

Note: You must have administrative rights to do this successfully

This way you have the possibility to register a specific installation of TOPSPIN

with the firewall. Example:

setfirewall c:\Bruker\ts20 install all

would do the required settings for an installation in ’c:\Bruker\ts20’ and allow
the remote connection feature to be accessed without restrictions to the initiating
network address. You can customize the script for different address ranges if re-
quired.
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4. Execute the configuration script ‘setfirewall.cmd’ from the Bruker BioSpin
Command Prompt (e.g. installation in C:\Bruker\TOPSPIN2.1):

• Click Start → All Programs → Bruker TOPSPIN → Bruker TOPSPIN
DONE INDEX2.1 → Bruker Utilities → Command Prompt

• Enter the command:

setfirewall install all

This way you have the possibility to register the installation of TOPSPIN with the
firewall. In this example the configuration script ‘setfirewall.cmd’ would do the
required settings for an installation in C:\Bruker\TOPSPIN2.1.

In case the installation path of Diskless or the NFS server is different from the
default installation path, the script will inform you that the respective firewall con-
figuration entries are not set. You have to execute the script manually and add the
correct paths.

In either case, you should consider re execution of the configuration script after
one of the following actions happened:

• Complete reset of firewall settings (which is possible e.g. from Control
Panel)

• TOPSPIN installation to new location

• Changes in Service Pack status (e.g. reinstallation)

For further questions and contributions, please feel free to contact software support
at:

nmr-software-support@bruker-biospin.de
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User Management

9.1 User Management in a standalone PC

After the installation of Windows XP, there is one user with administrator rights,
namely the user ’Administrator’. If the password for this user gets lost, there is no
way of resetting it other than re-installing Windows XP. Therefore, we strongly
recommend you install at least one more user with administrator rights, e.g. with
the name ’admin’ (actually, this name is also much easier to type on the keyboard).

Now you have for example two users with local Administrator rights, Administra-
tor and admin. Whenever the password of one of them gets lost, you can login as
the other one, open the User Manager and define a new password (compare chap-
ter 6.2).

The creation of the new administrator account means that the user ’Administrator’
is hidden in the log in menu. You are able to log in as the user ’Administrator’ by
pressing twice Ctrl+Alt+Delete in the log in window.

You can install a new user or administrator as follows:

9.1.1 Adding a new user in a standalone PC (method 1)

This method is recommended by Bruker BioSpin:
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1. Go to the icon My Computer on the desktop → right mouse click Manage
or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage
DONE INDEX
2. A window Computer Management will appear:

• Click Local Users and Groups

3. Right mouse click User → Select New User

4. A window ’New User’ will appear

• Enter the users Full Name and Description (optional) and the users pass-
word in the fields Password and Confirm Password → Create → Close

• If you deselect the option User must change password at next logon it is
possible to select User cannot change password and Password never
expires.

9.1.2 Adding a new user in a standalone PC (method 2)

This method is not recommended by Bruker BioSpin.

1. Log in as Administrator

2. Click Start → Control Panel → User Accounts

3. A window ’UserAccounts’ will appear: 

• Click Create a new account

4. A window ’UserAccounts’ will appear



User Management 135

INDEX

• Enter the name of the new account e. g. admin  → Next

5. A window ’Pick an account’ will appear
DONEINDEX
• Click Computer administrator → Create account

Now you have created a new account. But this account is not protected by a pass-
word by default. Therefore you have to set a password for this account!

1. Click Start → Control Panel → User Accounts

2. A window ’UserAccounts’ will appear: 

• Click Change an account

• Click the account you want to change → Click Create a password

• Type in the password, confirm it and type in a password hint → Create
Password

9.1.3 Adding normal users to the group NmrUser in a standalone PC

Each user who wants to run TOPSPIN must be a member of the group NmrUser.
This group is automatically created during the TOPSPIN installation. To add a user,
log in as Administrator (otherwise you will be asked for the administrator pass-
word during the process) and proceed as follows: 

1. Go to the icon My Computer on the desktop → right mouse click Manage
or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage

2. A window Computer Management will appear: 

• Click Local Users and Groups

3. Click Groups 

4. Highlight the group ’NmrUser’ 

• right mouse click → Properties

5. A window ’NmrUser Properties’ will appear: 

• Click Add

6. A window ’Select Users’ will appear: 

• Click Advanced → Click Find Now

• highlight every name you want to be a member of NmrUsers

• Click OK → OK
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7. Close the window ’NmrUser Properties’ by clicking OK

or:
DONE INDEX
1. Go to the icon My Computer on the desktop → right mouse click Manage

or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage

2. A window Computer Management will appear: 

• Click Local Users and Groups

3. Click User

4. Highlight the user ’admin’ 

• right mouse click → Properties

5. A window ’admin Properties’ will appear. Open the folder Member of.

• Click Add

6. A window ’Select Groups’ will appear: 

• Click Advanced → Click Find Now

• highlight group you want to be a member of

• Click OK → OK

7. Close the window ’NmrUser Properties’ by clicking OK

9.2 User Management in a Domain PC

9.2.1 Adding a second user with Administrator rights in a domain PC

The group ’domain admins’ are automatically a member of the local group
’administrator’ so it is not necessary to create a second user with administrator
rights.

9.2.2 Adding a local user in a domain PC

1. Log in as Administrator

2. Go to the icon My Computer on the desktop → right mouse click Manage
or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage

3. A window Computer Management will appear: 
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• Click Local Users and Groups

4. Highlight ’User’ 
DONEINDEX
• right mouse click → New User

5. A window ’New User’ will appear

• Enter the users Full Name and Description (optional) and the users pass-
word in the fields Password and Confirm Password → Create → Close

6. Highlight the user you had just create   

• right mouse click Properties

7. A window ’<Username> Properties’ will appear: 

• Click Member off → Add

8. A window ’Select Groups’ will appear: 

• Click Advanced → Click Find Now

• highlight every name you want to be a member of NmrUser

• Click OK → OK

9. Close the window ’<Username> Properties’ by clicking OK

Click Start → Shut Down 

Select Log off Administrator

Click OK

Press CTRL+ALT+DEL 

→ Now you can log on as the new user

9.2.3 Adding normal users to the group NmrUser in a domain PC

Each user who wants to run TOPSPIN must be a member of the group NmrUser.
This group is automatically created during the TOPSPIN installation.
To add a user, log in as Administrator (otherwise you will be asked for the admin-
istrator password during the process) and proceed as follows: 

1. Go to the icon My Computer on the desktop → right mouse click Manage
or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage
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2. A window Computer Management will appear: 

3. Click Local Users and Groups
DONE INDEX
• Click Groups 

4. Highlight the group ’NmrUser’ 

• right mouse click → Properties

5. A window ’NmrUser Properties’ will appear: 

• Click Add

6. A window ’Select Groups’ will appear: 

• Click Advanced → Click Find Now

• highlight every name or group you want to be a member of NmrUser

• Click OK → OK

7. Close the window ’<Username> Properties’ by clicking OK

9.2.4 Adding a global group to the local group NmrUser in a domain PC

Users who want to use TOPSPIN must be member of the group NmrUser. In a
Domain scenario we recommend to administrate users in global groups which are
added to the local group NmrUser. Proceed as follows: 

1. Go to the icon My Computer on the desktop → right mouse click Manage
or: Open the Microsoft Explorer → Go to My Computer → right mouse click
Manage

2. A window Computer Management will appear: 

3. Click Local Users and Groups

• Click Groups 

4. Highlight the group ’NmrUser’ 

• right mouse click → Properties

5. A window ’NmrUser Properties’ will appear: 

• Click Add

6. A window ’Select Users’ will appear: 

• Select in the field ’Location’ the domain name 

• In the window ’Enter Network Password’ type in your login name and pass-
word
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• Highlight the global group you want to be a member of NmrUsers (normally
this is the group ’Domain Users’)

• Click OK → OK
DONEINDEX7. Close the window ’NmrUser Properties’ by clicking OK
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Part II

Windows XP - Installation 
and Configuration
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Installation procedure 

Before you start:

10.1 Do's and Don'ts under Windows XP

10.1.1 Do not re-install Windows XP

Not only will it usually not cure the problem, you also lose all additional pre-
installed software (e.g. TOPSPIN, Office package, user accounting, screen and net-
work drives etc.). YOU will have to put all of these back on manually. In such a
case it is very important to have a backup of the essential files (see chapter 15.13
and 8.8). It will be many hours until you are back where you started. If you have
problems, use the Event Viewer and the other diagnostic tools to locate the
problem and cure it within Windows XP. If you think you need a re-install con-
sider an 'Windows XP repair'. Use the Windows XP Repair diskettes (creating
described in chapter 12) to repair Windows XP to the status of that repair disk
rather than doing a scratch install. Re-installing Windows XP is a last resort and
you should have very good reason to do it.

10.1.2 Use Windows sharing rather than FTP

Under Windows you locate other computers in the network with Windows
Explorer and then you can use drag-and-drop multiple files and entire directo-
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ries. You can also connect to UNIX machines in that fashion using a UNIX tool
called 'samba'. Installation details are in chapter 13.4.3. Nevertheless, in some
cases FTP is still the easiest way to get a file quickly.
DONE INDEX10.2 Removing existing software

Windows XP is more complex than you might think. Many files that are uploaded
during an installation go into other parts of the system or replace existing versions
of files. Thus, an uninstall is more like a build-back and you need that to really
clean things out. By removing the directory, you don't solve your problem and also
you lose the installation log which is stored as the software is installed. This log is
very important and used by the uninstaller to make sure it finds every file that went
on in the first place. 

Use the uninstaller from Control Panel, i. e. the icon labeled ’Add/Remove
Programs’. 

Without a log this software will not work any more. If the TOPSPIN is already
installed and you want to install a new version or re-install the same version, you
must first remove the old version and reboot the computer. 

Your own AU programs, pulse programs and parameter sets are NOT removed
when you de-install TOPSPIN. If you want to re-install any other package like NFS,
you must first remove that package (see below), reboot the computer and then re-
install the package.

Never delete directories to remove a program

Always use the ’Add/Remove Programs’ tool

Re-install a program in the following way:

→ remove the program → reboot → install the program → reboot

1. Click Start → Settings → Control Panel

2. Double-click the icon Add/Remove Programs

3. A window ’Add/Remove Programs’ will appear:

If you want to re-install the entire TOPSPIN (see chapter 6.4), please remove the
packages: 

• Bruker: TOPSPIN Bruker: AURELIA/AMIX

!
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• Bruker: ICON-NMR Bruker: SBASE
• Bruker: DISKLESS Bruker: FLEXlm
• Bruker: NMR-SIM Bruker: NMR-GLP
DONEINDEX
• Bruker: TOPSPIN patches Bruker: NMR-GUIDE

Note that not all of these packages are necessarily installed!

a) Select the package that you want to remove

b) Click the button Change/Remove

c) A window ’Check Setup Information’ will appear

d) Check if the path is correct then click OK

e) A window ’Remove Programs From Your Computer’ will appear: 

• A growing bar shows the progress of the de-installation

• When the de-installation is finished: click OK

f) Repeat step b) to e) to remove further packages or click OK to close the
window ’Add/Remove Programs’

4. Close the window ’Control Panel’ 

5. Reboot the computer.

During the installation of the TOPSPIN, several entries are made in the Windows XP
Registry. If an TOPSPIN package, e.g. TOPSPIN is removed as described above, the
corresponding entry in the Registry is automatically deleted.

10.3 Autorun of installation programs

TOPSPIN (like many other software packages) support the Autorun feature. This
means that the installation program automatically starts up when you insert the
CD-ROM. This, however, only works if the Autorun is enabled. If it is not, nothing
will happen after inserting the CD-ROM. In this case you can start the installation
program as follows: 

1. Click Start → Control Panel 

2. Double-click the icon Add/Remove Programs

3. Click Add New Programs → CD or Floppy

4. A window ’Install Program from Floppy Disk or CD-ROM’ will
appear: 
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The system is looking for a Floppy and/or a CD-ROM. If there are one of these
the path will be shown in the field ’Open’

Click Finish
DONE INDEX4a. If the field ’Open’ is empty: 

a) Click Browse 

b) In the field ’Look in’: select the CD-ROM drive

c) Find an icon Setup or Setup.exe

d) Click Setup or Setup.exe

or

1. Open the explorer (see 18.1.5)

2. Select the path of the CD-ROM drive (normally D:)

3. Double click on the file setup.exe

The Administrator can re-enable Autorun by changing the Registry entry

Warning: You are about to edit the Windows Registry File. This is Windows
XP's nerve center and errors in your setup may render your Windows XP
installation UNUSABLE. Please make sure you have a recent Windows XP
Repair Disk created BEFORE you proceed. 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom\Autorun 

from 0 to 1.

!
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Installing and configuring 
Windows XP Professional 

Windows XP exists in two different forms: Windows XP Professional and Win-
dows XP Home Edition. 
The installation as described in this chapter is valid for the English version of Win-
dows XP Professional on a hp workstation xw4400. In this case, you can install
Windows XP exactly as described here. For other versions of Windows XP or
other hardware, the installation procedure might be different.
For example, on some PC’s the boot sequence is interrupted with the Delete key
rather than with the F2 key. 

This description is intended for new installations. If Windows XP is already
installed and you have problems:

Before you decide to re-install Windows XP, try to repair 

Windows XP

Repairing Windows XP means that you selectively re-install parts of Windows XP,
leaving application software and data intact.

!



148 Installing and configuring Windows XP Professional

INDEX

11.1 Scratch install of Windows XP

1. If your computer is running:
DONE INDEXa) Click Start → Shut Down → Shut down the computer → Yes

b) When you see the text ’It is safe to turn off your computer’
insert the CD-ROM ’Windows XP Professional’.

2. Restart the computer and Interrupt the boot process by pressing the F8 key.

(Do not press F2 to go into BIOS, because there you can easily make your PC
unable to boot.)

3. Wait until the boot device menu appears, select removable device with the
ARROW KEY DOWN → ENTER

4. The ’Windows Setup’ screen appears: 

a) You see at the bottom of the window ’Setup is loading files’.

b) You see at the bottom of the window ’Setup is starting Windows XP’.

5. A ’Windows XP Professional Setup - Welcome to Setup’ screen will appear with
the Option of Continuing Setup, Repair a previous installation, or Quitting:

a) Press ENTER to Continue Setup.

6. A text about the "Windows XP Licensing Agreement" (EULA) screen will
appear:

• Press the PGDN key repeatedly until the end, press F8 (to accept).

You see at the bottom of the window ’Searching for previous versions of Mi-
crosoft Windows’.

7. If you have already other Windows XP installations on your PC, a list of them
will appear. Press ESC in order to make a new installation instead of repairing
an older one

8. If you have a couple of partitions on your hard disk, a list of currently available
partitions will appear:

a) Press the ARROW UP or DOWN key to highlight the partition on which
Windows XP must be installed. 

b) Press ENTER 

• Select Format the partition using the NTFS file system, press
ENTER 

!
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You are asked if you really want to format this partition or want to choose
a different partition. After this point formatting will be started, ALL
DATA ON THIS PARTITION WILL BE LOST! Data on other partitions!
DONEINDEX
(which might be on the same disk) remain untouched. If you want to for-
mat this partition, press F (to start formatting) and wait...

9. A window ’Your Computer will reboot in 15 s’ will appear

Remove any Floppy but keep the CD in its drive.

10. After the reboot the setup will continue automatically

A window ’Windows XP Setup’ occurs, please wait ...

11. A window ’Windows XP Professional Setup’ will appear:

a) Click NEXT or wait for a short time

b) Installing Devices (wait ...)

c) ’Regional Settings’

• Normally you could leave English (United States) for system locale. Set
the right keyboard layout → NEXT

d) ’Personalize Your Software’

• Type in your name and organization → NEXT

e) ’Your Product Key’ (see on the top of the PC):

• Enter the Product ID which is specified on the manual ’Microsoft Win-
dows XP Professional’ (on the Certificate of Authenticity) → NEXT

f) ’Computer Name and Administrator Password’:

• Enter the Name (hostname) you have chosen for your computer

Note that the first character must be alphanumeric and underscores are
not allowed

• Choose an Administrator password and enter it in the field Password,
enter the same password in the field Confirm Password→ NEXT

Important: remember the Administrator password.
g) ’Date and Time Settings’ 

• Check if Date&Time are set correctly, change if necessary

Select the correct time zone for your location, e.g.:

!
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GMT + 01:00 for Germany
GMT - 05:00 for the US east coast
GMT - 08:00 for the US west coast
DONE INDEX• click NEXT

h) ’Networking Settings’ (wait ...)

• Enable Typical Settings→ NEXT

i) ’Workgroup or Computer Domain’

• To get this information contact your system administrator, if you are not
sure at the moment, please choose ’No, this computer is not on a network
...’ and enter the workgroup name → NEXT, please wait ...

j) The text ’Performing Final Tasks’ appears:

• please wait ...

k) The text ’Completing the Windows XP Setup Wizard’ appears:

• click FINISH, the system will reboot

l) Eject the CD-ROM

12. A window ’Network Identification’ will appear → NEXT

a) Users of this computer - who can log on to this computer?

• Enable ’Users must enter a user name ...’, click NEXT → FINISH

You can log in as Administrator using the password which you have entered during
the installation. 

11.2 Installing Windows XP Service Pack

PCs from Bruker Biospin are delivered with the latest Service Pack available at the
time of delivery. Under Windows XP it is not necessary to reinstall the service
pack after e. g. configuring the network. 

The Service Pack can be downloaded from www.microsoft.com or
www.microsoft.de. 

For installation just follow the given instructions on the screen.

http://www.microsoft.com
http://www.microsoft.com
http://www.microsoft.de
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11.3 Installing the Graphics driver 

Hewlett Packard PCs from Bruker BioSpin are delivered with the Graphics driver
DONEINDEX
on the CD. If you do not have a floppy or a CD and want to install a newer driver,
you can download a Graphics driver from the Web. Go to:

http://h20000.www2.hp.com/bizsupport/TechSupport/Product.jsp?prod-
TypeId=12454&prodCatId=296720&locale=en_US&taskId=135

The Graphics drivers are offered as self-extracting .exe files. Just download the
file for your system, then click its icon and insert a formatted floppy. This way, you
can create a new Graphics driver floppy.

The Graphics driver CD can be installed as follows:

1. Insert the Graphics driver CD

2. Click Start → Control Panel

3. A window ’Control Panel’ will appear:

• Double-click the icon Display

4. A window ’Display Properties’ will appear:

• Click Settings 

5. If the window 'Invalid Display Settings' appears: click OK 

6. Click Advanced → Adapter → Properties → Driver → Update Driver→
Next → enable ’Display a List ...’ → Have Disk

7. A window ’Install From Disk’ will appear: 

Enter your CDROM, e.g. d:\ or accept the default if it is correct → Click OK

8. The Graphics driver which resides on the CDROM will appear: Click OK

9. A window ’Third-party Drivers’ will appear:

• Click Yes (to proceed) and wait ...

10. A window ’Installing Driver’ will appear: click OK

11. In the window ’Upgrade Device Driver Wizard’: click Finish 

12. Close the windows you have just opened

13. Remove the CD

14. A window ’Systems Settings Change’ will appear: click Yes (to reboot)

The procedure for other PC’s or other Graphics drivers might be a little different. 

http://h20000.www2.hp.com/bizsupport/TechSupport/Product.jsp?prodTypeId=12454&prodCatId=296720&locale=en_US&taskId=135
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Configuring Windows XP

12.1 Conversion of disk format from FAT to NTFS

Windows XP supports three file systems for disks: FAT16, FAT32, and NTFS. 

Bruker BioSpin TOPSPIN and the datasets of the NMR experiments requires the file
format NTFS. So if you use a FAT-partition of your harddisk(s), you have to con-
vert this partition to 'NTFS' (that is the file system of Windows XP) before you can
install the TOPSPIN. Only under NTFS, it is possible to have the file permissions,
ownership and access management settings that make Windows XP secure. You
can use the convert command convert.exe to convert an existing FAT volume
to NTFS. Because this conversion retains all of your files, use convert.exe
when you want to keep existing files on your volumes intact. 

The conversion to NTFS is a one-way process. After you convert a drive or parti-
tion to NTFS, you cannot convert it back to FAT. To restore the volume to the pre-
vious file system, you must format it as FAT again. This action erases all existing
data including your programs and personal files. In this case, you must either
restore your data from a backup, or reinstall your operating system and programs.

convert.exe requires that you have a certain amount of free space on the drive
or partition to convert it. If convert.exe determines that there is not enough
free space on the volume, it does not convert the volume.
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12.1.1 Check the Disk Partitioning

To check the configuration of the disk(s) of your PC, please start up the Disk
Administrator utility from the command menus as shown below:
DONE INDEX1. Click Start → Control Panel → Administrative Tools 

2. Click on Computer Management → Disk Management

If this is the first time you start Disk Administrator, you probably see two informa-
tion screens which you can confirm by clicking OK, respectively Yes:
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Finally, the disk administrator will show you how many disk drives your system
has, and how they are partitioned.

Please realize that repartitioning the C: partition involves re-installing Win-
DONEINDEXdows XP! 

Also, the maximum partition size with FAT is 4 GByte, with NTFS 7.8 GByte.
Nevertheless, if you decide to make changes in the partitioning now is a good time
to do it because you did not invest too much time in configuration and installation
yet (e. g. the TOPSPIN is not installed and configured so far). All other partitions are
usually empty at delivery of the PC and you can re-partition them or assign differ-
ent drive letters. An other file system format is FAT32 that has the advanced of
none maximum partition size and that could be read by windows 9x, NT and 2000.

12.1.2 Converting partitions from FAT to NTFS

You see that in our case, both C: and D: already have the NTFS file system. If, on
your system, partition D: or any other partition on which you want to store NMR
data is FAT, you can change that from the Disk Administrator. Just click 

All Tasks → Format from the Action menu, select the NTFS file system and Start
formatting. 

Be aware that this will erase the entire partition. 

The C: drive cannot be converted from the disk administrator. It can, however, be
scheduled for conversion during the next boot up. In this way, the entire contents
of C:, like Windows XP, will remain intact. Important: This is again a critical oper-
ation concerning power loss. If the conversion runs and the power goes away it
will render the disk unusable and Windows XP must be re-installed. So it might be
a good idea your PC to connect to an Uninterrupted Power Supply before you
move on.

To convert a drive from FAT to NTFS without loss of data, start a Command
Prompt from the command menus: Then type the following command on the com-
mand line and press return:

convert <drive:> /fs:ntfs

The system will ask you to schedule the actual conversion for the next boot-up and

!
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you will reply with ’y’ as shown below:
DONE INDEX

you do NOT need to re-boot now and wait the 2-3 minutes for it to complete. Just
move on with the operations explained in the next chapter. The conversion to
NTFS will automatically be done during the next re-boot.

12.1.3 Cutting down the re-boot time

1.  Click Start → Control Panel → double click on System

       A window ’System Properties’ will appear:

2. Click Advanced → Startup and Recovery:

The default entry for the time the system waits for your boot selection during boot
up is set to 30 seconds. You can set this entry to 5 seconds which is usually enough
to select a different boot mode (or partition) if you want to do that. 

3. Click OK
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Windows XP Networking 

In order to run TOPSPIN, you must setup the network (TCP/IP protocol), even if

your PC is not connected to a spectrometer or to the laboratory network.1 You can
setup the network as a so-called Domain scenario or as Workgroup scenario. This
chapter describes the Workgroup scenario.

13.1 TCP/IP configuration

This chapter describes how to install both the laboratory network (Workgroup sce-
nario) and the spectrometer internal network for a ’hp workstation xw4400’. The
description for other PC’s with a different Ethernet card might be a little different.
Before you start, make sure all network hardware components (network card,
adapter, cables etc.) are properly connected. Then make a list of the following
information: 

• IP address for the PC in the laboratory network 

• subnet mask of the laboratory network

• DNS domainname of the laboratory network

• IP address of the DNS nameserver(s) (if a nameserver exists) 

1.  The TOPSPIN license requires TCP/IP to be installed.

!
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• IP address of the default gateway (if a default gateway exists)

If your PC is not physically connected to the laboratory network, you can use any
IP address, subnet mask and domainname for the (external) network configuration.
DONE INDEXA frequently used IP address for such a ’standalone’ computer is 192.168.0.1. This
address is not assigned to any network computer (by world-wide-agreement).
However, for the spectrometer internal network, you must use the values as speci-
fied below.

Perform the following steps according to the necessities of your setup: 

13.1.1 Create a New Network Connection

1. Log in as Administrator

2. Click Start → Control Panel → Network Connections

3. A window Network Connections will appear

4. Click on Create a new connection on the left side of the window

5. A window Network Connection Wizard will appear → NEXT

6. Enable Connect to the Internet → NEXT

7. A window Now Getting Ready will appear

8. Enable Connect using a broadband connection that is always on → NEXT

9. A window Completing the New Connection Wizard will appear → Click FIN-
ISH

13.1.2 Configuring the TCP/IP of an existing Network Connection

1. Log in as Administrator

2. Click Start → Control Panel → Network Connections

3. A window ’Network Connections’ will appear

4. Highlight the connection you want to configure  → File → Properties

5. Highlight the TCP/IP entry and click Properties

6. The window ’Internet Protocol (TCP/IP) Properties’ will appear:

7. Enable ’Use the following IP address’

b) In the field IP Address: enter the IP address of your computer

c) In the field Subnet Mask: enter the subnet mask of your network
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e.g. 255.255.255.0 or 255.255.0.0

d) In the field Default Gateway: enter the IP address of the Default Gateway
in your network (if available)
DONEINDEXe) If you have a nameserver:

• In the field Prefered DNS Server enter the IP address of the nameserver

• If you have a second nameserver enter his IP address in the field ’Alter-
nate DNS server’

f) Click Advanced → DNS

g) Enable the field Append these DNS suffixes (in order) → Add

• In the window ’TCP/IP Domain Suffix’: 

Enter the network domainname  → Add

h) Click OK

i) If the question appears:

’This connection has an empty primary WINS address. Do you want to con-
tinue?’ → YES → OK → OK → CLOSE

13.1.3 Configuring the TCP/IP with DHCP of an existing Network 
Connection

This chapter describes how to configure the TCP/IP of an existing Network Con-
nection for DHCP (Dynamic Host Configuration Protocol)

1. Log in as Administrator

2. Click Start → Control Panel → Network Connections

3. A window ’Network Connections’ will appear

4. Highlight the connection you want to configure  → File → Properties

5. Highlight the TCP/IP entry and click Properties

6. The window ’Internet Protocol (TCP/IP) Properties’ will appear. Select the
options:

• Enable IP address automatically



160 Windows XP Networking

INDEX

• Enable DNS server address automatically
DONE INDEX

7. Click on Advanced. A window ’Advanced TCP/IP Settings’ will appear:

8. Ensure that the Default gateways box is empty. If not: select each entry and
click on the Remove button. 
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9. Select the DNS tab.
DONEINDEX

10. Select the Register this connection's addresses in DNS option. 

11. Check that the DNS server addresses, in order of use and Append these DNS
suffixes (in order) boxes are empty. If not: select each entry and click the
Remove button. 

12. Select the WINS tab. 

13. The WINS addresses, in order of use should be empty. If not: select each
entry and click the Remove button. 

14. Click → OK → OK → CLOSE

15. If you are asked to restart your computer: Click Yes.

16. After your computer has been restarted, Windows will automatically request
network information from the DHCP server. 

13.1.4 Configuring the TCP/IP of the Spectrometer Control:

1. Log in as Administrator

2. Click Start → Control Panel → Network Connections

3. A window ’Network Connections’ will appear

4. Highlight the connection you want to configure → File → Properties

5. Highlight the TCP/IP entry and click Properties

6. The window ’Internet Protocol (TCP/IP) Properties’ will appear:!
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• In the field IP Address: enter 149.236.99.1

• In the field Subnet Mask: enter 255.255.255.0
DONE INDEX
For the spectrometer network ONLY THESE VALUES ARE VALID!

Do not choose different settings for the IP address or Subnet mask.

• Leave the Field Default Gateway empty

7. Click OK

If your PC controls a spectrometer we recommend to do the following: 

1. Click Start → Control Panel → Network Connections

2. A window ’Network Connections’ will appear: 

a) Select the Adaptor to which the spectrometer CCU is connected. This is nor-
mally, but not necessarily Adaptor 2. 

b) Right mouse click → Properties

c) Disable the entry Client for Microsoft Network (TCP/IP) by clicking on
the ’+’ sign to the left of the entry

13.2 Changing the hostname of the computer and its effects

If you want to change the hostname of your PC you can do this in the following
way. IMPORTANT: You also have to change the text-file:

<TOPSPINHOME>\conf\nmrsuperuser

This file contains the computer-name and the Windows XP user which is the TOP-
SPIN-SUPERUSER. You can edit and change this file with a normal text editor like
notepad if you are logged in as the Windows XP-user which is the NMRSUPE-
RUSER.

1. Log in as Administrator

2. Click Start → Control Panel → Network Connections 

3. A window ’Network Connections’ will appear: 

a) Click Advanced → Network Identification

b) A window ’System Properties’ will appear

c) Click Network Identification → Properties

!
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d) In the field Computer Name: enter the new hostname

Note that the first character must be alphanumeric and underscores are not
allowed!
DONEINDEXe) Click OK 

4. A window ’Network Identification’ will appear: 

• Click OK 

5. In the window ’System Properties’: 

• Click Close

6. A window ’System Setting Change’ will appear: 

• Answer the question if you want to restart the computer now by clicking Yes

7. If you have Floating licenses you must change the hostname in the file
license.dat. By default it resides in C:\flexlm\Bruker\licenses.
You can do this in the following way:

a) Click Start → All Programs → Accessories → Command Prompt

b) Enter: cd c:\flexlm\Bruker\licenses

c) Enter: notepad license.dat

• Change the hostname in the SERVER line, then save and exit the file.

Of course, you can also change the license file from the Explorer. We have cho-
sen the Command Prompt because the Explorer might add the (hidden) exten-
sion .txt to the file license.dat which makes it unusable (see chapter
16.1.3).

13.3 Network diagnostic commands

Here is a list of the most important network diagnostic commands as they can be
entered from the Command Prompt:

• arp - displays or modifies the IP to physical address translation tables 

• hostname - displays the name of the current host 

• ipconfig - displays information about the current TCP/IP configuration 

• netstat - displays protocol statistics and current TCP/IP connections 

• ping - checks if a destination host is receiving TCP/IP packets 
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• route - maintains and displays routing tables 

• tracert - displays the route packets take to a destination host
DONE INDEX
• net start - displays all running services

• net use - display current network connection

• nbtstat -a - displays all registered NetBIOS names

13.4 Accessing remote files and directories 

13.4.1 Sharing directories from a Windows XP host

Network operations under Windows XP primarily takes place via the Windows XP
sharing mechanism. For example, you can share the data directory c:\data on
nthost_a by taking the following steps:

1. Log in as Administrator on nthost_a

2. Open drive C: in the Explorer

3. Right-click on data

4. A popup window will appear:

Click Sharing and Security

5. A window ’Data Properties’ will appear:

a) Click Share this folder

• Accept the default shared name data, or enter any other name 1

• Optionally, you can enter a comment

b) Optionally, you can set a user limit and/or shared permissions
(note that the default permissions are Full Control for Everyone)

c) Click OK

The directory c:\data can now be accessed from any Windows XP host in the
network, e.g. from nthost_b, in the following way:

1. Log in on nthost_b as normal user 

2. Click the icon My Network Places on the desktop 

1.  This is the name under which the directory can be accessed from other hosts
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3. A list of hosts in the network will appear: 

• Double-click the icon of nthost_a 
DONEINDEX
4. A window ’Enter Network Password’ will appear: 

a) In the field Connect As: enter the name of any user on nthost_a 

b) In the field Password: enter the password for this user

→ A list of shared partitions/directories will appear 

(The network password is only requested for the first connection). 

Now you can: 

• Access the remote directory as if it were local 

• Copy the remote directory or any sub-directory or file in it, by dragging the
corresponding icon into any target directory window (assuming you have
the write permission in the target directory).

Note that the latter is only useful if the remote directory is not permanently shared. 

13.4.2 Enabling and disabling Simple File Sharing

A PC under Windows XP Professional that is joined to a workgroup has the Sim-
ple File Sharing enabled by default. The Simple File Sharing is located in the
folder's properties. When you set the Simple File Sharing the share and the file per-
missions are configured.

A Windows XP Professional PC that is joined to a domain use only the classic file
sharing and security interface.

If you disable Simple File Sharing, the Shared Documents feature is not turned off. 

You have more control over the permissions to individual users, if you disable the
Simple File Sharing, However, you must have advanced knowledge of NTFS and
share permissions to keep your folders and files secure. 

It is recommended that you share folders only on the network within your user pro-
file that remote users on other computers need to access. Never ever share the root
of your system drive. In this case your computer is more vulnerable to malicious
remote users.

To turn Simple File Sharing on or off: 

!
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1. Double-click My Computer on the desktop. 

2. Click on Tools, select Folder Options. 
DONE INDEX
3. Click the View tab, then click to clear the Use Simple File Sharing (recom-

mended) check box to disable Simple File Sharing.

4. Click OK.

Levels of Access

There are five levels of access:

1. Level 1: My Documents (Private)

2. Level 2: My Documents (Default)

3. Level 3: Files in shared documents available to local users

4. Level 4: Shared Files on the Network (Readable by Everyone)

5. Level 5: Shared Files on the Network (Readable and Writable by Everyone)

In Levels 1, 2, and 3 folders are available only to a user who is logging on locally.
Levels 4 and 5 folders are available to users who log on locally and remote users
from the network .

You can have the following permissions:

Access 
Level

Everyone 
(NTFS/File)

Owner System Administrators Everyone 
(Share)

Level 1 no Full
Control

Full
Control

no no

Level 2 no Full
Control

Full
Control

Full
Control

no

Level 3 Read Full
Control

Full
Control

Full
Control

no

Level 4 Read Full
Control

Full
Control

Full
Control

Read

Level 5 Change Full
Control

Full
Control

Full
Control

Full
Control
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1. Level 1: My Documents (Private)

Only the owner of the file or folder has the permission to read and write to the
file or folder. All subfolders that are contained within a folder that is marked as
DONEINDEX
private remain private unless you change the parent folder permissions. The op-
tion to make a folder private is only available to a user account in its own My
Documents folder.

To Configure a folder and all of the files in it to Level 1: 

a) Right-click the folder → click Sharing and Security.

b) Click to select the Make this Folder Private check box → click OK.

2. Level 2 (Default): My Documents (Default)

Only the owner of the file/folder and a local administrator have the permission
to read and write to the file/folder. This is the default setting for all of the folders
and files in each user's My Documents folder.

To configure a folder and all of the files in it to Level 2: 

a) Right-click the folder → click Sharing and Security. 

b) Ensure that both the Make this Folder Private and the Share this
folder on the network check boxes are cleared → click OK.

3. Level 3: Files in Shared Documents Available to Local Users

Files are shared with users who log on to the computer locally. Local adminis-
trators and Power Users can read, write, and delete the files in the Shared Doc-
uments folder. Restricted Users can only read the files in this folder. In order to
allow Remote Users to access folders/files at Level 3, you must share them out
on the network (Level 4 or 5).

To configure a file/folder and all of the files in it to Level 3:

a) Start Microsoft Windows Explorer

b) Copy or move the file/folder to the Shared Documents folder under My
Computer. 

4. Level 4: Shared on the Network (Read Only)

For everyone on the network and local users (including the Guest account (if ac-
tivated)) the files are shared to read. But they are not allowed to modify the con-
tents. User that can connect to the computer on the network are able to read and
change these files. 

To configure a folder and all of the files in it to Level 4:
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a) Right-click the folder  →  click Sharing and Security. 

b) Click to select the Share this folder on the network check box 
DONE INDEX
c) Click to clear the Allow network users to change my files check box →

click OK.

5. Level 5: Shared on the Network (Read and Write)

This level is recommended only for a closed protected network that has a fire-
wall configured.

This level is the most available and least secure of all access levels. Any user can
read, write, change, or delete a file in a folder shared at this access level.

To configure a folder and all of the files in it to Level 5: 

a) Right-click the folder → click Sharing and Security 

b) Click to select the Share this folder on the network check box → click
OK.

NOTE: All NTFS permissions that refer to Everyone include the Guest account. 

13.4.3 Sharing directories from a UNIX host using Samba

If you are logged in on a Windows XP host, you can access data which reside on a
UNIX host, using the sharing mechanism. This, however, only works if the Samba
package is installed on the UNIX host. For further information please see the TOP-
SPIN Installation Guide for Linux. You can download this Installation Guide as the
up to date version from the Bruker web-server:

http://www.bruker-biospin.de/NMR/nmr-
softw/passwd/docu/index.html

13.4.4 Mounting Windows XP partitions from a UNIX host using NFS

If your PC is controlling a spectrometer, installation of the Hummingbird NFS
Server is mandatory. The partition C:\Bruker\Diskless\clients\spect
is mounted via NFS by the spectrometer CCU (which is a UNIX host). In the same
way, you can mount any Windows XP partition or directory on any UNIX host.
Proceed as follows: 

1. Export the Windows XP partition as described in chapter 6.6.1. In step 4, you
must enter the partition and, optionally, the UNIX host(s) to which it must be
exported.

http://www.bruker-biospin.de/NMR/nmrsoftw/passwd/docu/index.html
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2. On the UNIX host: 

a) Open a UNIX shell

b) Type su to become superuser
DONEINDEXc) Create a mount directory, e.g. mkdir /ntdata

d) mount the partition, e.g.: 

• on SGI: mount nthost:/c/data /ntdata

• on X32: mount -f NFS nthost:/c/data /ntdata

Note that, if the pathname on the Windows XP hosts contains uppercase let-
ters, these must also be specified with the mount command. 

13.4.5 FTP 

Network transfer under Windows XP is generally done via the directory sharing as
described in chapter 13.4.1 and 13.4.3. Nevertheless, Windows XP supports trans-
fer via FTP. Just enter ’ftp hostname’ from a Command Prompt and you can
transfer files.

13.4.6 Telnet

Windows XP contains a telnet command for remote login. Just enter telnet
hostname in a Command Prompt to login to a remote host. The telnet command
can only be used to login from your PC to a remote host (e.g. a UNIX host) but not
vice versa. 

With Windows XP it is also possible to do a telnet login to a Windows XP compu-
ter but this feature is not very convenient.

13.5 Outlook Express

Alternatively to printing and faxing diagnostics results to Bruker BioSpin or some-
where else, you can send the same information via electronic mail. For this to
work, the spectrometer PC needs access to the Internet, i.e. to an Internet gateway
in your local network. 

Install a program that allows for composing and sending e-mail messages. If you
have Microsoft Internet Explorer 6.0 or newer, we recommend to install it. Inter-
net Explorer is bundled with an e-mail application called Outlook Express.
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13.5.1 Installation and configuration of Outlook Express

Outlook Express gets automatically installed with Microsoft Internet Explorer 6.0
or newer.
DONE INDEX• Open Start → All Programs →Outlook Express

• or double-click the Outlook Express icon on the desktop. 

Supply all parameters asked for by the setup wizard. Contact your network admin-
istrator if you are not sure what to fill in. 

Select Options from Outlook Express’ Tools menu and configure the General Set-
tings as shown below.

Outlook Express version 6 is able to handle the default mail handling and the sim-
ple MAPI client as one. It is sufficient to enable the setting as default mail program

Do not reboot the computer now. Open the Options interface again, switch to the
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Send page and select the topics as shown below. 
DONEINDEX

Switch to the Security page and disable Warn me when other applications try to
send mail as me, then reboot the computer.

To disable this warning might be a security leck. If you do not disable this warning,
you get a warning every time if ICON-NMR send an e-mail.

13.5.2 Sending an e-mail with Outlook Express
• Fill in the correct recipient’s address.
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• Click the Send button.

If you want to use an e-mail application not mentioned here, make sure it has some
’use as simple MAPI client’ feature and activate it. 
DONE INDEX
13.6  Installing the TOPSPIN in a Windows XP Domain

Windows XP provides two different security scenarios for computer networks, the
Workgroup and the Domain scenario. With a Workgroup scenario, each computer
has its own local security database of user accounts and passwords. This means
that users from workstation A are not known at workstation B. They might have
the same name on both workstations but internally they are represented by two dif-
ferent security identifiers. Users from workstation A can access files on worksta-
tion B via the sharing mechanism (see chapter 13.4.1). The Workgroup scenario is
typically used for small networks. For large networks, the Domain scenario is usu-
ally preferred. In this case, one computer (the Domain Controller, DC) maintains
the security database for an entire group of Windows XP Computers. A Domain
user can log on at each workstation in the Domain with a single account and pass-
word. Furthermore, the Domain Administrator’s account has administration rights
on every computer in the Domain. Nevertheless, a local Administrator account
exists on each computer for local administration tasks.

Bruker BioSpin TOPSPIN fully supports both security scenarios. The description of
the TOPSPIN installation in chapter 6.4 is valid for a Workgroup scenario. This
chapter describes the additional installation steps which are required for a Domain
scenario. The NMR Superuser (see chapter 6.2), which is specified during the
installation of TOPSPIN can now be a local account or a Domain account. In both
cases the NMR Superuser only needs standard access permissions. The installation
of TOPSPIN, however, requires Administrator rights because certain system serv-
ices and two user groups are installed. Furthermore: 

TOPSPIN must be installed as local Administrator

This means no Domain-wide administrative tasks are done during the installation.
The installation of TOPSPIN in a Domain involves the following steps: 

1. Make sure that there is a Local or Domain account for NMR Superuser, or cre-
ate one.

2. Installation of TOPSPIN by the local Administrator.
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3. Creation and configuration of global groups of NMR users by the Domain
Administrator.

4. Make sure that all nmr users have an existing HOME directory 
DONEINDEXAs an example, we use a Domain \\NMRLAB with two workstations; \\NTSPEC
which controls a spectrometer and \\NTPROC which is used for processing. The
security database resides on the Domain Controller \\BOSS. Step 2, the installation
of TOPSPIN is the same on \\NTSPECT and \\NTPROC so it will only be described
for \\NTSPEC. 

13.6.1 Creating an NMR Superuser account

Before you install TOPSPIN, you have to make sure that there is an account for
NMR Superuser. If there is none which you like to use, create a new one. Accord-
ing to your preference this can either be a local or a Domain account. 

a) Creating a local NMR Superuser account

If you prefer a local NMR Superuser, do the following: 

1. Log on at Windows XP Professional Workstation \\NTSPEC as the local
Administrator or any other user who has User Administration rights, select-
ing \\NTSPEC as Domain. 

       

\\NMRLAB

            \\NTSPEC 

    
 

 TopSpin

 

  TopSpin

 

\\NTPROC

  \\BOSS 

   Win-Server

Controller(DC)
    Domain

Spectrometer
Datastation

 XP-ProfessionalXP-Professional
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2. Open the User Manager and create an account for the NMR Superuser, e.g.
with the name nmrsu. (see also chapter and 9.1).

b) Creating a Domain NMR Superuser account
DONE INDEXIf you prefer a Domain NMR Superuser, do the following:

1. Log on at the Domain Controller \\BOSS as the Domain Administrator.

2. Open the User Manager and create an account for the NMR Superuser, e.g.
with the name nmrsu (see also chapter and 9.1).

Note that the installation of TOPSPIN, which must be done as local Administrator,
relies on the fact that the NMR Superuser was correctly installed. It cannot check
if a Domain NMR Superuser really exists.

c) Installing TOPSPIN

The installation of TOPSPIN involves the following steps:

1. Log on as local Administrator on Windows XP Professional \\NTSPEC.

2. Install the TOPSPIN as described in chapter 6.4. 

During the installation process, you will be asked for the NMR Superuser. Enter
the name of the NMR Superuser account as created before (see chapter 13.6.1).

After the installation process, NMR users cannot start TOPSPIN yet. First they
must be added to the local group NmrUser. Users with a local account, e.g. lo-
calnmrusera can simply be added to NmrUser as described in chapter 9.1.3.
However, for users with a Domain account, which is typical in a Domain scenar-
io, we recommend to use global groups as described in chapter 13.6.2.

13.6.2 Installing global user groups

The TOPSPIN installation program creates a local group NmrUser. Each user who
wants to use TOPSPIN must be a member of this group. Domain users could be
added individually to the local group NmrUser but, in a network with many Work-
stations and varying users, this would be an elaborate task. Therefore, we recom-
mend to create so called global user groups. Global groups are created by the
Domain Administrator on the Domain Controller. Each global group contains
users who are allowed to do certain tasks, e.g. start TOPSPIN on a specific spec-
trometer or datastation. These global groups are then added to the local group
NmrUser on the various Workstations in the network. In our example, the Domain
Administrator creates the global groups SpecUsers and ProcUsers which are then
added to the local group NmrUser on \\NTSPEC and \\NTPROC respectively. After
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that, for example, the global user spec_usera can control the spectrometer from
Workstation \\NTSPEC. By managing these global groups on the Domain Control-
ler, the Domain Administrator can control which users can use the spectrometer
DONEINDEX
and which can use the datastation. In practice, one global group will be added to
the local group NmrUser on several Workstations and NmrUser on one Worksta-
tion can contain several global groups.

The installation of the global user groups involves the following steps:

1. Log on at the Domain Controller as Domain Administrator. 

2. Create the global groups SpecUser and ProcUser. 

3. Log on as local Administrator at workstation \\NTSPEC, selecting \\NTSPEC as
Domain. 

4. Add the global group NMRLAB\SpecUser to the local group NmrUser as

\\BOSS  Win XP Server

Global groups:
SpecUser
ProcUser
..

Members of SpecUser
spec_usera
spec_userb
..

   \\NTSPECT
Win XP Professional          Win XP Professional

Groups:
  Administrators
  ..
  NMRUser
  NMRSuperUser 

Members of NMRUser
  Localnmrusera
  ..
  NMRLAB\SpectUser

\\NTPROC

Groups:
Administrators
..
NMRUser
NMRSuperUser

Members of NMRUser
     Localnmrusera

  ..
NMRLAB\ProcUser

\\NMRLAB
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described in chapter 9.2.4. 

5. Repeat step 3 and 4 for \\NTPROC adding NMRLAB\ProcUser to the local
group NmrUser.
DONE INDEX
13.6.3 Check for the HOME directory of every nmr users

There are two possibilities for the HOME directory of an user, local on every PC or
fixed on one PC in the domain. Bruker supports both scenarios, the last one is a lit-
tle bit more convenient, because the resource file (used by command ’setres’) of
TOPSPIN is stored in the home directory of the user. If there are individual settings
it is easier to have to create this file only once and use it on all TOPSPIN installa-
tions of the windows domain.

Note that the configuration of TOPSPIN relies on the fact that the given HOME
directory of an user exists. The HOME directory cannot be created by TOPSPIN.
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Installing a Printer

Printers must be installed at a Windows XP level and can then be used in TOPSPIN

and TOPSPIN PLOT EDITOR. 

14.1 Installing a new local printer

Installing a local printer implies installing the software, e.g. the printer driver for
that printer. You can get printer drivers from various sources: 

1. From a CDROM or floppy which was delivered with the printer:
Please follow the instruction in the printer installation guide. If you do not have
one, just insert the floppy or CDROM. The Setup program might start automat-
ically. If it does not, open the Explorer and find a file named Setup or
Install and click it.

2. From the Web:
Just go to the manufacturers Web home page, e.g. www.hp.com,
www.canon.com or www.epson.com and look for Download or Drivers.
Usually, an executable file can be downloaded which can be unpacked and
installed, simply by clicking on it. 

3. From the Windows XP CDROM:
If you do not have a CDROM or floppy with printer software and no Web
access you can install a printer driver from your Windows XP CD. You will get

http://www.hp.com
http://www.hp.com
http://www.canon.com
http://www.epson.com
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a list of printers for which a driver was available at the time your Windows XP
version was released. If your printer type does not appear, you can select a
related printer. However, Bruker BioSpin does not guarantee that this will work
DONE INDEX
(see chapter 14.1.1 for installation instructions). Note: 

Bruker BioSpin does not supply printer drivers for Windows XP!

14.1.1 Installing a printer from the Windows XP CDROM

A large number of printer drivers are available on the Windows XP CDROM. Note
that these are the drivers which were available at the time Windows XP was
released. For older printers these are usually valid. For newer printers the drivers
might not be on the CD or better drivers might be available. Please use drivers
delivered with the printer or from the Web whenever possible.

You can install a printer from the Windows XP CD as follows: 

1. Log in as Administrator

2. Click Start → Printers and Faxes

3. A window ’Printers’ will appear: 

• Double-click the icon Add Printer

4. A window ’Add Printer Wizard’ will appear: → Click NEXT

a) Click Local Printer, enable Plug and Play search mode if you want that the
system looks for a new printer → Click Next

b) A window ’New Printer Detection’ will appear

• if the system finds a right printer → Click Next

• if the system does not find a printer define it manually during the next
steps → Click Next

c) Select the port to which the printer is connected → Click Next

d) In the field Manufacturers: select the manufacturer of the printer, e.g. HP

e) In the field Printers: select the type of the printer

If your printer does not appear in the list, select a related printer type or click
Cancel and get the driver from the Web.

f) Click Next

g) In the field Printer Name: enter the name under which you want to use the
printer (or accept the default name)
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h) If other printers are already installed, you will be asked if the new printer
must be the default printer: 

• If you want to use this printer as default printer → Click Yes
DONEINDEX• If you do not want to use this printer as default printer → Click No

i) Click Next

j) ’Printer Sharing’: Do one of the following: 

If the printer must be available for other computers in the network:

• Click Shared 
• In the field Share Name: enter the name by which the printer can be

accessed from a remote host, e.g. viola_deskjet
• Click Next
• A window ’Location and Comment’ appears. Write in some informa-

tions about the location, the printer administrator and individual print-
er specifications (e. g. the fax-default-printer etc.) → Click Next.

If this printer should only be used on the local computer:

• click Not shared. 
k) Click Yes (to print a test page) → Click Next → Click Finish

5. If the window ’Insert disk’ appears:

• Insert the CDROM ’Windows XP Professional’ → Click OK 

6. A window ’Files Needed’ will appear:

• Click OK (to copy the Driver files for your printer from the CD)

7. A new icon will appear in the window ’Printers’ (see step 3): 

a) Click the right mouse button on the new printer’s icon

b) Click Printing Preferences in the pop-up menu

8. A window ’Printing Preferences’ will appear:

a) Click Advanced

a) Click in the Field Paper Size

b) Select the correct paper size for your printer

c) Click OK → OK

Step 8 makes sure that applications like Word, Excel, Paint and TOPSPIN ... will use
this paper size as default.
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14.2 Remote printing from a PC to a PC
DONE INDEX
14.2.1 On the PC to which the printer is physically connected

If the printer is not installed yet:

• Install the printer as described in chapter 14.1. During this installation you
have to choose between ’shared’ and ’not shared’; click Shared

If the printer is already installed as a local printer: 

a) Log in as Administrator

b) Click Start → Printers and Faxes

c) Click the right mouse button on the printer icon and select Sharing ...

d) A window ’<printer name> properties’ will appear: 

• Click Shared

• In the field Share Name: enter the name under which the printer can be
accessed on the network, e.g. viola_deskjet

• Click OK 

e) Close the window ’Printers’ by clicking the X button

14.2.2 On the PC from which you want to print

1. Click Start → Printers and Faxes

2. A window ’Printers’ will appear: 

• Double-click the icon Add Printer

3. A window ’Add Printer Wizard’ will appear:

a) Click Network printer

b) Click Next

c) A window ’Locate your printer’ will appear, enable one of the three fields
under the point ’What Do You Want To Do’

• ’Find a Printer in the Directory’ is a powerful search tool that is looking for
a printer with the properties you want in the active directory if you are mem-
ber of domain

• Click Next, a window ’Find Printers’ will appear:
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• Choose the domain path in the field ’In’

• In the menu ’Features’ you have the possibility to enable some addi-
tional search modes like resolution, paper size etc. 
DONEINDEX• Click Find Now

• ’Type the Printer Name ...’

• Use this option if you already knows whats the name of the printer you
want to install (use the form //<Print-Server>/<Printer-Name>) or if you
want to start a search in the subdomain of your network 

• Click Next

• ’Connect to a Printer ...’

• Use this option if you want to connect to a internet printer that has an
own URL address

Wait until list of shared printers on that UNIX host appears. If this list does not
appear within one minute, click the Network Connections icon on the desktop
and try to connect to the remote host. Then go back to the window ’Connect to
printer’, click the remote host again and see if get a list of shared printers now.

4. The window ’Add Printer Wizard’ will appear: 

a) Do one of the following: 

• Click Yes if you want to use this printer as default printer 

• Click No if you do not want to use this printer as default printer

b) Click Next, click Finish

14.3 Remote printing from a UNIX host to a PC

14.3.1 On the PC to which the printer is physically connected

Install the printer as described in chapter 14.2.1. 

1. Log in as Administrator

2. Insert the CDROM ’Windows XP Professional’

3. Close the window ’Windows XP CDROM’ by clicking Exit

4. Click Start → Control Panel → Network Connection

!
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5. A window ’Network and Dial-up Connection’ will appear: 

• Click on the pull down menu Advanced → Optional Network Component
DONE INDEX
6. A window ’Optional Network Component’ will appear: 

• Enable Other Network File and Print Services

• Click on Networking Services to highlight it then click Details 

• enable Simple TCP/IP Services → OK 

• The check box for Other Network File and Print Services is now white
and that one for Networking Services grey and both have a tick, click Next

7. Click Start → Control Panel → Administrative Tools → Services

8. A window ’Services’ will appear: 

a) Scroll down and check the following entries: 

• Simple TCP/IP Services
• Print Spooler
• TCP/IP Print Server

If one of these entries is set to manual: 

• Click that entry to highlight it
• Click Action → Properties → Startup type → select Automatic →

OK
9. Click Start → Turn Off Computer → Restart → Yes

14.3.2 On the UNIX host from which you want to print

On the UNIX host, you must setup a network printer as follows: 

1. Open a UNIX shell

2. Become superuser; type su

3. Edit the file /etc/printcap and make an entry like: 

laserjet|HP :\
:rm=viola.netx.applic.com:\ 1

:rp=hplj4ml:\
:sd=/usr/spool/lpd/hplj4ml:\
:sh:

1.  Depending on your network you must enter hostname or hostname.domainname
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where: 

• laserjet is the name for the printer on the UNIX host
DONEINDEX
• viola.netx.applic.com is the hostname.domainname of the PC

• hplj4ml is the name of the printer on the PC

4. Create the spooling directory which is specified in /etc/printcap:

a) mkdir -p /usr/spool/lpd/hplj4ml 

b) chown daemon.daemon /usr/spool/lpd/hplj4ml 

c) chmod 770 /usr/spool/lpd/hplj4ml 

More information on network printing under UNIX can be found in the manual
netprint which is available on:

http://www.bruker-biospin.com/documentation_nmr.html

 and as ’Network Printing’ in the TOPSPIN online help.

14.4 Installing a printer with a JetDirect print server

If your printer is connected to the network via a HP JetDirect print server, you
must install it in the following way:

1. Log in as Administrator

2. Install the Service Microsoft TCP/IP Printing as described in chapter 14.3.1. 

3. Click Start → Printers and Faxes

4. A window ’Printers’ will appear: 

• Double-click the icon Add Printer

5. A window ’Add Printer Wizard’ will appear: 

a) Click Next → Local Printer, disable ’Automatically detect and install my
Plug and Play Printer’, click Next

a) Enable Create New Port select Type LPR Port → Next 

6. A window ’Add LPR compatible printer’ will appear: 

a) In the field Name or Address of server providing lpd: enter the name or IP
address of the Print Server. 

b) In the field Name of printer or print queue on that server you must enter: 

• raw1 if you have an internal JetDirect adapter

http://www.bruker-biospin.com/documentation_nmr.html
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• raw1, raw2 or raw3 if you have an external JetDirect print server,
depending on the JetDirect port to which the printer is connected.

c) Click OK
DONE INDEX7. In the window ’Printer Ports’:

• Click Close

8. In the window ’Add Printer Wizard’: 

• Click Next

9. Continue the installation as described in chapter 14.1.1, step 4d.
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Troubleshooting

15.1 General checks

15.1.1 Windows XP Services

The TOPSPIN requires the following Windows XP Services to control a spectrome-
ter. Proceed as follows: 

1. Click Start → Control Panel → Administrative Tools

2. Double-click Services

3. A window ’Services’ will appear:

At least the following services should appear with status Started: 

• Bfs 

• Bootparam

• Bruker FLEXlm License Server (only if the PC has a local license. If the
license server is a remote machine, the FLEXlm service has to be started
only there)

• Hummingbird Inetd 1

1.  These service is only required for AVANCE and AVANCE-II spectrometers.
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• Hummingbird NFS Server 1

• Hummingbird Port Mapper 1

2

DONE INDEX
• Bruker DHCP Server 

• Bruker tftpd32

• Schedule

Note that this list only contains the Services required for the TOPSPIN. Several
other Services are required for Windows XP and possibly for other software
packages on your system. 

4. If one or more of these services are not running: 

• Reboot the computer and check again

5. If rebooting does not solve the problem, then proceed as follows: 

If bfs and/or bootparam are not running: 

• Re-install TOPSPIN and DISKLESS (see chapter 6.4)

If the Hummingbird NFS Server and/or Port Mapper are not running:

• Remove the NFS Server directory 

(normally C:\Program Files\NfsSrvr.nt)

• Re-install the NFS Server (see chapter 4.3)

If the Bruker DHCP Server is not running:

• Please see chapter 15.6

6. Carefully check the NFS Server configuration (see chapter 6.6). 

15.1.2 The Event Viewer

If you have any problems on your Windows XP host, it is always a good idea to
look at possible Events which caused them: 

1. Click Start → Control Panel → Administrative Tools → Event Viewer

2. A window ’Event Viewer’ will appear:

• Click Application Log to see Application Events

• Click System Log to see System Events

1.  This service has to run only on AVANCE and AVANCE-II spectrometers.
2.  This service has to run only on spectrometers with a BSMS rack with ECLB board.
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• Click Security Log to see Security Events

3. Double-click on an Event to get more information on it. 
DONEINDEX
4. Note that Events do not necessarily indicate problems. If fact, there are three

type of events: Information, Warning and Error. 

To prevent the Event Log from getting full we recommend to do the following: 

5. Click on one of the three Log’s, e. g. System Log  → Action → Properties

6. A window ’System Log Properties’ will appear: 

7. Set the ’When maximum log size is reached’ to one of the following:

•  Overwrite Events as Needed 

•  Overwrite Events Older than 7 Days

15.2 TOPSPIN does not start

If TOPSPIN does not start, you should first look for an error message in the window
where the TOPSPIN startup messages appear. Then check if you have one of the fol-
lowing problems:

1. A window ’Choose Server or File’ appears: 

The file license.dat was not found. You might have one of the following
problems: 

• The Flexlm license manager is not installed

→ Install Flexlm license manager from the TOPSPIN CDROM

• license.dat has been deleted or renamed

→ Setup the file license.dat as described in chapter 7.2.3. 

• license.dat has a (hidden) extension .txt or .example

→ Rename the file to license.dat

2. If hostid ’0’ or ’ffffffff’ occurs: 

You may run Windows XP and your network-adapter has no link to the network.
Establish an link to the network or install the

NWlink IPX/SPX/NetBIOS Compatible Transport Protocol:

a) Click Start → Control Panel → Network Connections

!



190 Troubleshooting

INDEX

b) Right-click Local Area Connection xxx

c) Click Properties → Install... → Protocol → Add

d) The Select Network Protocol-menu will appear after some seconds.
DONE INDEXClick NWlink ... → OK

e) After some seconds the Properties-menu will reappear → Click Close

3. ’Cannot connect to license server... WinSock Error code...’

The file license.dat was found, but Flexlm does not run. Maybe:

a) Flexlm is not installed: → Install Flexlm from the TOPSPIN DVD

b) the Service (Bruker) Flexlm license server is not running: 

→ Click Start → Control Panel → Administrative Tools

• Double-click Services

• A window ’Services’ will appear:

• Select Flexlm..., click Start 

4. ’Server node is down or not responding (-96,379)’

The server could not answer because he is down, the entry <SERVER-NAME>
in ’license.dat’ is wrong or the server has been wrong configured:

→ Check if the server in the ’license.dat’ file is down:

• Click Start → All Programs → Accessories → Command Prompt

• type ’ping <SERVER-NAME>’ and check if the correct reply occurs:

a) A reply like this:
Reply from <SERVER_IP_ADRESS>: bytes=32 time<10ms

TTL=128 shows that the server is okay.

b) A reply like this: ’Request timed out’ shows that the server is down

c) A reply like this: ’Bad IP address <SERVER-NAME>’ shows that the
<SERVER-NAME> is wrong or the server is not correctly configured.

→ Check if the entry of the server in the ’license.dat’ file is wrong
(wrong name, blanks, ...), if so correct it.

→ Check if the server has a wrong configuration, e. g. TCP/IP protocol or
NetBIOS network service is not installed. For this you should have a look
at:

• Start → Control Panel → Network Connections 
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• Click on the LAN entry of your ethernet card → File → Settings

• A window ’Local Area Connections Properties’ will appear
DONEINDEX
• Look if there is an entry ’Internet Protocol (TCP/IP)’ 

• Yes? click on it to highlight the entry → Properties

• No? see 13.1.1

• A window ’Internet Protocol (TCP/IP) Properties’ will appear

• Click on Advanced

• A window ’Advanced TCP/IP Settings’ will appear

• make sure that the entry ’Enable NetBIOS over TCP/IP’ is enabled

Also click:

• Start → Control Panel → Administrative Tools

• Double-click Services

• A window ’Services’ will appear:
make sure that server and TCP/IP NetBIOS have the status ’started’

5. ’Cannot find resolution file’ 

→ Reboot the computer and try again

6. ’Invalid license key (inconsistent license key)’

The file license.dat might contain one of the following errors:

• The hostid in the SERVER line is wrong

• The FEATURE line contains the wrong license key, the wrong date
and/or the wrong number of licenses 

• The hostid is appended at the end of the FEATURE line
(this is correct for Node Locked licenses but not for Floating licenses, see
chapter 7.1)

7. ’Invalid data returned from license server’

• Hostname in the file license.dat is incorrect 

8. ’Invalid host’ 
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• The file license.dat contains additional characters at the end of the
FEATURE line (after ““)

9. For more information on the Flexlm license manager: 
DONE INDEXClick Start → run enter c:\flexlm\bruker\help\index.htm →
Click OK

10. If you do not get the license to run you can the flexlm_diagnostic.cmd script to
send debug information to Bruker BioSpin.:

1. Double click on the icon ’Bruker Utilities’ on the desktop. A window
Bruker Utilities will appear

2. Double click on the command prompt 

Note: It is not possible to use a ’normal’ windows command prompt, because
in this ’special’ command prompt of ’Bruker Utilities’ there are several pa-
rameters and path entries defined.

3. Enter the command:

flexlm_diagnostic.cmd 1>flexlm_diagnostic.out 2>&1

The script may require 1 minute to execute.

Please send the whole output of the TOPSPIN start window using copy&paste
and the file <topspinhome>\flexlm_diagnostic-out.txt to:

nmr-software-support@bruker-biospin.de

15.3 TOPSPIN troubleshooting

If your current TOPSPIN session has a problem, you can find in this chapter some
instructions how to get rid of this situation. 

In order to stop TOPSPIN in case of any problems, the first thing to know is, that it
is using a client / server structure. It is possible to start more than one client. This
feature is used for the remote control but can also be very useful for troubleshoot-
ing!

• The client can be stopped without touching a running acquisition. 

To get rid of a TOPSPIN problems follow the description below. These steps are
increasingly drastic. Please note that this procedure is only necessary in case of
any problems as TopSpin does not react anymore. 

1. Create debug information and send it to Bruker BioSpin. For this follow the
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instructions in chapter 15.3.1

2. Open a Windows command prompt and start a second TOPSPIN graphical user
interface with the command:
DONEINDEX<topspinhome>/topspin -client

<topspinhome> is the TOPSPIN installation directory, in a default installation
this is C:\Bruker\TopSpin

Does the second TOPSPIN graphical user interface works fine?

• Yes? The problem is solved you can go ahead with TOPSPIN.

Although you can now work with TopSpin you should restart the pro-
gram as soon as possible. Typically wait until the current acquisition is
finished, then exit and restart TopSpin.

• No? go ahead with next step

3. To kill the current TOPSPIN session completely, execute a Windows Command
prompt:

killtopspin

Note, that this will stop your TOPSPIN session and therefore also a running acquisition.

4. Start TOPSPIN and go on working.

15.3.1 Send debug information to Bruker BioSpin

If you are in a situation, that TOPSPIN problems appear periodically please send
information about this to Bruker BioSpin. For a successful and fast processing of
incoming emails please make sure that the following information is given:

1. Use TOPSPIN command about to get the information about:

• version number 

• Server patchlevel

• GUI build number 

2. Operating system information

• operating system version (Windows Command prompt command winver)

3. A detailed description how to reproduce the problem

4. TOPSPIN internal debug files. To get these files do the following:

Go into the Windows Command prompt where TOPSPIN was started, maximize
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the window and then press the keys Ctrl and Break simultaneously. This will
create a debug output within the Command prompt. To mark the whole text,
click with the right mouse button in the Command prompt, a window appears,
DONE INDEX
select mark all. Press the keys Ctrl and c simultaneously. Open a Text Editor
(e.g. Notepad). 

• click on Edit → Paste 

• click on File → Save As... and enter a name for the file

• click on File → Exit 

Now it is necessary to pack all available information which Bruker needs to ana-
lyze your problem.

Start TOPSPIN and click

Options → Administration → Execution Protocols → savelogs

or enter in the TOPSPIN command line savelogs.

A window Execute Savelogs appears.

Please enter a support token and click Execute.

You can also use the savelogs.cmd script which is available under Bruker
Utilities → Miscellaneous.

Click Start → All Programs → Bruker TOPSPIN → Bruker TOPSPIN x.y →
Bruker Utilities → Miscellaneous. Double-click the script file: savel-
ogs.cmd’. Please enter a support token (e.g. your last name). The script will
automatically generate a ’*.tar.gz’ file with all available debug information from
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the TOPSPIN directories. This file will be stored in the directory:

<USERHOME>\Local Settings\Temp
DONEINDEX
Please attach these files into an email and send it to this address: 

nmr-software-support@bruker-biospin.de

If the file size is too big you can also put it on the german Bruker BioSpin ftp
server:

ftp://ftp.bruker.de

You have to login with the user name ‚ftp‘ and your email address as password.
Now you are authorized to put files into the directory ‚incoming‘ (or to get files
from the directory ‚outgoing‘). When you have uploaded files into ‚incoming‘ send
an email to 

nmr-software-support@bruker-biospin.de

with the information described above and a list of files you have uploaded onto the
ftp server.

15.4 Communication problems between PC and Spectrometer

If the acquisition (zg, gs, wobb) and/or configuration (cf) fails, you might have
a communication problem between the Windows PC and the spectrometer. 

Different spectrometer hardware requires different troubleshooting procedures. To
find out which spectrometer do you have, check which combination of the follow-
ing boards are present in your spectrometer. 

For a convenient classification the respective boards are shown below. Note, the
pictures are just an example, e. g. the EC level can be different.

name specific boards Troubleshooting information

AVANCE CCU-RCU chapter 15.5

AVANCE-II CCU-DRU chapter 15.5

AVANCE-III IPSO-DRU chapter 15.6

ftp://ftp.bruker.de
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Do I have an AVANCE type spectrometer? 
DONE INDEX? Yes, if you have the two boards:

CCU and RCU

For troubleshooting 
information go to
chapter 15.5
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Do I have an AVANCE-II type spectrometer? 
DONEINDEX? Yes, if you have the two boards:

CCU and DRU

For troubleshooting 
information go to 
chapter 15.5

Do I have an AVANCE-III type spectrometer? 

Yes, if you have the two boards:

IPSO and DRU

For troubleshooting information go to chapter 15.6

?
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Note: CCU, RCU and DRU have an upright orientation while the IPSO board is
typically horizontally orientated.

In all cases the first step of troubleshooting should be to check if the spectrometer
DONE INDEXis on power and there is a physical network connection between the Windows PC
and the spectrometer.

15.5 Troubleshooting for AVANCE and AVANCE-II 
spectrometers

If the acquisition (zg, gs, wobb) and/or the configuration (cf) fails, you might
have a communication problem between the PC and the spectrometer CCU. This
chapter is for troubleshooting of Avance and Avance-II spectrometers

15.5.1 Hardware related problems

1. Check if the Ethernet cable between the PC and the CCU is properly connected. 

→ Remove and re-connect the Ethernet cable. 

2. Does the connection light come on if you connect CCU and ethernet board in
the PC?

a) If the light is off

The connection light is one of the three LEDs that most Ethernet cards have. One
of them, usually in yellow, lights up the same moment that both ends of the re-
spective cable are connected to life devices like a hub or wall socket or a com-
puter.

• Check the cable or the Ethernet card; with some cards you need to reboot the
PC with CCU and Ethernet-board being connected to make the initial con-
nection. If the PC is started without any cable connected to the board some
configurations will disable the card unless configuration takes place (makes
sense for unused cards, however forces us to re-boot more often than we
might want to).

• In some cases the auto-negotiate protocol of certain cards doesn't work. That
means CCU can't find out whether to go for 10baseT or 100baseT. Some of
the newer Ethernet cards allow you to switch the auto-negotiate off. Soft-
ware configuration allows you to set a fixed speed of 10. In some cases you
can also force a card into 10Mbps by putting a hub (a 10Mbps hub!)
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between PC and CCU. The hub will tell the card to switch to 10Mbps and
CCU gets around auto-negotiate, too.

If the light still doesn't come on, please connect the Ethernet board with some
DONEINDEXoperational network (e.g. corporate network). If you get a physical connection
(light goes on) obtain a temporary IP address for the PC and install the card, net-
work, netmask, DNS etc to the point where you see the rest of the company
through the 'network neighborhood' of your PC. This will make sure that your card
works at all. Then switch back to the IP/netmask for spect and reboot PC. Is the
light on? If not, get a new Ethernet card. 

b) If the light is on: 

At this point you know that the physical connection is intact (that is: the connec-
tion light on the PC's Ethernet board came on). There are two possibilities to
check from here: 

• CCU is indeed booting OK, yet you can't access it for some reason. 

• CCU really does not boot and you have to find out why.

Before you proceed you might want to quickly check the settings in NFS Mae-
stro. Call it from the Control Panel (HCL NFS Server) and you need to see the
configuration given in chapter 6.6. If settings have to be altered, do this, reboot
the PC and then the CCU before checking again.

• The minimum test is this: Try to ping spect and then to telnet spect (see
chapter 8.3). Here is how to proceed:

If you can ping and telnet and get spect's login prompt you should be able
to run TOPSPIN from here. You are all set. 

If you can ping but cannot Telnet to CCU the physical connection is all right
but CCU doesn't boot. Please connect a monitor cable to CCU and open a Hyper
Terminal connection. HyperTerminal is Windows's text terminal emulator and it
comes with every copy of Windows. The details are in chapter 15.5.5

If you can't even ping CCU try a new Ethernet cable and if it still doesn't work
try another type of Ethernet card.

15.5.2 Software related problems 

1. Please check if the required Services are running as described in chapter 15.1.1.

2. The firewall may prevent the spectrometer booting. To check this (see chapter
20.8.2):



200 Troubleshooting

INDEX

• Click Start → Control Panel.

• In the window Control Panel → click Windows Security Center.
DONE INDEX
• Click Windows Firewall.

• A window ’Windows Firewall’ appears. Click on the Advanced tab.

Yes? No problem, continue with the next step. 
No? You found the problem. Contact your network administrator to cor-
rect the firewall settings.

15.5.3 View the output of the CCU console

In order to view the output of the spectrometer CCU, you must connect the COM2
port of the PC to tty00 of the CCU. The hyper terminal application can be used to
make the output of the CCU visible on the PC (this has the same function as cu
and kermit on UNIX systems). 

15.5.4 Configuration of HyperTerminal 

1. Click Start → All Programs → Accessories → Communications → Hyper-
Terminal

2. If you do this for the first time HyperTerminal will ask for some informations in
the window ’Location Information’.Type in your ZIP-code and click OK

3. A window ’Phone And Modem Options’ will appear → OK

Then establish a new connection:

4. A window ’Connection Description’ will appear: 

a) In the Field Icon: click any icon you decide for

b) In the field Name: enter CCU 

c) Click OK

5. A window ’Connect to’ will appear:

a) Click in the field Connect using: select COM2

b) Click OK

6. A window ’COM2 Properties’ will appear: 

a) Click in the field Bits per second and select 9600

b) Click in the field Flow Control and select Xon/Xoff

(the other settings remain unchanged: Data bits 8, Parity None, Stop bits 1)
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c) Click OK

→ the output of the CCU will appear in the window ’CCU Hyper Terminal’
DONEINDEX
7. Click File → Save

8. Click File → Exit 

9. Answer the question ’Are your sure you want to disconnect now?’ with Yes

15.5.5 Usage of Hyper Terminal

1. Click Start → All Programs → Accessories → Communications → Hypert-
erminal → CCU.ht

2. A window CCU Hyper terminal will appear in which you see the output of the
CCU. 

If the CCU is booted, you will see a login prompt and you can log in as root. If
the CCU is not booted you can push the reset button on the CCU and view the
boot process. The boot process is shown below. The messages ’Fast ethernet...’
only occur for CCU/9 and indicate whether you have a 10 MBit/s or 100 MBit/s
ethernet connection. Note that a UNIX pathname for the DISKLESS program is
shown. Do not worry about this, it is automatically interpreted as an Windows
XP path like: C:\Bruker\Diskless...

Autoboot: Waiting to load bfs()/usr/diskless/cli-
ents/spect/root/unix.r4600_std (
CTRL-C to abort)
loading

Fast ethernet (FEN): 100 MBit/s, half duplex
   ---1---
Obtaining /usr/diskless/clients/spect/root/unix.r4600_std
from server ’hostname’
833328+107984+827152 entry: 0x80021000
CPU: MIPS .... Processor Chip Revision: ...
FPU: MIPS .... Floating Point Unit [CP1] Revision: ...

RISC/os Release 4_52 mips Version UMIPS
Total real memory = 16777216
Available memory  = 14360576
Root on nfs file :,Swap on nfs f
Fast ethernet (FEN) : 100 MBit/s, half duplex
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   ---2---
hostname: spect
domainname: software.bruker.de
DONE INDEX
   ---3---
Root fstype nfs
Available memory  = 12713984

   ---4---
The system is coming up. Please wait.
/etc/init.d/sym_install start
/etc/init.d/sym_install calls sym_install
Adding swap device /swapfile
Fast ethernet (FEN) : 100 MBit/s, half duplex
Internet daemons: portmap inetd.
NFS daemons: nfsd biod lockd statd.
/tmp: Permission denied                       

/var/tmp: Permission denied
The system is ready:

spect Console login:

Booting might hang, stop (and print an error message) or go into an endless loop
at one of the positions 1 through 3. This might be caused by one of the problems
mentioned below. Check the indicated files and correct them if necessary or per-
form the indicated steps. 

a) If booting stops at position ---1--- and you get the messages:

Fast ethernet (FEN): 100 MBit/s, half duplex
No server for /usr/diskless/clients/spect/root/un-
ix.r4600_std
BRUKER CCU R4600 Monitor
Version 5.40 MIPS OPT Wed Jun 11 19:30:43 MSZ 1997 root
Memory size: 16777216 (0x1000000) bytes, 16 MB
Icache size: .... (....) bytes
Dcache size: ..... (....) bytes

>>

then you might have one of the following problems:

• The Service bfs not running:

Click Start → Control Panel → Administrative Tools → Services →
bfs → Start
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• The Diskless package is not installed (see chapter 6.4)

• The ethernet cable between PC and CCU allows no data throughput:
DONEINDEX
- check the connection between the cable and the PC/CCU

- check if the correct ethernet card is connected

- check the configuration of the ethernet port (see chapter 13.1)

b) If booting stops at ---2--- you may have one of the following problems: 

• The Service bootparam is not running:

Click Start → Control Panel → Administrative Tools → Services →
bootparam → Start

• The file C:\Windows\system32\drivers\etc\Hosts is
wrong:

It should contain the following entries: 

149.236.99.1 ASP_ST2
149.236.99.99 spect 

Be sure that ’spect’ is the first entry after the number in this line

• Be sure that the spectrometer ethernet card is configured for ’half
duplex’.
Click Start → Control Panel → Network Connections → select the
spectromter ethernet card → click Properties → click Configure →
select Advanced → select Speed & Duplex → change the value to 100
Mb Half Duplex

c) If booting stops at ---3--- you might have the following problem:

• The file c:\Bruker\Diskless\WinApp\bootparams is wrong.
For a default installation it must contain the lines: 

#
spect  root=ASP_ST2:C:/Bruker/Diskless/clients/spect/root \
          swap=ASP_ST2:C:/Bruker/Diskless/clients/spect/swap \
         dump=ASP_ST2:C:/Bruker/Diskless/clients/spect/dum

For a custom installation the path of Diskless can be different!

d) If booting hangs at ---3--- in a loop and you get the messages: 

a) like this:

domainname: software.bruker.de
mount root ASP_ST2:C:/Bruker/Diskless/clients/spect
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/root failed, rpc status 15
PANIC: vfs_mountroot: cannot mount root
syncing disks... done
DONE INDEX
then you might have one of the following problems:

• The Service Hummingbird NFS Server is not running

Click Start → Control Panel → Administrative Tools → Services
→ Hum. NFS Server → Start

• The path C:\Bruker\Diskless\clients\spect is not ex-
ported (see chapter 6.6).

b) like this:

domainname: software.bruker.de
mount root ASP_ST2:c:/Bruker/Diskless/clients/spect
/root failed, rpc status 2
PANIC: vfs_mountroot: cannot mount root
syncing disks... done

then you might have the problem that the drive letter of the diskless instal-
lation is written in lower case (maybe caused by a custom installation). To
solve the problem you can either

• De-install Diskless and use for the new installation ’typical’ or make
sure that the drive letter is upper case

or

• Open the file 

c:\Bruker\Diskless\WinApp\bootparams 

and change all drive letters to upper case

c) If booting stops at ---4--- and you get messages like this:

<date> INIT: Can’t open /etc/ioctl.syscon. errno: 13

touch: /etc/mtab cannot create

mount: /etc/mtab: No such file or directory

<date> INIT: warning: /etc/ioctl.syscon does not ex-
ist, default settings assumed

<date> INIT: Can’t open /etc/ioctl.syscon. errno: 13

<date> INIT: Cannot create /etc/utmp

<date> INIT: failed write of utmp entry: "   "

Please check diskless tree permissions and NFS User- and Group-Map-
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pings (see Chapter 6.6)

d) If you see the message: 
DONEINDEX
mount dumpfile ASP_ST2:C:/Bruker/Diskless/clients/spect/dump failed

during the boot process, you can ignore this. The CCU will boot anyway. 

3. Click File → Exit to finish your Hyper Terminal session. 

15.6 Troubleshooting for AVANCE-III type of spectrometer

There are some differences in troubleshooting AVANCE / AVANVCE-II and
AVANCE-III type of spectrometers. An important difference is, that on AVANCE-
III spectrometer is neither telnet spect available nor a nfs server necessary.
Several hardware units are connected via ethernet devices and controlled via a
DHCP Server. This DHCP server comes with the Diskless installation of the TOP-
SPIN DVD. The process is called Bruker DHCP Server. 

To find out what are the IP addresses of the different (via ethernet connected) hard-
ware units there are two different possibilities:

• the TOPSPIN command ha (for hardware addresses)

• the command ethernet-service-tools

Both commands offer a list of available (via ethernet connected) hardware units
and their IP addresses. A mouse click on the name of a module opens the start page
of the respective module in a web browser. From there it is easy possible to reset,
test and configure the hardware unit. The firmware download can also be started
from there.

Note: The web pages of the hardware units are optimized for the web browser
Microsoft Internet Explorer.

15.6.1 Communication problems with an AVANCE-III spectrometer

To check if an AVANCE-III is booted correctly you can use the following tests:

1. To check which ethernet connected hardware units are available you can use
one of the two commands ha or ethernet-service-tools
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• TOPSPIN command ha
DONE INDEX

A window appears that shows several hardware modules. Does the window
offers an entry for the Main Controller? 

Yes? The AVANCE-III is booted correctly, go on with the TOPSPIN command
cf

No? Go to step 2

• Open Command Prompt (Click Start → All Programs → Bruker TOP-
SPIN → Bruker TOPSPIN x.y → Bruker Utilities → Command
Prompt) and enter the commands:

• cd prog/bin

• Click Enter

• ethernet-service-tools 

• Click Enter

A window appears that shows several hardware modules. Does the window
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offers an entry ’IPSO’? 
DONEINDEX

Yes? The AVANCE-III is booted correctly, go on with the TOPSPIN command
cf

No? Go to step 2

2. Check the network configuration:

a) Check the network configuration according the information in chapter 13.1.

b) Check the file C:\WINDOWS\system32\drivers\etc - at least the
following entries have to exist for spectrometer control: 

127.0.0.1 localhost.localdomain localhost

149.236.99.1 ASP_ST2

149.236.99.99 spect

If the ethernet card for the laboratory network is not configured as DHCP,
also the name of the own PC has to be listed

xyz.xyz.xyz.xyz name_of_own_pc.domain  name_of_own_pc

Does this entry exists? 

Yes? No problem, continue with the next step.
No? You found the problem. Add the name of the PC as described in chap-
ter 13.2. Then reboot the PC and check if the spectrometer now boots cor-
rectly. 

c) Check if the hostname and IP address of the PC is correctly available in the 
nameserver. 

• open a Command Prompt
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• type in ipconfig /all

The entries should look like this:
DONE INDEX

Yes? No problem, continue with the next step. 
No? You found the problem. Contact your network administrator to cor-
rect the settings. 

3. The firewall may prevent the spectrometer booting. To check this (see chapter
20.8.2):

• Click Start → Control Panel.

• In the window Control Panel → click Windows Security Center.

• Click Windows Firewall.

• A window ’Windows Firewall’ appears. Click on the Advanced tab.
Yes? No problem, continue with the next step. 
No? You found the problem. Contact your network administrator to cor-
rect the firewall settings.

4. The DISKLESS package is not installed. Insert the TOPSPIN DVD into the DVD
drive, select the DISKLESS package and de-select all other packages. For more
details see installation description in chapter 6.4. After installation of DISKLESS

reboot the spectrometer.
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5. Check if the Bruker DHCP Server is running. 

• Open a Command Prompt and enter the command 
DONEINDEX
net start

Under ’These Windows services are started’ has to be mentioned:

Bruker DHCP Server

Yes? The DHCP service is running, go to the next step 

No? You may have found the problem, the Bruker DHCP Server is not run-
ning, try to start them with:

a) Click Start → Control Panel → Administrative Tools

b) Double-click Services

c) A window ’Services’ will appear:

Select the service: Bruker DHCP Server

d) Right-mouse-click on this service and select Start.

Now you have to reboot the spectrometer.

Yes? The service is running, go to the next step 

No? You may have found the problem, the Bruker DHCP Server cannot be
started.

6. Change the binding of the spect ethernet card:

a) Log in as Administrator

b) Click Start → Control Panel → Network Connections

c) A window ’Network Connections’ will appear

Highlight the connection which is configured for the IP-adress
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149.236.99.1
DONE INDEX

Right-mouse-click on this connection and select Rename and rename it
to spect
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d) Click Advance → Advance Settings...

A window ’Network Connections’ will appear
DONEINDEX

e) Please check if the spect entry is on the second position.

f) If not please move the entry with the arrow buttons on the right side of
the window to the second position.

g) Click OK.

Yes? The service can be started, go to the next step

No? You may have found the problem, the Bruker DHCP Server cannot be
started:

7. Swap the functions of the two ethernet cards (spect and network) between
them:

a) Log in as Administrator

b) Click Start → Control Panel → Network Connections

c) A window ’Network Connections’ will appear

d) Highlight the connection you want to configure (It is recommended to
change first the settings for the ethernet card which is configured for the
IP-adress 149.236.99.1). Click File → Properties

e) Highlight the TCP/IP entry and click Properties

Change the entries.
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f) Repeat the handling for the second ethernet card.

g) Reboot the PC.
DONE INDEX
Note: Do not forget to swap the ethernet cables (!) and to reboot the PC!

Yes? The service can be started, go to the next step

No? You may have found the problem, the Bruker DHCP Server cannot be
started:

8. Check if the Bruker tftpd32 is running. 

• Open a Command Prompt and enter the command 

net start

Under ’These Windows services are started’ has to be men-
tioned:

Bruker tftpd32

Yes? The tftpd32 service is running, go to the next step 

No? You may have found the problem, the Bruker tftpd32 is not running, try to
start them with:

a) Click Start → Control Panel → Administrative Tools

b) Double-click Services

c) A window ’Services’ will appear:

Select the service.: Bruker tftpd32

d) Right-mouse-click on this service and select Start.

Now you have to reboot the spectrometer.

If these troubleshooting steps do not give any hint on an existing problem, you
might have a hardware problem. Please get in contact with your local Bruker BioS-
pin office. Adresses of several offices can be found in chapter 22, for contact infor-
mation about all Bruker BioSpin office please go to our web server:

http://www.bruker-biospin.com/contact_us.html

15.7 Troubleshooting for NMR-GUIDE

If you have some trouble with your installation of the NMR-GUIDE, please check

http://www.bruker-biospin.com/contact_us.html
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the following :

1. Check for the NMR-GUIDE license (see chapter 7)
DONEINDEX
Edit the file C:\flexlm\Bruker\licenses\license.dat and check
weather there is a FEATURE NMRGUIDE line. If not, enter the FEATURE line
or apply for a license at

license@bruker.de

2. Check for all necessary components

• Internet Explorer > 6.0 (see chapter 3)

3. Install the NMR-GUIDE program from the TOPSPIN DVD once again and reboot.
(This is necessary, because installation of the operating system components
might have overwritten certain registry keys that are set during the NMR-GUIDE

installation.)

4. Now try the NMR-GUIDE again

15.8 helium measurement not startet

If the helium measurement will not be started please check in the directory

<topspinhome>\prog\logfiles

the two files heliumlog and heliumlog.err. The heliumlog file include
the values according the helium measurements. If an error occurs during the meas-
urement this will be reported in heliumlog.err file. 

If both files are empty please try to set up a new sheduled task.

Create a new "Scheduled Task" to start the helium measurement:

1. Login as local administrator.

2. Click Start → Control Panel → select Scheduled Tasks

3. Click on "Add Scheduled Task"

4. A window "Scheduled Task Wizard" appears → click next

5. In the appearing window click on the Browse button and go to 

<topspinhome>\prog\bin (e.g. C:\Bruker\TOPSPIN\prog\bin) and select
helevtransfer.cmd and click open
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6. In the next window select under 'Perform this task' the option 'Daily' and click
next

7. Select for 'Start time' "03:00 AM" and 'Perform this task' "Every Day" → click
DONE INDEXnext

8. In the next window click on next → finish

15.9 Bruker Service tools

Several tools for checking the spectrometer hardware are delivered with TOPSPIN.
This includes tools for BSMS, HPPR, ACB, GRAD, HPCU, RX22. You can start a
service tool as follows, for a full description see chapter 8.6: 

1. Double-click the icon Bruker Utilities on the desktop

2. A window will appear with the icons Service tools, Test Tools etc.: 

a) Double-click Service Tools to get a list of service tools

b) Double-click Test tools to get a list of test tools

3. A windows with the available tools will appear:

• Double-click any icon to start the corresponding tool 

15.10 Windows XP Service Pack

All PC’s delivered by Bruker BioSpin have the latest Service Pack installed. It can
also be downloaded from the Microsoft Web pages www.microsoft.com or
www.microsoft.de. 

For installation just follow the given instruction on the screen.

Under Windows XP it is not necessary to reinstall the service pack after e. g. con-
figuring the network. 

During the installation, you might get the message that files were detected which
are not the original Windows XP files and which are also part of the Service Pack.
Sometimes, these files are even newer than the ones in the Service Pack. This typi-
cally happens when you installed recent driver software. You are asked if these
files should be overwritten. Bruker BioSpin recommends to answer this question
with No, unless you are sure you want to update this file from the Service Pack. 

http://www.microsoft.com
http://www.microsoft.de
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15.11 Disk full or fragmented

If you have disk space problems, have a look at the Windows XP Online help: 
DONEINDEXClick Start → Help → Index

enter increasing disk space choose one subentry and click Display. If
you want to defragment your disk see chapter 19.3. Note that NTFS partitions,
which are required for TOPSPIN, suffer much less from fragmentation than FAT
partition. 

Furthermore, you might have to remove TOPSPIN data, e.g.: 

1. Delete imaginary data using the deli command

They are no longer needed for spectra which have been phase corrected.

2. Delete processed data using the delp command

They can always be retrieved by reprocessing the data.

3. Delete raw data with the del command 

Please make sure you have a backup of the data.

15.12 Creating an Windows XP Boot Disk

You can use a Windows XP bootable disk to start the operating system on a com-
puter running Windows XP. Use the procedures in this article to work around the
following boot issues: 

• Damaged boot sector. 

• Damaged master boot record (MBR). 

• Virus infections. 

• Missing or damaged ntldr or ntdetect.com files. 

• Incorrect ntbootdd.sys driver. 

You cannot use the Windows XP boot disk to help resolve the following issues: 

• Incorrect or damaged device drivers that are installed in the System folder. 

• Boot issues that occur after you see the Windows XP startup (Osloader)
screen.
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15.12.1 PC is not booting from floppy?

In case it is not possible to boot the PC from a bootable floppy, this possibility
might be disabled in BIOS. The following description shows how to enable the
DONE INDEXboot-from-floppy feature on a hp workstation xw4400 PC. On other PC’s the pro-
cedure might be slightly different.

1. During boot time cancel the boot process and go into BIOS 

On different PCs there are different ways to do this, for example, on some PCs
the boot sequence is interrupted with the Delete key rather than with the F2 key. 

2. Go to section 

Security → Boot Devices Security

3. Set Floppy to Enabled 

Note: It is recommended to disable the boot-from-floppy feature after the boot
process is done! 

If it is enable, it is possible to get very easily a boot virus into BIOS, that can make
your PC defective!

Another small advantage is, that if the BIOS feature above is enabled and a ’nor-
mal’ floppy is inside the drive, booting the PC will stop and showing the informa-
tion that a non bootable floppy is inside. If it is disabled booting the operating
system will work with or without floppy.

15.12.2 Floppy boots Operating System from hard disk

You can create an Windows XP Boot Disk by formatting a floppy from within
Windows XP and copying the following files from the root of an Windows XP
boot partition (e.g. C:) to the floppy (Special note: the boot partition is the first par-
tition which is read by bios. This is normally but not necessary the partition ’c:’. If
you installed Windows XP on a different partition e.g. ’d:’, the following files are
anyhow on ’c:’. 

• ntldr

• ntdetect.com

• boot.ini

If you are using SCSI disks with the SCSI BIOS disabled then also copy the file:

• ntbootdd.sys
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a) Create a Boot Floppy Disk with the command prompt
DONEINDEX
Copy these files with command prompt is easier to describe than with the Win-
dows explorer, because these are critical system files that are normally not shown
in the explorer window.

1. Click Start → All Programs → Accessories → Command Prompt

2. Type c:

3. Type dir /ah → you should see the necessary files

4. Type xcopy /h boot.ini a: 

5. Type xcopy /h ntldr a: 

6. Type xcopy /h ntdetect.com a: 

7. If necessary (see above) type xcopy /h ntbootdd.sys a: 

Now you can boot your PC from the Boot floppy. Be aware that this will only
work if Windows XP is still on the hard disk. If Windows XP is not available or
corrupt it must be repaired again from CDROM or from floppy.

b) Create a Boot Floppy Disk with the Windows Explorer

1. Format a floppy disk by using the Windows XP format utility.

2. Copy the ntldr and the ntdetect.com files from the I386 folder on the
Windows XP Setup CD-ROM, Windows XP Setup floppy disk, or from a
computer that is running the same version of Windows XP as the computer
that you want to access with the boot floppy. 

3. Copy the boot.ini file from a computer that is running Windows XP.
Or create a boot.ini file, and then modify it to match the computer that
you are trying to access. The following example works for a single-partition
IDE drive with Windows XP installed in the \Windows folder, but the exact
value in the [operating systems] section depends on the configuration of the
Windows XP computer that you are trying to access: 

[boot loader]

timeout=30

Default= multi(0)disk(0)rdisk(0)partition(1)\windows

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\windows="Windows XP"
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If your computer boots from a SCSI hard drive, you may need to replace the
multi(0) entry with scsi(0). If you are using scsi(x) in the boot.ini file,
copy the correct device driver for the SCSI controller in use on the computer
DONE INDEX
to the root of the Setup disk, and then rename it ntbootdd.sys. Change
the disk(0) number to represent the SCSI-ID of the hard drive you want to
boot to. If you are using multi(x) in the boot.ini file, you do not need to
do this. 

4. Start your computer by using the floppy disk, and then log on to Windows
XP.

15.13 Backup of Windows XP and TOPSPIN

The standard backup programs under Windows XP is called ntbackup which
can be started by clicking: 

Start → All Programs → Accessories → System Tools → Backup 

Under Windows XP ntbackup is possible to use ZIP, tape and external hard disks
as backup media.

You cannot choose a CD-R, CD-RW, or DVD-R device because ntbackup.exe does
not support backing up to these devices. The Removable Storage Management
(RSM) does not have the ability to recognize these three devices as backup pool
media. RSM regards CD-R, CD-RW, or DVD-R as just a file system-capable
media type, but the Windows file system does not support formatting these media
types. When it attempts to write an RSM free label, RSM does not succeed
because the disc appears to be write protected. This means that RSM treats CD-R,
CD-RW, or DVD-R media as a read-only media type even if you add them to the
ntbackup media pool. Before you buy a tape drive, make sure it is compatible with
your PC’s interface(s); IDE and/or SCSI. 

Bruker BioSpin recommends to make a regular backup of the partition(s) on which
Windows XP and the TOPSPIN are installed.

15.13.1 Complete Backup of the PC

1. Click Start → All Programs → Accessories → System Tools → Backup 

→ a window backup will appear 

2. Click Welcome → Backup Wizard
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→ a window Backup Wizard will appear → Next

3. Enable Backup everything on my computer → Next
DONEINDEX
4. Choose the media drive you want to store the backup → Next

5. Click ’Finish’ to start the backup

15.13.2 Backup of specific directories

1. Click Start → All Programs → Accessories → System Tools → Backup

→ a window backup will appear 

2. Click Backup

→ all available drives will appear

3. Choose the directory you want to backup. Click the check box left of the direc-
tory to select the entire path for backup  → a tick will appear in the check box 

4. Choose the Backup media or file

5. Click Start Backup

6. A window Backup Job Information will open

7. Click Start Backup

15.13.3 Frequent backup of specific directories

If you commonly use Ntbackup to back up a single folder, you might want to cre-
ate a simple batch file. Suppose you would like to make a daily backup of a direc-
tory:

1. Choose the path of the file as describe above 
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2. Click Start Backup
DONE INDEX

3. A window Backup Job Information will open

4. Click Advanced
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5. Click the arrow at the right of the field Backup Type and choose Daily

6. Click OK → Click Start Backup
DONEINDEX15.14 Security check of a Windows XP system

Microsoft offers a tool for free download that checks your PC for security leaks.
The result is listed with an evaluation of the different topics. For further details
check the following Microsoft website.

http://www.microsoft.com/technet/treeview/default.asp?url=/tech-
net/security/tools/Tools/mbsahome.asp

15.15 Restore the Operating System to a Previous State in 
Windows XP

Use the System Restore tool in order to return your computer to a previous work-
ing state. The System Restore takes a ’snapshot’ of critical system files and some
program files and stores this information as ’restore points’. You can use these
’restore points’ to return Windows XP to a previous state.

15.15.1 Using System Restore to Restore Windows XP

• Windows XP Does Not Start

If Windows does not start, restart Windows by using the ’Last Known Good
Configuration’ feature:

1. Start the computer and then press the F8 key when Windows begins to start.
The ’Windows Advanced Options’ menu appears.

2. Select ’Last Known Good Configuration’ (your most recent settings that
worked), and then press ENTER.

3. If a boot menu appears, use the ARROW keys to select Microsoft Windows
XP, and then press ENTER. Windows XP restores the computer to the most
recent restore point.

• Windows XP Does Start

1. Log on to Windows as an administrator.

2. Click Start → All Programs → Accessories → System Tools → System
Restore. System Restore starts.

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/tools/Tools/mbsahome.asp 
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/tools/Tools/mbsahome.asp 
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3. A window Welcome to System Restore appears, click Restore my computer
to an earlier time (if it is not already selected) →  click Next.

4. A window Select a Restore Point appears. Click the most recent system
DONE INDEX
checkpoint in On this list, click a restore point list → click Next.

5. A System Restore message may appear that lists configuration changes that
System Restore will make → click OK.

6. On the Confirm Restore Point Selection page, click Next. The System
Restore will restore the previous Windows XP configuration and then
restarts the computer.

7. Log on to the computer as an administrator. A window The System Restore
Restoration Complete will appear → Click OK.

15.15.2 Troubleshooting

It could happen that you restore Windows XP to a previous configuration that you
do not want. To undo the restoration: 

1. Log on to Windows as an administrator.

2. Click Start → All Programs → Accessories → System Tools → System
Restore. System Restore starts.

3. A window Welcome to System Restore appears. Click Undo my last restora-
tion → Next.

4. A System Restore message may appear that lists configuration changes that
System Restore will make → click OK. 

5. On the Confirm Restoration Undo page, click Next. System Restore restores
the original Windows XP configuration, and then restarts the computer. 

6. Log on to the computer as Administrator. A window The System Restore Undo
Complete appears → Click OK.

15.16 Turn on and turn off System Restore in Windows XP

The ’System Restore’ is the feature that allows a computer system to be ’rolled
back’, or restored, to a point in time before certain events took place, for example,
prior to specific software or hardware installations. System Restore monitors
changes to the system and some application files, and automatically creates restore
points. You can also create your own restore points at any time.
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In Windows XP the ’System Restore’ is enabled by default.

15.16.1 Turn on System Restore
DONEINDEXTo turn on System Restore, follow these steps: 

1. Click Start → right-click My Computer → click Properties. 

2. Click the System Restore tab. 

3. Click to clear the Turn off System Restore check box (or the Turn off System
Restore on all drives check box) → click OK.

15.16.2 Turn off System Restore

When you turn off System Restore, all existing restore points are removed, and
you are no longer able to track or undo changes to your computer. To continue to
use System Restore to restore your computer to a previous state, do not turn off
System Restore. 

To turn off System Restore, follow these steps: 

1. Click Start → right-click My Computer → click Properties. 

2. Click the System Restore tab. 

3. Click to select the Turn off System Restore check box (or the Turn off Sys-
tem Restore on all drives check box) → click OK. 

4. Click Yes when you receive the prompt to the turn off System Restore.

15.17 Start the system restore tool from a command prompt in 
Windows XP

Windows XP includes the System Restore tool, but you cannot start the System
Restore tool from a Recovery Console prompt. Because of this, it may be useful to
start the System Restore tool when you are unable to start your Windows XP-based
computer normally or in Safe mode. 

NOTE: You must log on with administrator rights. 

1. Start your computer to Safe Mode with Command Prompt.

2. At the command prompt, type 

%systemroot%\system32\restore\rstrui.exe
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and then press ENTER. 

Follow the instructions on the screen to begin restoring your computer to a pre-
vious, functional state.
DONE INDEX
15.18 Logon problems: Last Known Good

Changes in the Registry must be made with extreme care, any mistakes can make
the system unusable. Occasionally, software installations make erroneous Registry
entries. If your PC does not boot any more, you can try to go back to the so-called
Last Known Good, the last Registry Control Set with which the system success-
fully booted. Please proceed as follows:

1. Reboot and Interrupt the boot process hitting F8 when you see: 

For troubleshooting and advanced startup of Windows XP press F8

2. Use the arrow down/up keys to select the entry ’Last Known Good’, then press
ENTER and follow the instructions

Warning: when you reboot the computer after you installed new software, wait
until all disk activity has finished, before you log on. As soon as you log on, the
current control set becomes the Last Known Good and the Original Control Set
(before software installation) is gone.

15.19 The Emergency Recovery DVD

Each PC which is delivered from Bruker BioSpin Germany comes with a Emer-
gency Recovery DVD. This DVD contains an image of the PC and can be used for
restoring the PC. The image contains the installed and pre configured operating
system and all necessary programs like TopSpin. It does not contain any user spe-
cific data, like spectrometer configuration, NMR datasets or network configura-
tion. 

In case of a hard disk crash, a hacked system, or even a stolen PC it is possible to
get back on a new PC hardware a well working system within 20 minutes. After
restoring the image the last nmr_backup file must be restored and the TopSpin
command cf must be executed.

More information about nmr_backup and the TopSpin command nmr_save
file are available in chapter 8.8



Troubleshooting 225

INDEX

15.19.1 Using the Emergency Recovery CD

Note: This should be done by experienced people only! All data currently on the
disk will be destroyed!
DONEINDEXIf in doubt please contact your system administrator, maybe it is still possible to
get data from the old disk. New hardiest are not expensive therefore using a new
hardiest for restoring an image might be the best solution!

1. Insert the Bruker Emergency Recovery DVD and boot the PC. The window
Image Boot DVD Bruker Biospin will appear.

→ Press F1

2. The Acronis True Image selection window appears

Select Acronis True Image (full version)

Acronis True Image will be started. This will take about 2 minutes.

3. The window Acronis True Image appears.

→ Click on Recovery

4. The window Welcome to the Restore Image Wizard appears. 

→ Click on Next

5. In the window Image Archive Selection click on the plus sign left to CD Drive.
Typically this is (D:) or (E:). You will see some directory and disk icons. 

→ Click on the first disk icon below the directory icons. 

On the right side a short description of the image DVD will appear. Please read
this carefully and make sure that this is the image you like to install on this PC.

6. Click Next in the window Restored Hard Disk Drive Location

7. Select the hard disk on which you want to restore the image. In general you will
have only one hard disk available, so click on this line and then click Next.

8. In the window Verify Archive Before Restoring you can verify the image before
it is used. This would need the same time which is necessary for restoring the
image.

9. In the window Partition or Disk to Restore check the box left to Disk 1 to
restore the complete image.

10. In the window Restore Partitions Resize you now have the possibility to change
the size of individual partitions. This is only necessary e. g. if you use a smaller
hard disk that on which the image was created. So if you use the same disk size

!



226 Troubleshooting

INDEX

you can check No, I do not want to resize partitions.

→ Click on Next
DONE INDEX
11. In case the hard disk which you have selected contains already partitions you

must select Yes, I want to delete all the partitions on the destination hard disk
drive before restoring.

→ Click on Next

12. In the window Next Selection select No, I do not because you only want to
restore the image on one hard disk. 

→ Click on Next

13. In the last window you will get a summary of the chosen operations. Check if
everything is defined correctly.

→ Click on Proceed

14. Restoring image will then be started. This process will take about 20 minutes.
When it is finished a window will appear with information Image was success-
fully created.

15.20 An image of the PC

Each PC which is delivered from Bruker BioSpin Germany has a license for the
backup tool Acronis True Image. With this software it is possible to create a one-
to-one backup of the hardiest of the system.

It is recommended to periodically create a backup of the hardiest. In case of any
problems (hardiest crash, virus, hacker attack ...) you are able to rebuild the situa-
tion of your last backup within a few minutes. 

In chapter 15.19 it is described how to use the Bruker Emergency Recovery DVD.
This DVD contains the first image of the PC. If you create periodically a new
image of your PC you will be able to restore a system which is much more up-to-
date and contain all your individual settings like network configuration, user man-
agement, spectrometer configuration etc.

15.20.1 Creating an image

You need a boot-CD to start Acronis True Image, if there is no such CD, you can
install Acronis True Image on a Windows system and create the Bootable Rescue
Media from there. The original Acronis True Image installation CD is usually
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bootable.

1. Insert a bootable Acronis True Image CD and boot the PC. The window Acro-
nis True Image appears.
DONEINDEX→ Click on Create Image

2. The window Create Image Wizard - Welcome to the Create Image Wizard
appears. 

→ Click on Next

3. In the window Create Image Wizard - Selecting Partitions to Image select the
partitions you want to image.

→ Click on Next

4. A window Information appears that informs about the possibility of an incre-
mental image 

→ Click on OK

5. The window Create Image Wizard - Image Archive Creation appears. Select the
partition, drive or network drive where you want to store the image. The fol-
lowing steps describe archiving on a network drive

→ Click on Next

Please note that Acronis True Image is able to burn images to DVD with version
9.0 3.633 and higher. Previous versions can only store on CD, hard disks and net-
work drives.

6. The window Create Image Wizard - Creating Image Mode appears. Select
either a full backup or an incremental one. The following steps describe the cre-
ation of a full backup.

→ Click on Next

7. The window Create Image Wizard - Image Archive Splitting appears. It is rec-
ommended to choose Fixed Size and specify 650 MB. With this size you can
afterwards burn the image files on CD if necessary.

→ Click on Next

8. The window Create Image Wizard - Compression Level appears, select Maxi-
mum.

→ Click on Next

9. The window Create Image Wizard - Image Archive Protection appears. You can
enter a password to protect your image. If in doubt do not choose a password,
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this makes it more save for the restoring of the image.

→ Click on Next
DONE INDEX
10. The window Create Image Wizard - Image Archive Comments appears. Enter

important information about the current image. This makes it easy in the future
to identify this image.

→ Click on Next

11. The window Create Image Wizard - Imaging operation summary appears.
Check if everything is correct.

→ Click on Proceed

12. Creation of the image will start. This process will take about 20 minutes. When
it is finished a window will appear with information Image was successfully
created.
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File and directory handling

16.1 Viewing and opening files/directories

Windows XP offers three different ways of finding files or directories (folders). If
you want to find a specific file and you have no idea where it resides, you can use
the Search program. If you want to get an overview over the directory tree(s), you
can use Windows Explorer or My Computer. 

16.1.1 Windows Explorer

The Explorer provides an overview over all drives, directories and files in a two
paned window.

1. Click Start → All Programs → Accessories → Windows Explorer

or right-click Start → Explore

2. A double-paned window ’Exploring’ appears

• On the left side you see all drives and top level directories

• On the right side you see the contents of the drive or directory which is cur-
rently selected on the left side.

A drive or directory can be expanded in the left pane by clicking on the ’+’ button
to the left of its icon. The ’+’ button changes to a ’-’ button. When you click the
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icon itself, contents of the directory will appear in the right pane. A double-click
on the icon, both expands the directory and shows its contents.
DONE INDEX

16.1.2 My Computer

The My Computer window provides an overview over all drives, directories and
files. The differences under Windows XP between the Explorer and My Compu-
ter are very small. In fact you can use both windows with the same layout and han-
dling.

1. Double-click the icon My Computer on the desktop

2. A window ’My Computer’ will appear, showing the computer’s drives: 

3. Double-click a drive, e.g. (C:)

4. A window showing the contents of the top level directory on C: will appear: 

Double-click any icon. Depending on the file type, one of the following will hap-
pen: 

• A directory (Folder) will be opened and its contents will be shown

• An executable program will be started 

• A text file will be opened using an editor (by default notepad)
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• For an unknown file type, a window ’Open with’ will appear, showing a list
of available programs

If you click a directory icon two things might happen:
DONEINDEX• the directory contents appears in a new window

• the directory contents replaces the contents of the current window 

You can configure this feature according to your preference: 

a) Double-click the icon My Computer on the desktop

b) Click Tools → Options

c) A window ’Options’ will appear:

• Click General and select one of the two options of ’Browse Folders’

The disadvantages of a separate window for each directory is that your screen is
soon filled up with windows. However, a quick way of closing an entire hierarchy
of windows is the key combination ALT+SHIFT+F4. 

If you want the explorer layout as a two paned window, select View → Explorer
Bar and enable ’Folders’. You are not able to store this configuration, this might
be the biggest difference between the Explorer and My Computer

16.1.3 Explorer and My Computer can hide file extensions

Windows XP Explorer and My Computer allow you to hide known file extensions
like .txt, .fm, .doc etc. One of the problems when you hide them is that the
editor Notepad appends the extensions .txt to files which do not have a known
extension. For example, license.dat is changed to license.dat.txt and
thereby becomes unusable. Therefore, we recommend to configure My Computer
such that it shows file extensions: 

1. Double-click My Computer

2. Click Tools → Folder Options → View

3. Unselect Hide file extensions for known file types

4. Click OK

This setting also applies to Explorer.

16.1.4 Search

The Windows XP Find program allows you to search files and directories accord-
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ing to various criteria. 

Suppose you are looking for the file named cosy: 
DONE INDEX
a) Click Start → Search → For Files or Folders

(or press F3 when the cursor is on the desktop background)

b) Click the small arrow right of the field Look in: select the drive on which
you expect to find the file. If you select My Computer, all drives will be
searched.

c) In the field Named: enter cosy

d) Click Find now

All files which contain the string cosy in their name will appear in the result, e.g.
cosy, cosygs, pecosy. You can directly open the file by clicking on it. Further-
more, you can also search for text files which contain a certain string if you define
it in the field ’Containing Text’. Clicking on ’Search Options’ will show you
some more parameters like ’Date’ or ’Size’ which you can added in your search
options

16.1.5 The Windows Command Prompt

A Windows XP Command Prompt (shell) can be opened in three ways: 

• Click Start → All Programs → Accessories → Command Prompt

• Click Start → Run enter cmd click OK

• Press CTRL+ESC → r enter cmd click OK

A window will appear where you can enter Windows commands like cd, dir,
type, copy, ren, move, notepad, print, ipconfig, cacls,
telnet, ftp etc. 

The default Prompt is C:\> when the computer was booted from this drive.

16.2 File and directory permissions

Windows XP supports file level security on NTFS but not on FAT filesystems.
Note that TOPSPIN can only be installed on NTFS and as such it supports file level
security.
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16.2.1 Permissions and Types of Access 

Folders and files can have the following permissions: 
DONEINDEX

1 folder permission 

2 file permissions

Permission
Full 

Control
Modify

Read & 
Execute

List Folder 
Contents1 Read Write

Traverse Folder1 / 
Execute File2 yes yes yes yes no no

List Folders1 /     
Read Data2 yes yes yes yes yes no

Read Attributes yes yes yes yes yes no

Read Extended 
Attributes

yes yes yes yes yes no

Create Files1 /     
Write Data2 yes yes no no no yes

Append Data yes yes no no no yes

Write Attributes yes yes no no no yes

Write Extended 
Attributes

yes yes no no no yes

Delete Subfolders 
and Files

yes no no no no no

Delete yes yes no no no no

Read Permissions yes yes yes yes yes yes

Change Permissions yes no no no no no

Take Ownership yes no no no no no

Synchronize yes yes yes yes yes yes
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16.2.2 Changing file permissions

The permissions of a single file can be changed as follows:
DONE INDEX
1. Find the file in the Explorer (see chapter 16.1.1)

2. Right-click the file icon 

3. Click Properties 

4. A window ’Properties’ will appear:1

• Click Security

5. Highlight the user/group for whom/that you want to change the permissions

6. Click Allow or Deny to set the permissions

7. If you want to add a new user/group click on Add

8. A window ’Select Users, Computers or Groups’ will appear: 

a) Select the one you are looking for Add → OK 

9. Select the permissions you want to give to the new name

If you want to select special permissions, do step 1-5 then click Advanced 

1. A window ’Access Control Settings for <filename>’ will appear: 

• Click Permissions → View/Edit

2. A window ’Permission Entry for <filename>’ will appear:

• Click Allow or Deny of the permissions you want OK → OK → OK

16.2.3 Changing directory permissions

The permissions of a directory can be changed in the same way as file permissions: 

In the window ’Permissions Entry for <directoryname>’ you can select in the
Field ’Apply onto’ the effects of changing the permissions. Click the small arrow
right of the field Apply onto and select the entry of your choice. You can select
any combination between folder and/or subfolder and/or files OK → OK → OK

1.  If Windows XP is installed the security section might be not displayed. If you like to see it, 
you have to define it in the options of Windows Explorer. Click on ’Tools’ → ’Folder 
Options’, click on ’View’ and disable the entry: ’Use simple file sharing (Recommended)’
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16.2.4 Read-only attribute 

The problem of setting the Read-only attributes only in the entire directory and
not in the subdirectory is solved under Windows XP:
DONEINDEX1. Find the file or directory in the Explorer

2. Right-click its icon 

3. Click Properties 

4. A window ’Properties’ will appear: 

a) Click the attribute Read-only to switch it on or off

5. A window ’Confirm Attribute Changes’ will appear where you are able to
decide if your changes are set only for the entire directory or also for the subdi-
rectories and folders.

16.3 Known Problems in TOPSPIN for Windows XP

AU programs which were copied from another computer are sometimes not dis-
played properly by Notepad. This happens if they were transferred with FTP in
binary mode. You can either transfer the file again using ftp in ascii mode or with
rcp or you can correct the local AU program as follows: 

1. Start → All Programs → Bruker TOPSPIN → GNU Shell 

2. vi au_program 

in the editor window enter: 

:set textmode
:wq!

3. notepad au_program 

→ the AU program should be displayed correctly now

16.4 Compressing files and directories

16.4.1 Setting the Compress attribute

For each file and directory under Windows XP, you can set so called attributes.
One of these is the Compress attribute which reduces the size considerably.
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1. Right-click a file or folder in the Explorer

2. A popup menu will appear: 
DONE INDEX
• Click Properties

3. A window ’<name> Properties’ will appear: 

a) Click Advanced 

b) Enable the attribute Compress Contents to save disk space → OK → OK

Compressed data will be uncompressed and recompressed automatically whenever
they are accessed by an application. Note that this process will take time and your
application runs slower when they work on compressed data. For transferring files
or directories you might want to compress/archive them in zip format using the
program Winzip rather than using the Compress attribute (see chapter 19.2).

16.5 Editing text files 

You might know, UNIX doesn't write Carriage Returns (CR) at the end of text
lines. That means that some files we create will not display properly in an editor
like Notepad:

That doesn't mean that the file is damaged, it only means that the editor cannot
resolve the issue. One reason to pick WordPad as an editor is that WordPad
(unlike Notepad) is smart enough to render such files:
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Thus, if you see displays like the Notepad-example above, please try a smarter edi-
tor: WordPad comes with every Windows and those that have Microsoft Word can
of course use Microsoft Word to edit files in luxury.

16.6 Upper/Lower case letters

The Windows file system NTFS intentionally does not differentiate between upper
and lower case letters. Therefore working on a PC, please observe the following:

1. if you want to work with your SGI spectra on a PC avoid to create datasets with
the same name differentiated only by being written in upper or lower case let-
ters.

2. do not ignore the upper and lower case letters of TOPSPIN commands. If for
instance you type rpar PROT* TOPSPIN will display the rpar-list of all param-
eter sets beginning with 'PROT'. The command rpar Prot* will show no
parameter list, although the MS-Explorer displays the parameter set 'PROTON'
in the wrong way 'Proton'.
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Plotting and Printing under 
Windows XP

17.1 Printing / plotting data

17.1.1 Plotting and printing 

Under Windows XP, all common printer drivers are available and printers are
installed with the Windows XP add printer tool (see chapter 14.1). When a printer
is installed under Windows XP, it can be used for plotting from TOPSPIN and TOP-
SPIN PLOT EDITOR.

The default printer and plotter for TOPSPIN are defined during the configuration of
TOPSPIN by expinstall (see chapter 8.1.1).

17.1.2 Print/Plot from the Menu

The current data window can be printed as follows:

1.  From the TOPSPIN menu:

• Click the print button in the upper toolbar

• or Click File → Print
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• or Enter print or Crtl-p

All these actions are equivalent; they open the Print dialog box.
DONE INDEX

2. In the Print dialog box:

a) Select Print active window [prnt]

b) Click OK

Before printing starts, the operating system print dialog box will appear to se-
lect e.g. the printer and printer properties.

The Print dialog box contains two further options:

• Print with layout - start Plot Editor [plot]

If you select this option and click OK, the Plot Editor will be started. This
option is equivalent to entering plot on the TOPSPIN command line.

• Print with layout - plot directly [autoplot]

Selecting this option activates the Plot Editor layout list box. Select the
desired layout and click OK to print. Standard layouts are delivered with
TOPSPIN. They use the Windows default printer. User defined layouts use
the printer defined in the TOPSPIN PLOT EDITOR. On a 1D dataset, only
1D layouts are listed, on a 2D dataset only 2D layouts are listed etc.

For the last two options, the following Required Parameters are available.

Use plot limits:

• from screen/ CY

The plot limits and maximum intensity are used as they are on the screen
(processing parameter F1P, F2P and CY, respectively)
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• from Plot Editor Reset Actions

The plot limits and maximum intensity are set according to the TOPSPIN
PLOT EDITOR Reset Actions (right-click inside the TOPSPIN PLOT EDI-
DONEINDEX
TOR data field and choose Automation to set the Reset Actions).

• as saved in Plot Editor

The plot limits and maximum intensity are set in the specified layout

Fill dataset list:

• from your default portfolio

The portfolio contains the current TOPSPIN dataset plus the data from the
default Plot Editor portfolio

• from port folio saved in dataset

The portfolio contains the current TOPSPIN dataset plus the data from the

portfolio stored in this dataset

17.1.3 Plot data from the Processing guide

Printing/plotting data can be done from the Processing guide by clicking the
Plot/Print button. If Automatic mode is checked, the active data window will be
printed as it appears in the screen. If Automatic mode is unchecked, you will get
the dialog box.

17.1.4 Plot data with the TOPSPIN PLOT EDITOR

Although the print command allows you to use or start the TOPSPIN PLOT EDI-
TOR, you can also start it from the command line (enter plot). This will open the
TOPSPIN PLOT EDITOR from which you can create layouts and plot data. The
complete TOPSPIN PLOT EDITOR functionality is described in its online manual
that can be opened from the TOPSPIN PLOT EDITOR Help menu.

17.1.5 Print the Integral list

1. Click the Integrals tab of the data window
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2. Enter print, Ctrl+p or right mouse click in the data window to print it
DONE INDEX

17.1.6 Print the Peak list

1. Click the Peaks tab of the data window

2. Enter print, Ctrl+p or right mouse click in the data window

17.1.7 Copy data to Other Applications

Under Windows XP, you can easily copy the data window contents to other appli-
cations. To do that: 

• Click Edit → Copy [copy]

This will copy the data window contents to:

• the clipboard. After that you can paste the clipboard contents to any Win-
dows application.

• the Windows Metafile file screenDump.wmf in the user properties directory
(enter hist to locate this directory). The Windows Metafile can be
imported by other applications or send to a different computer.

Note: Some programs, when importing spectra from the clipboard or metafile, do
not display the contained information correctly. Particularly when you resize the
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imported graphics, sections of the text, the spectrum, or the axis sometimes have
disappeared.Usually this is only a display problem. When you print the respective
page, the representation is correct.
DONEINDEX17.1.8 Store (Export) a Data Window as Graphics File

The clipboard and metafile formats are resizable vector formats. In addition to this,
TOPSPIN allows you to save the contents of a data window in a graphics file of
selectable type, e.g. .png, .tif, .wmf etc. To do that:

1. Click Edit → Export

2. Navigate to the storage folder

3. Enter the destination filename and extension

4. Click Export

The resolution of such a screen dump equals the resolution of your screen. When
you import a graphics file into an other program, you may loose information when
resizing the graphics.

17.1.9 TOPSPIN PLOT EDITOR

1. TOPSPIN PLOT EDITOR uses the printer driver system of Windows XP for any
printer output. This means that any printer for which a windows driver is cor-
rectly installed can be selected as print device. Note that the printer name in a
layout file written by the Windows XP version is probably not known by the
UNIX version of TOPSPIN PLOT EDITOR because of the different printer han-
dling. Apart from that, layout files can be freely interchanged between the two
platforms.

2. TOPSPIN PLOT EDITOR uses the Windows XP Clipboard. If you put one or
more TOPSPIN PLOT EDITOR objects to the clipboard then these are stored in
windows metafile format. Therefore any windows application which is able to
read metafile data from the clipboard can import TOPSPIN PLOT EDITOR

objects.

3. Another way of exporting graphics is the menu option ’File/Export’ which
allows you to save the complete layout in Windows Enhanced Metafile format
(EMF). Most current graphical-oriented windows applications can import this
format. This provides a convenient way of importing TOPSPIN PLOT EDITOR

graphics into programs like Word or Powerpoint.
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4. With the TOPSPIN PLOT EDITOR you can directly send your current plot as
Email. Just click File → Send and TOPSPIN PLOT EDITOR will pop-up your
default mail client and add the current plot as an EMF attachment. 
DONE INDEX
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Windows XP commands

18.1 Important Windows XP functions and their shortcuts

The following Windows XP functions will be used regularly in this manual. They
can all be started in different ways by mouse click or by entering a command on
the keyboard. The following section describes some ways to start important func-
tions:

1. Open the Management Console: 

• My Computer → right click Manage

2. Working as other User:

• Right click on many icons → choose Run as ...

• Right click in Explorer on many applications → choose Run as ...

• Type in a command prompt:

runas /user:administrator cmd.exe

this will ask you for the administrator password and then open a Command
prompt with administrator permissions

3. Open the Control Panel:

• Click Start → Control Panel
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• Click My Computer → Control Panel

• Press Ctrl+Esc → s → c
DONE INDEX
4. Open a Command Prompt:

• Click Start → All Programs → Accessories → Command Prompt

• Press Ctrl+Esc → r → enter cmd → click Enter

5. Open the Task Manager: 

• Click the RIGHT mouse button on the Taskbar → click Task manager

• Press Ctrl+Shift+Esc

6. Search for files or directories: 

• Click Start → Search → For Files or Folders 

• Enter Ctrl+Esc → s → s → click Enter

• Press F3 while the focus is on the desktop

(if the focus is not on the desktop: click on the desktop first)

7. Start the Windows Explorer: 

• Click Start → All Programs → Accessories → Windows Explorer

• Right-click Start → Explorer

• Double-click icon My Computer on the desktop

8. Configure the network:

• Click Start → Control Panel → Network Connections

• Right-click My Network Places → Properties

9. Close a hierarchy of windows opened from My Computer: 

• Press Alt+Shift+F4

More shortcuts may be found in chapter 18.3.1.

18.2 Online Help

Windows XP online help provides you with two kinds of help: 

• help on specific topics

• help on what you see on your screen
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18.2.1 Getting Help on specific topics

Click Start → Help (for a list of help topics)
DONEINDEX
• Click Index to get help on a predefined list of keywords

• Enter the first letter(s) of a keyword

• Click Find to get help on all keywords contained in a data base

From the window which displays the help text you can go back to the main Help
window by clicking Help Topics. 

18.2.2 The question mark (?) in the upper right corner

Several windows, e.g. most windows which are opened from the Control Panel,
have a question mark in the upper right corner. If you click it, the cursor will
change to an arrow with a question mark. Now you can click a button or field you
want information about. The information will disappear when you click the desk-
top background. 

18.2.3 Tips on Windows XP 

This window appears every time you log in, unless you unselect

Show this screen at startup

If you want this window back: click Start → Run enter welcome click OK

Click in the right window to read some tips.

18.2.4 Windows XP tips and tricks on the Web

Innumerous tips and tricks on Windows XP can be found on various Web pages. 
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18.3 Keyboard shortcuts
DONE INDEX
18.3.1 General Shortcuts

Function or mouse equivalent Keyboard shortcut 1 

Start CTRL+ESC 

Start → Documents CTRL+ESC d 

Start → Help - CTRL+ESC h
- F1 from desktop or explorer

Start → Run - CTRL+ESC r 
- WIN+R

Start → Search - CTRL+ESC c 
- F3 from desktop or explorer 
- WIN+F

Start → Shutdown CTRL+ESC u 

Taskbar → Task Manager CTRL+SHIFT+ESC 

Close the active window ALT+F4 1

1. Be careful: If no window is active Windows XP will prompt for re-
boot

Close a hierarchy of windows ALT+SHIFT+F4 

Switch to other task ALT+TAB

Minimize all windows on desktop WIN+M

Restore all windows as seen before WIN+SHIFT+M

Toggle normal/full-screen Com-
mand Prompt

ALT+ENTER

Copy entire screen to Clipboard PRTSC (Print Screen) 

Copy active window to Clipboard ALT+PRTSC (Print Screen)
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18.3.2 Shortcuts for Windows Explorer

Function Keyboard shortcut 1 
DONEINDEX

18.4 Command Prompt versus Graphical Interface

In a Windows environment, you normally work with a graphical interface, i.e. the
Start button, Icons on the desktop, the Explorer etc. Nevertheless, Windows XP
offers a Command Prompt, a shell, from which you can run various commands.
The following table compares the Command Prompt with the graphical interface. 

Open new Explorer window WIN+E

Rename file F1

Open online help F2

Open ’Find’ dialog F3

Open ’Folder’ drop-down list F4

Force refresh of windows contents F5

Switch between left and right pane F6

Go up one level in folder hierarchy BACKSPACE

open context menu - SFHIFT+F10
- right mouse click

Function Command 
Prompt 

Graphical Interface 

Files 

list files dir Explorer → Click Drive or Folder

delete a file del 
(erase)

Right-click an icon in Explorer → Delete

rename a file ren Right-click an icon in Explorer → Rename

find text in files find Start → Search → For Files and Folders → 
Containing text
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Function Command 
Prompt 

Graphical Interface 
DONE INDEX

18.5 Windows XP Command Prompt versus UNIX shell

Bruker BioSpin supports the TOPSPIN for both Linux and Windows XP. Here are
some of the differences between these two operating systems which are of interest. 

18.5.1 Directory specification

In a UNIX shell, pathnames are specified using the slash (/) character, whereas
under Windows XP the backslash (\) character is used. Example:

UNIX shell: cd /Bruker/TOPSPIN

Windows XP Command Prompt: cd \Bruker\TOPSPIN

Under UNIX, command options are usually specified with a minus character (-)
whereas in an Windows XP Command Prompt, the slash (/) character is used. For
example, the command for listing files sorted by date: 

UNIX shell: ls -lrt

Windows XP Command Prompt: dir /od

find a file Start → Search → For Files and Folders → 
Search for Files or Folders

Directories 

make a dir. mkdir
(md)

 File → New → Folder

remove a dir. rmdir  Right-click icon in Explorer → Delete

change dir. cd <dir> Explorer

Utilities

time and date date,
time

Start → Settings → Control Panel → 
Date/Time

backup ntbackup Start → Programs → Accessories → Sys-
tem Tools → Backup
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18.5.2 Windows XP commands versus UNIX commands 

Under Windows XP, most commands can be executed via the Graphical Interface.
You can, however, also open a Windows XP Command Prompt and run commands
DONEINDEXfrom there. Here is a list of UNIX shell commands and the corresponding Win-
dows XP shell commands: 

Function UNIX shell Windows XP 
Command Prompt 

Files

List files ls dir

copy a file cp copy

rename a file mv ren

delete a file rm del (erase)

print a file lp print 

edit a file vi, jot notepad

display file contents cat type

sort a file sort sort 

compare 2 files diff comp, fc

find text in file grep find 

find a file find 

Directories

make a directory mkdir mkdir 

remove a directory rmdir rmdir 

copy a directory cp -r xcopy

change directory cd <dir> cd <dir>

show current directory pwd cd

Utilities

time and date date date, time
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Function UNIX shell Windows XP 
Command Prompt 
DONE INDEX

18.6 The UNIX GNU shell

For compatibility reasons, a UNIX shell is delivered on the TOPSPIN CD and auto-
matically installed during the installation of TOPSPIN. When the installation is fin-
ished you can open a GNU shell by clicking: 

Start → All Programs → Bruker TOPSPIN → GNU Shell 

A GNU shell will open in which you can enter a restricted set of UNIX commands. 

manual pages man help 

backup tar backup (floppy) or 
ntbackup (tape)
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Useful tools for Windows 
Windows XP

This chapter contains a description of some tools we found useful. We realize that
many other tools are available for various purposes and we are very interested in
your experiences. Just send your comments to: 

nmr-software-support@bruker-biospin.de 

19.1 Update the operating system

There are two things that help you to be up-to-date with the operating system

• email notification about security fixes

• download and installation of hotfixes and service packs

Please see also chapter Microsoft Security Center (chapter 20.8).

Note: Bruker BioSpin recommends to choose the option ’Download updates for
me, but let me choose when to install them’ because the option ’Automatic down-
load recommend updates for my computer and install them’ could cause that the
PC restarts automatically after the installation of an update.
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19.1.1 Email notification about security fixes

Microsoft offers the possibility to subscribe for a newsletter that will inform you
about security problems and their available fixes. Open Internet explorer and type
DONE INDEXin:

http://register.microsoft.com/regsys/pic.asp

You can subscribe there with your email address and after registration you can
decide which kind of newsletter you want to get. It is recommended to subscribe at
least for the Microsoft Security Notification Service to get all information about
security leaks and their fixes.

19.1.2 Update of the operating system

• Click on Start → All Programs → Internet Explorer Windows Update

• The Internet Explorer will open. Click on Tools → Windows Update
This will show a page where you can choose to start the search for all necessary
updates.

• After the search is finished you have to choose which update of the available
list you like to download.

• Start the download and follow the instructions.

19.2 Winzip: pack/unpack zip, tar, gz, uue files

The program Winzip allows you to pack or unpack archive files. The most com-
mon format is .zip, but Winzip also handles several other Windows and UNIX
formats like .tar, .gz (created with gzip) and .uue (created with uuencode).
An Evaluation Version of WinZip is available at: www.winzip.com which can be
used for viewing and extracting archives. For creating archives, you should order
an official version. Once Winzip is installed, it is automatically started when you
click a file with the extension .zip, .tar, .gz, .uue etc. You can also drag and
drop the file’s icon into the Winzip window. Then click Extract to extract one file
from the archive or click Checkout to extract all files.

19.3 Defragment your disk

Windows XP has an tool that allows you to defragment your disk. In the course of


http://register.microsoft.com/regsys/pic.asp
http://www.winzip.com
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time your disk will become more and more fragmented. Although an NTFS parti-
tion (which is required for TOPSPIN), suffers much less from fragmentation than a
FAT partition, it might be a good idea to defragment it from time to time. 
DONEINDEXStart → All Programs → Accessories → System Tools → Disk Defragmenter
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Windows XP Tips and Tricks

20.1 Creating shortcut icons on the desktop

20.1.1 Creating shortcut icons to programs

For frequently used programs, it is convenient to create a shortcut icon on the
desktop. For example, a shortcut to the editor Notepad can be created as follows:

1. Right-click the Start button

2. Click Open

3. A window ’Start Menu’ will appear:

a) Click All Programs → Click Accessories

b) Press and hold the right mouse button on the Notepad icon

c) Drag the Notepad icon on the desktop, then release the right mouse button

d) Click Create Shortcut(s) Here

Alternatively, you can click Start → Search to find the executable file Note-
pad.exe and perform step c to d. (see also chapter 20.1.2).
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20.1.2 Creating shortcut icons to documents/files:

For frequently used files, it is convenient to create a shortcut icon on the desktop.
If Windows XP recognizes the extension of the file, the corresponding program to
DONE INDEXread the file will be started, e.g. Word for a .doc file. For a text file without exten-
sion, you can specify the program to be used. e.g. notepad, in the shortcut proper-
ties. As an example we will use the TOPSPIN history file: 

1. Find the directory <var>\prog\curdir\<user> in the Explorer

e.g. C:\Bruker\TOPSPIN\prog\curdir\guest

2. Press and hold the right mouse button on the icon history

3. Drag the history icon on the desktop, then release the right mouse button

4. Click Create Shortcut(s) Here

→ an icon Shortcut to history will appear

5. Right-click the icon Shortcut to history

6. Click Properties

7. A window ’Shortcut to history properties’ will appear:

a) Click Shortcut

b) In the field Target: insert the program to be used before pathname, e.g. 

notepad C:\Bruker\TOPSPIN\prog\curdir\guest\history 

c) Click OK

20.2 Use the classic logon screen under Windows XP

To temporarily use the classic logon screen, press CTRL+ALT+DEL two times on
the Welcome logon screen.

To configure Windows XP to use the classic logon and shutdown screens for every
logon session, follow these steps: 

1. Click Start, and then click Control Panel.

2. Double-click User Accounts.
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3. Click Change the way users log on or off.
DONEINDEX

4. Clear the Use the Welcome screen check box.

20.3 Convenient handling of TOPSPIN under Windows XP 

20.3.1 Reading data from the Explorer into TOPSPIN

TOPSPIN can read data from the Explorer, via the Clipboard. Perform the following
steps: 

a) In the Explorer: 

• Find the dataset you want to display in TOPSPIN
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• Right-click the data name folder

• A popup window will appear: click Copy
DONE INDEX
b) In TOPSPIN:

• click File → Paste

You can also click a data expno or procno folder and read the corresponding data-
set into TOPSPIN. 

20.3.2 Copy a text item into the TOPSPIN command line

Any text item which can be copied to the Clipboard can be pasted to the TOPSPIN

command line. Of course this is only useful if this text item is an existing TOPSPIN

command. You can, for example, copy an TOPSPIN command from the manual to
the command line:

1. Click Help → Complete Processing Manual

2. A PDF viewer (if installed) will start up showing the TOPSPIN processing man-
ual:

a) Click Tools → Select text

b) Mark an TOPSPIN command in the manual, e.g. search

c) Enter Ctrl-C

3. Move the cursor on the TOPSPIN command line: 

4. Click the middle mouse button.

This feature is especially useful for long command names or commands with many
arguments.The text can come form various sources, e.g. online documents, the
Command Prompt, text editors. You can, however, not copy file or program names
directly from the Explorer to the TOPSPIN command line.

20.4 Various useful configurations

This paragraph describes several settings that we found useful. They have no influ-
ence on the TOPSPIN performance and you are free to choose your own settings. 

20.4.1 Configuring the Taskbar

1. Right-click the Taskbar 1
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2. Click Properties

3. A window ’Taskbar Properties’ will appear: 
DONEINDEX
• De-select the item Always on top, click OK

This will create more space on the desktop.

20.4.2 Hide known file extensions

See chapter 16.1.3

1. Open the Explorer

2. Click the menu Tools → Folder Options

3. In the ’Folder Options’ window: 

a) Select VIEW

b) Unselect Hide file extensions for known file types (if it is selected)

c) Click OK

20.4.3 Show hidden files and folders

1. Open the Explorer

2. Click the menu View → Options

3. In the ’Folder Options’ window: 

a) Select VIEW

b) Select Show hidden files and Folders

c) Click OK

20.4.4 Configuring the GNU shell

The GNU shell is delivered on the CD ’TOPSPIN for Windows XP’ and is automati-
cally installed together with the installation of TOPSPIN. It provides a set of UNIX
commands. By default, the resize and cut & paste functions are not active. 

Making the GNU window resizable by default:

1. Click Start → All Programs → Bruker TOPSPIN → GNU Shell

2. A GNU shell window will appear:

1.  The taskbar is usually, but not necessarily, at the bottom of the screen 
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a) Click the symbol in the upper left corner of the window

b) Click Properties
DONE INDEX
3. A window ’GNU shell properties’ will appear:

a) Click Layout

b) In the field Screen Buffer Size: 

• Set Width to 200 
• Set Height to 100

c) Click OK

4. A window ’Apply properties to shortcut’ appears:

a) Click Modify shortcut which started this window

b) Click OK

Enabling the cut & paste function:

1. Click Start → All Programs → Bruker TOPSPIN → GNU Shell

2. A GNU shell window will appear:

a) Click the symbol in the upper left corner of the window

b) Click Properties

3. A window ’GNU shell properties’ will appear:

a) Click Options

b) Select QuickEdit Mode

4. A window ’Apply properties’ appears:

• Click Apply properties to current window only 

• Click OK

The reason we do not recommend to enable the cut & paste function by default is
that it would also count for the GNU shell started by TOPSPIN. Accidentally using
cut & paste in that window could cause TOPSPIN to crash. 

20.5 Connecting UNIX and Windows XP with Samba

Samba is a suite of programs which work together to allow clients to access UNIX
file systems and printers via the SMB (Session Message Block) protocol.
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In practice, this means that you can ’share’ disks and printers with UNIX systems.
You can then access them from LanManager clients, Windows for Workgroups
3.11 clients, Windows95 clients, Windows NT clients, Windows 2000 clients,
DONEINDEX
Windows XP clients and OS/2 clients. A ’share’ is a term used to describe
resources (directories, printers, etc.) that the server is making available for others
on the network to use.

More information you may find in chapter 13.4.3, in the directory
/usr/samba/README and /usr/samba/docs or if you have Internet
access on http://samba.org

The license conditions are described in /usr/samba/COPYING.

20.5.1 Accessing the network share provided by Samba

5. You can access shares from any Windows XP PC using the Run… feature
available from the Start button.

Type in two back-slashes followed by the (UNIX-)computer name (this operation
is equivalent to running a 'find' on a particular computer.

6. The corresponding response shows up in a Windows Explorer window:

You can double-click on the share you want to see and it will come up with either a

http://samba.org
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password request for shares with managed access…
DONE INDEX

… or the list of contents (in yet another Explorer window):

If you cannot get access to a share that you see and you are confident that the
password is correct please see chapters 20.5.3 and 20.5.4.

To copy files you can drag-and-drop them from a content display and deal with
files and directories as if they where local (e.g. you can drag-and-drop acqu-files
into a Wordpad-icon on you desktop. Technically the job of making a connection is
completed here.

20.5.2 Mapping network shares into 'local' drives

For some applications (including TOPSPIN) you will need, however, to map the net-
work share to a (virtual) disk drive. That is: You create a look-alike of a local drive
like, say, U: that points to the share you assign to it. Doing this is very simple:
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Step #1: click with the right mouse button on the share you want to map to a disk
drive
DONEINDEX

Select 'Map Network Drive' (as shown).

Step #2: Select an appropriate drive letter (here: U:) and decide whether or not to
click the 'reconnect at logon' box. If you want a permanent connection that auto-
matically is re-established any time the (client) PC is booting up click this box. If
you don't check it this connection will only last until the next reboot.

Step #3: Press 'OK'. As you press 'OK' the system will connect this network share
as a new drive called U: You can look up the new virtual disk in Windows
Explorer after a few seconds:

On the right-hand side the files shared out from UNIX are shown and you can go
about copying, moving etc just like with native Windows files.
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20.5.3 Configuring Windows XP to handle UNIX-style password 
requests
DONE INDEX
One of the most annoying problems with SAMBA is that older versions are not
able to authenticate network connectors using encrypted passwords. In SAMBA
2.0.x the default setting is still plain password but you could change it to
encrypted. T2.1his is the best way for the security of your network. If you want to
use the plain-text password, it is possible on Windows XP side, to enable the
authentication with clear-text passwords sent over the networking enabling the
respective registry key (see the following chapters 20.5.5 and 20.5.4)

Note: THIS INTRODUCES A SIGNIFICANT SECURITY LEAK!

20.5.4 Enable Plain Text Password

1. Log in as administrator. 

2. Click Start → Control Panel

3. Click Administrative Tools → Local Security Policy

4. Enable the tree Local Policies → Security Options

5. On the right side double click the entry ’Send unencrypted password to ...’

6. Click on ’enabled’

7. If your computer is part of a Windows NT / 2000 / XP domain contact your
domain administrator about this policy setting and its interaction with possible
’group policies’

20.5.5 There is one shortcut you can try with newer samba-versions

They deliver a file called WinXP_PlainPassword.reg in the
../samba/docs directory. If you can locate this file in the Windows Explorer
and double-click it, it will automatically make the additions to the registry file
detailed hereafter. If you double-clicked the file and it worked you are done here.
If not, you need to proceed as detailed in chapter 20.5.4 and manually make the
necessary changes.
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20.6 How to log on to Windows XP if you forget your password
DONEINDEX
20.6.1 Method 1: Log On as an Administrator and Reset the Password

If you can not log on to Windows by using a particular user account (including the
Administrator or Computer Administrator accounts), but you can log on to another
account with administrative privileges (including the Administrator or Computer
Administrator accounts), follow these steps: 

1. Log on to Windows by using the administrator account that has a password that
you remember.

Note: You cannot log on as usual by using the Administrator or Computer Ad-
ministrator account to a Windows XP Professional-based computer in a work-
group. To log on as the Administrator or Computer Administrator, you must start
Windows XP in Safe Mode.

2. Click Start → Click Run. 

3. In the Open box, type the following command, and then click OK: 

control userpasswords2

4. Click the user account that you forgot the password for → Click Reset Pass-
word. 

5. Type a new password in both the New password and the confirm new password
boxes → Click OK.

You should now be able to log on to Windows with the user account and the new
password.

WARNING: If you reset the password for a user account in this manner in Win-
dows XP Professional, the following types of information for that user will be no
longer available: 

• E-mail messages that are encrypted with the user's public key 

• Internet passwords that are saved on, or remembered by, the computer 

• Any files that the user has encrypted

20.6.2  Method 2: Use a Password Reset Disk

If you created a password reset disk for Windows XP, you are able to reset your
password by using the password reset disk. For additional information about how
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to use a password reset disk, please check the articles in the Microsoft Knowledge
Base: 

• In order to create and use a Password Reset Disk for a computer that is not a
DONE INDEX
domain member in Windows XP please read:

http://support.microsoft.com/default.aspx?scid=kb;EN-
US;305478

• In order to create and use a Password Reset Disk for a computer in a domain in
Windows XP please read:

http://support.microsoft.com/default.aspx?scid=kb;EN-
US;306214

20.7 Error Message When You Use the Add Printer Wizard

When you create a printer (either a local printer or a remote network printer) by
using the Add Printer Wizard, you may receive the following error message: 
"Operation could not be completed. The print spooler service is not running."

This error occurs because the Spooler service has not been started or has stopped
working. To start the Spooler service, follow these steps: 

1. Click Start → Click Control Panel. 

2. Double-click Administrative Tools → Click Services. 

3. Double-click the Printer Spooler service → Change the startup type to
Automatic. This sets the Spooler service to start automatically when you
restart the computer. 

4. If you want to start the spooler service immediately, click the Start button
under the Service Status field.

20.8 Microsoft Security Center

If you connect your computer to the Internet, you can be vulnerable to viruses,
worms, hackers, and other Internet intruders. To help protect your computer
against viruses and other security threats, Bruker BioSpin recommends to have a
firewall and updated antivirus software running at all times.

Microsoft Windows XP Service Pack 2 (SP 2) contains the new Security Center,
which helps you to manage your computer's security settings and therefore more

http://support.microsoft.com/default.aspx?scid=kb;EN-US;305478
http://support.microsoft.com/default.aspx?scid=kb;EN-US;306214
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secure. If you are not running a firewall or an up-to-date version of antivirus soft-
ware, you will see an alert in the notification area, to the right of the taskbar.

Wit the help of the Security Center you can check the status of the important secu-
DONEINDEXrity settings. You can also use it to find information about the latest virus or other
security threat or to get customer support from Microsoft for a security-related
issue.

20.8.1 How to open Security Center

1. Click Start → Control Panel.

2. Double-click Security Center. A window ’Microsoft Security Center’ will
appear:

The Security Center helps to check that you have:

• A software firewall.

• Configure the settings for Automatic Updates.

• An up-to-date antivirus program. 

If the Security Center detects that your computer might benefit from enhanced
security in one of the three areas (Firewall, Automatic Updates and Antivirus pro-
gram), it displays an alert in the notification area (to the right of the taskbar). An
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alert message is displayed every time you log on, until the problem is fixed.

Windows Security Center checks for many common antivirus and firewall pro-
grams, but it is possible that you might be using a program that Windows can't
DONE INDEXfind. If you are not sure about the status of your antivirus or firewall solution, or if
you receive a Security Center alert that seems incorrect, check with your antivirus
or firewall vendor to find out if the software you are running is supported in the
Security Center.

Note: If your computer is part of a domain, your security settings are typically
managed by your network administrator. In this case, the Security Center does not
display your security status or send alerts.

20.8.1.1 What do the new security icons mean?

Windows XP SP2 contains a set of security icons that can help you recognize
potential security risks and choose appropriate security settings. 

These icons means:

• Indicates important security information and settings.

• Notifies you of a potential security risk.

• Situation is more secure. Your computer is using recommended
    security settings.

• Warning: situation is potentially harmful. Consider adjusting security
              settings to enhance the security of your computer.

• Your computer's current security settings are not recommended.

20.8.2 Firewall

Windows Firewall, previously known as Internet Connection Firewall or ICF, is a
protective tool that monitors and restricts information that travels between your
computer and a network or the Internet. This provides a line of defence against
someone who might try to access your computer from outside the Windows Fire-
wall without your permission.
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Bruker BioSpin recommends to protect your computer against viruses or security
threats, we recommend to keep the Windows Firewall (or another firewall) on.
DONEINDEX
20.8.2.1 To open Windows Firewall

1. Click Start → Control Panel.

2. In the window Control Panel → click Windows Security Center.

3. Click Windows Firewall.

4. A window ’Windows Firewall’ appears:

Because a firewall restricts communication between your computer and the Inter-
net, you might need to adjust settings for some programs that prefer an open con-
nection. These adjustments are called ’exceptions’.

Windows Firewall now has three settings:

1. On: Windows Firewall is turned on by default, and normally you should leave
it that way. When you choose this setting, Windows Firewall blocks all unsolic-
ited requests to connect to your computer, except for requests to programs or
services selected on the Exceptions tab.

2. On with ’Don't allow exceptions’: When you select the Don't allow excep-
tions check box, Windows Firewall blocks all unsolicited requests to connect to
your computer, including requests to programs or services selected on the



272 Windows XP Tips and Tricks

INDEX

Exceptions tab. Use this setting when you need maximum protection for your
computer (e.g. when you connect to a public network in a hotel or airport)

There is no need to keep Don't allow exceptions selected all the time, because
DONE INDEX
when it is, some of your programs might not work correctly, and the following
services are blocked from accepting unsolicited requests:

• File and Printer Sharing 

• Remote Assistance and Remote Desktop

• Discovery of network devices 

• Preconfigured programs and services on the exceptions list

• Additional items that you've added to the exceptions list

3. Off: This setting turns Windows Firewall off. When you choose this setting,
your computer is much more vulnerable to harm from unknown intruders or
viruses. This setting should only be used by advanced users for computer
administration purposes, or if your computer is protected by another firewall.

20.8.2.2 Windows Firewall settings

If you are running Windows XP SP2 the Windows Firewall is turned on by default.
This means that most programs will not be allowed to accept unsolicited commu-
nications from the Internet unless you choose to list those programs as exceptions.
There are two programs that, by default, are already added to the exceptions list:
Files and Settings Transfer Wizard and File and Printer Sharing. 

Because firewalls restrict communication between your computer and the Internet,
you might need to adjust settings for some other programs that prefer an open con-
nection. You can make an exception for these programs, so that they can communi-
cate through the Windows Firewall.

Each time you allow an exception for a program to communicate through Win-
dows Firewall, your computer is made more vulnerable. If you have lots of excep-
tions and open ports, your computer can become more vulnerable. To help
decrease your security risk:

• Only allow an exception when you really need it. 

• Never allow an exception for a program that you don't recognize.

• Remove an exception when you no longer need it.

Sometimes you might want someone to be able to connect to your computer,
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despite the risk such as when you expect to receive a file sent through an instant
messaging program.

You can use the Bruker BioSpin setfirewall.cmd script to configure the
DONEINDEXWindows firewall (see chapter 8.9).

Note: The firewall for the spect ethernet card has to be disabled!

20.8.2.3 To add a program to the exceptions list

1. Click Start → Control Panel.

2. In the window Control Panel → click Windows Security Center.

3. Click Windows Firewall.

4. A window ’Windows Firewall’ appears:.

5. Click on the Exceptions tab. Under Programs and Services, select the check
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box for the program or service that you want to allow, and then click OK.
DONE INDEX

20.8.2.4 Add a program (or service) to the exception list

1. Click Start → Control Panel.

2. In the window Control Panel → click Windows Security Center.

3. Click Windows Firewall. A window appears → click on the Exceptions tab. 
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4. Click on Add a Program. This will open a dialog box. 
DONEINDEX

Click the program that you want to add, and then click OK. The program will
appear, selected, on the Exceptions tab, under Programs and Services.

5. Click OK. 

20.8.2.5 Open a Port in the exception tab

If you still do not find the program, you can open a port instead (When you open a
port, remember to close it again when you are done using it.).

Adding an exception is preferable to opening a port because it is more secure than
opening a port, because the firewall is only open while the program is waiting to
receive the connection.

1. Click Start → Control Panel.

2. In the window Control Panel → click Windows Security Center.

3. Click Windows Firewall.
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4. A window ’Windows Firewall’ appears. Click on the Exceptions tab. 
DONE INDEX

5. Click on Add a Port. This will open a dialog box. 

Click the program that you want to add → click OK → click OK. 

20.8.2.6 Advanced Options

Advanced users can open ports for, and configure the scope of, individual connec-
tions to minimize opportunities for intruders to connect to a computer or network.
To do this, open the Windows Firewall, select the Advanced tab and use the set-
tings under Network Connection Settings.

1. Click Start → Control Panel.

2. In the window Control Panel → click Windows Security Center.

3. Click Windows Firewall.
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4. A window ’Windows Firewall’ appears. Click on the Advanced tab. 
DONEINDEX

5. Click under Network Connection Settings on Settings. 

6. Click OK. 

20.8.2.7 How to disable Firewall Alerts from the Security Center

If you have installed another firewall than Windows Firewall, the Security Center
may still be able to tell you the status of that firewall and may also display an alert
if it stops working. 

There are some firewalls that Windows Security Center will not find, such as a
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hardware firewall or certain types of software firewalls. If your computer is using a
hardware firewall, you should not disable Windows Firewall. If you install and run
another firewall, you should turn off Windows Firewall. If you use another soft-
DONE INDEX
ware firewall that Windows doesn't recognize, you may want to disable the Secu-
rity Center firewall alerts.

Note: You should only disable these alerts if you are sure that your computer is
protected by a firewall. The following procedure assumes that you have already
turned off Windows Firewall and that you have received an alert telling you that
you do not have a firewall installed.

20.8.2.8 How to specify a firewall that Windows does not find

1. Click Start → Control Panel.

2. Double-click Security Center.

3. Select Firewall → click Recommendations. (Note: The Recommendations
button is not available when your Firewall setting is marked ON.)

4. In the Recommendations dialog box, select the ’I have a firewall solution
that I'll monitor myself’ check box → click OK.

When you use this procedure, the Security Center displays your Firewall setting as
Unknown, and does not send you alerts. 

20.8.3 Automatic Updates

Windows Security Center allows you to easily manage security settings for Auto-
matic Updates. When you turn on Automatic Updates, Windows routinely checks
the Windows Update Web site for high-priority updates that can help protect your
computer against attacks. High-priority updates include security updates, critical
updates, and service packs.

20.8.3.1 How to change your Automatic Updates settings

By default, any new updates are installed each day at 3 a.m.

1. Click Start → Control Panel.

2. Double-click Security Center.

3. Under Manage your security settings for → click Automatic Updates
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4. A window ’Automatic Update’ will appear:.
DONEINDEX

The options for Automatic updates are:

• Automatic: Automatic download recommend updates for my computer and
install them: e.g. ’Every day’ at ’3:00 AM’

• Automatic: Download updates for me, but let me choose when to install
them (recommended by Bruker BioSpin for PCs which controls spectrome-
ter.

• The Updates are downloaded behind the scenes whenever you are connected
to the Internet. The downloading process does not interfere with other
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downloads or interrupt you while you work. If you disconnect from the
Internet before updates are fully downloaded, the download process will
continue the next time you connect to the Internet. 
DONE INDEX
• Automatic: Notify me but do not automatically download or install them.

• Turn off Automatic Updates. Your computer will be more vulnerable unless
you install updates regularly. Install updates from the Windows Update Web
site.

You can also visit the Windows Update Web site on a regular basis to get updates
for your computer. The Web site provides the same high priority updates as Auto-
matic Updates, but also offers optional updates that can help improve your compu-
ter's performance or add functionality to some of your programs.

Bruker BioSpin recommends to choose the option ’Download updates for me, but
let me choose when to install them’ because the option ’Automatic download rec-
ommend updates for my computer and install them’ could cause that the PC
restarts automatically after the installation of an update.

20.8.4 Antivirus

20.8.4.1 How to disable Antivirus Alertsform the Security Center

If you are running Windows XP SP2 Windows Security Center should tell you
about the status of your antivirus software and display an alert if it stops working.
Some antivirus programs are designed to report specific information about the pro-
gram to the Security Center.

However, not all antivirus programs are designed to report to the Windows Secu-
rity Center. In fact, there are some antivirus solutions that the Security Center will
not detect at all. If you use an antivirus program that Windows does not recognize,
and you keep it up to date and properly configured, you may want to disable the
antivirus Security Center alerts.

Note: You should only disable these alerts if you are sure that your computer is
protected by the full version of an up-to-date antivirus program. In addition, once
you disable alerts, even if your program receives an update that makes it fully
detected within Security Center, you will not receive alerts unless you clear this
check box.
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20.8.4.2 How to specify an antivirus program that Windows does not find

1. Click Start → Control Panel.
DONEINDEX
2. Double-click Security Center.

3. In the Security Center, under Virus Protection, click Recommendations. (The
Recommendations button is not available when your Virus Protection setting is
marked ON.)

4. In the Recommendations dialog box, select the I have antivirus software
that I'll monitor myself check box, and then click OK.

When you use this procedure, the Security Center displays your Virus Protection
setting as Unknown, and does not send you alerts.

20.8.5 Microsoft Pop-up Blocker

With the Windows XP SP2 Internet Explorer you are able to prevent most pop-up
windows from appearing over Internet pages you want to view while you are using
the Internet. 

Many advertisers on the Internet use windows that pop up in the middle of your
screen to display a message. They might also open when you click a link or button
on a Web site, and they might open either over or under the window you wish to
view. Some pop-ups are helpful. Unfortunately, some pop-up windows can contain
inappropriate content or can be a way for you to accidentally download dangerous
software (called spyware or adware) onto your computer.

When you install SP2, Pop-up Blocker is turned on in Internet Explorer and set to
the medium setting, which means it will block most automatic pop-ups. The
default settings for the pop-up blocker allow you to see pop-ups that are opened
when you click a link or button on a Web site. Pop-up Blocker will also play a
sound and show the Information Bar when a Pop-up is blocked. You can adjust
these settings so that Pop-up Blocker works the way you want it to.

20.8.5.1 How to change Pop-up Blocker settings

1. Open the Microsoft Internet Explorer. 
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2. On the Tools menu, select Pop-up Blocker → click Pop-up Blocker Settings.
DONE INDEX

If you want to see pop-up windows from a specific Web site, type the address (or
URL) of the site in the Address of Web site to allow box, and then click Add. 

If you would like to temporarily allow a site to display pop-ups, click the Informa-
tion Bar when it notifies you that a pop-up has been blocked  → click Temporar-
ily Allow Pop-ups. 

20.8.5.2 How to block pop-ups when you click a link (or button) on a Web site

1. Open Internet Explorer. 

2. On the Tools menu, select Pop-up Blocker → click Pop-up Blocker Settings. 

3. Select the High setting in the box near the bottom of the dialog box. 

Note: If you want to see pop-ups that are blocked when you have this setting
turned on, hold down the CTRL key while the window opens.

20.8.5.3 To turn on Pop-up Blocker

1. On the Tools menu, select Pop-up Blocker.

2. Click Turn on Pop-up Blocker.

If you get similar pop-up windows no matter what sites you visit or even if you are
not on the Web at all, you could have spyware, adware, or other software on your
computer that's launching pop-ups. To stop these pop-ups, you will have to iden-
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tify the software, then remove it or change its settings to stop it from launching
pop-ups.

Pop-up Blocker will not block pop-up windows that you open deliberately by
DONEINDEXclicking a link. For example, if you were on a travel reservation site and you
clicked a link to open a pop-up window containing your confirmation details, this
pop-up window would not be blocked because you opened it intentionally. The
Pop-up Blocker will not block some pop-ups with certain types of animated con-
tent or pop-ups from Web sites that are in two Web content zones: Local intranet
or Trusted sites.

20.8.6 Multilingual User Interface Pack (MUI) for Microsoft Windows XP 
Professional 

The Multilingual User Interface Pack (MUI) is a special package with a set of lan-
guage specific resource files which can only be added to the English version of
Windows XP Professional. The Multilingual User Interface Pack allows (when
installed) the user interface language of the operating system to be changed
according to the preferences of individual users to one of the supported (and
installed) languages. Local users can then select the user interface language or it
can be set by group policy for organizational units. 

The Multilingual User Interface Pack also allows different language users to share
the same workstation. For instance, one user might choose to see system menus,
dialogues and other text in German, while another user logging onto the same sys-
tem might prefer to see the corresponding text in Hungarian. 

On Windows PCs delivered by Bruker BioSpin the ’Multilingual User Interface
Pack’ for Microsoft Windows XP Professional is preloaded. The following lan-
guages are available: English (default), Chinese (Simplified), Chinese (Tradi-
tional), Finnish, French, German, Hungarian, Italian, Japanese, Korean, Polish,
Spanish, Swedish, Turkish

Note: Multilingual User Interface Resource Files are only sold as a bundle with
the English version of Windows. It is not available through retail channels.

For further information please refer to:

http://www.microsoft.com/globaldev/DrIntl/faqs/muifaq.mspx#MUIques1

http://www.microsoft.com/globaldev/DrIntl/faqs/muifaq.mspx#MUIques1
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20.8.6.1 Change the user interface language

The appropriate Menus and dialogues language can be selected from the Regional
DONE INDEX
Options applet in Control Panel.

1. Click Start → Control Panel.

2. Double-click Regional and Language Options.

3. Click on the Languages tab.

The Menus and dialogs drop down list will display all the installed languages.

Note: Changes to the user interface language only become effective after logging
off and logging on again.

For further information please see:

http://www.microsoft.com/globaldev/refer-
ence/win2k/setup/changeui.mspx

http://www.microsoft.com/globaldev/reference/win2k/setup/changeui.mspx
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21.1 Some notes for the helium handling 

In the TOPSPIN installation path (normally C:\Bruker\TOPSPIN) in the direc-
tory ...\prog\logfiles are two files named heliumlog and helium-
log.err. The heliumlog saves every night at 3.00 am the actual helium level
in a new line. The heliumlog.err documents every error during detecting the
helium level.

The helium log runs under the local system account. Change this to the user whois
always logged on:

a) Click on Start → Settings → Control Panel → 'Task Scheduler'.

b) Click twotimes on the task AT1(2,...) which runs at 3:00 AM.

21.1.1 Automatic notification for helium refill

1. Open a Command Prompt and enter: 

• cd /d c:\Bruker\TOPSPIN 

• notepad heliumlimit 

type in the number (without ’%’) of the helium level should activate the notifi-
cation, e. g. 25 
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Click file → save as .. and save it as <TOPSPINHOME>\heliumlimit

Of course, you can also install the heliumlimit file from the Explorer. We have
chosen the Command Prompt because the Explorer might add the extension .txt
DONE INDEXto the file heliumlevel which makes it unusable (see chapter 7.2.2).

2. Now you could create a command script <TOPSPINHOME>\heli-
umwarn.cmd that will be executed if the actual helium level is the same or
below the entry (in %) in the file <TOPSPINHOME>\heliumlimit

E. g. it is possible to create a message window on the screen of the spectrometer
PC and/or every other PC in your network (e. g. the PC of the responsible person
for helium refill). You could do this in the following way:

3. Open a Command Prompt and enter: 

• cd /d c:\Bruker\TOPSPIN 

• notepad heliumwarn.cmd 

type in the following text:

@echo off

rem ------------------------------------------------------

rem heliumwarn.cmd: example MS cmd script to send a warning

rem                argument1=LEVEL

rem                argument2=LIMIT

rem ------------------------------------------------------

rem  user defined variables:

rem  INSTRUMENT: is the name of the spectrometer

rem  ADDRESS   : the address where the message is sent to.

rem              type ’net help send’ for details

rem ------------------------------------------------------

set INSTRUMENT=’Avance-300’

set ADDRESS1=%COMPUTERNAME%

set ADDRESS2=%NMR-SUPERUSER-PC%

set ADDRESS3=%HELIUM-REFILLER-PC%

rem ------------------------------

rem  catch command line arguments:

rem ------------------------------

set MYSELF=%0
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set LEVEL=%1

set LIMIT=%2

rem ---------------------------------------
DONEINDEXrem  get the name of the spectrometer host:

rem ---------------------------------------

set HOST=%COMPUTERNAME%

rem ----------------------------

rem  prepare the email message:

rem ----------------------------

set MSG=Attention: At the magnet of the %INSTRUMENT% spec-
trometer is the heliumlevel of %LEVEL%%% equal or lower than
the helium level limit of %LIMIT%%%: please order liquid he-
lium and refill the helium tank. --- This message has been
sent by %MYSELF% on %HOST% to %ADDRESS1%, %ADDRESS2% and
%ADDRESS3%

rem ------------------

rem  send the message:

rem ------------------

net send %ADDRESS1% %MSG%

net send %ADDRESS2% %MSG%

net send %ADDRESS3% %MSG%

You have to write in your individual parameters

• replace Avance-300 with the name of your spectrometer

• replace NMR-SUPERUSER-PC with the name of the PC of the NMR-Supe-
ruser

• replace HELIUM-REFILLER-PC with the name of the PC of the responsible
person for helium refill

• Attention - the text sequence:

set MSG=Attention: At the magnet of the %INSTRUMENT%
spectrometer is the heliumlevel of %LEVEL%%% equal or
lower than the helium level limit of %LIMIT%%%: please
order liquid helium and refill the helium tank. --- This
message has been sent by %MYSELF% on %HOST% to %ADDRESS1%,
%ADDRESS2% and  %ADDRESS3%
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had to be written in one line!
DONE INDEX
click file → save as.. and save it as <TOPSPINHOME>\heliumwarn.cmd

Now the defined PC’s will get an error message if the actual helium level is the
same or below the entry (in %) in the file 

<TOPSPINHOME>\heliumlimit

The notifications were sends only once but it will be activated again if the helium
level is against higher than the limit.

Note that this script is only an example, if you would like to add more PC’s in
the notification list you had to add the respective addresses, if you like to have-
less addresses you have to delete the respective entries.

21.2 Script for saving important files

TOPSPIN offers a script (xwinnmr.save) for saving very important files that are not
delivered by BRUKER. This script can save and extract user specific data from the
TOPSPINHOME directory and puts them into a tar-file. Files that start with an "."
are ignored. The script can be started as follows:

• Click on the Bruker Utilities icon on the desktop

Bruker Utilities → Miscellaneous → xwinnmr.save.cmd 

• For more information open the command prompt of the Bruker Utilities

Bruker Utilities → Command prompt      and enter 

.\prog\bin\utilities\miscellaneous\xwinnmr.save –help

Files and directories will be saved into the special tar-file xwin_backup.tar
which is, by default, in the directory TOPSPINHOME/xwin_backup. 

The xwinnmr.save script saves the same files and directories as the nmr_save AU
program (see chapter 8.8).

The options for xwinnmr.save starting from a command prompt are:
 xwinnmr.save [-options]

• help additional information
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• path <string> absolute path where backup tar-file
nmr_backup.tar will be created (backup
directory)
DONEINDEX
• restore <string> absolute path where backup tar-file can be found

(backup directory); the target directory must
also be specified! (see examples below)

• replace overwrite existing nmr_backup.tar file

• silent do not display any messages

• source <string> absolute path to TOPSPIN/XWIN-NMR installation
that should be saved

• spect <string> spectrometer name (e.g. spect; default is the cur-
rent name)

For safety reasons the tar-file will not be replaced by executing the xwin-
nmr.save script once again. So if you like to use the script several times, you
have to move the xwin_backup.tar file from the directory TOPSPIN-
HOME/xwin_backup on a backup medium (floppy, CD ...) and then start the
script once again or you have to use the ’replace’ option.

21.3 Where Do I Find What?

If you cannot find the required information in this manual, please check the manu-
als listed below.

Further useful information you can also find in the Release Letter for the respec-
tive TOPSPIN version.

• TOPSPIN Users Guide
Window handling, diplaying data, interactive data manipulation, user interface
related items.

• Acquisition Reference
Description of all acquisition commands, parameters and files. 

• Processing Reference
Description of all processing commands, parameters and files.

• AU Reference
How to write AU programs. Description of all AU macros, functions and vari-
ables. List of Bruker AU programs.
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• TOPSPIN PLOT EDITOR

Printing and plotting of data sets.

• NMR-SIM Experiment Simulator
DONE INDEX
Simulation of NMR experiments.

• ICON-NMR Automation Interface
Comprehensive user interface, tailor made for all your laboratory management
and control needs.

For further manuals please refer to:

• TOPSPIN  → Help

• http://www.bruker-biospin.com/documentation_nmr.html

• NMR-GUIDE

http://www.bruker-biospin.com/documentation_nmr.html
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Bruker BioSpin addresses 

Germany
Bruker BioSpin GmbH
Silberstreifen
76287 Rheinstetten
Germany
Tel: +49 (0)721 5161 0
Fax: +49 (0)721 5171 01

Bruker BioSpin
Service & Support Department
Silberstreifen
76287 Rheinstetten
Tel: +49 (0) 721 5161 296
Fax: +49 (0) 721 5161 943

http://www.bruker-biospin.com

ftp server: ftp.bruker.de

Email: nmr@bruker-biospin.de (sales)
       mbu@bruker.de (service)
       applik@bruker.de (application)
       nmr-software-support@bruker-biospin.de (software)
       license@bruker.de (licenses)

http://www.bruker-biospin.com
ftp://ftp.bruker.de


292 Bruker BioSpin addresses

INDEX

USA
Bruker BioSpin Corporation
15 Fortune Drive 
DONE INDEX
Manning Road
Billerica, MA. 01821-3991

Tel: +1 978 667 9580 5195 (center)
     +1 978 667 9580 5444 (application)
Fax: +1 978 667 6168 (center)
     +1 978 667 2955 (application)

http://www.bruker-biospin.com
ftp server: ftp.bruker.com

e-mail: applab@bruker.com
        center@bruker.com
        software@bruker.com

Switzerland
Bruker BioSpin AG
Industriestraße 26
CH-8117 Fällanden

Tel: +41 (44) 8259 111
Fax: +41 (44) 8259 696

web server: www.bruker.ch
e-Mail: epweb@bruker.ch
        all_ap@bruker.ch

France
Bruker BioSpin S.A.
34, rue de l’industrie
F-67166 Wissembourg/Cedex

Tel: +33 3 88 73 68 00
Fax: +33 3 88 73 68 79

e-Mail: support-rmn@bruker.fr (customer support)

http://www.bruker-biospin.com
ftp://ftp.bruker.com
http://www.bruker.ch
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England
Bruker BioSpin LTD.
Banner lane
DONEINDEX
Coventry CV4 9GH
Tel: +44 (24) 7685 5200
Fax: +44 (24) 7646 5317

web server: www.bruker.co.uk

e-mail: service@bruker.co.uk
        apps@bruker.co.uk

Our webpage

http://www.bruker-biospin.com/contact_us.html

• provides contact adresses of our facilities and offices worldwide

http://www.bruker.co.uk
http://www.bruker-biospin.com/contact_us.html
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Numerics
2D 48

3D 48

B
backup 218, 219, 252

BASH 99
DONEINDEX
4D 48

A
about 118, 193

ACB tool 214

account
Computer administrator 135

acquisition
mode 28, 82

Acquisition Reference Manual 21, 93

Acrobat Reader 19, 39

Acronis True Image 226

Add/Remove 144

adding a new user 133

Additional license 64

Adobe 19

adware 281, 282

Amix 63

antivirus program 269, 280

arp 163

AURELIA 48, 63

Auremol 44, 48, 63

automatic
configuration of a datastation 25, 94

Automatic backup 29, 86, 94

Automatic Updates 269

Autorun 145, 146

AV 14

AVANCE 14, 15, 35, 195, 198

AVANCE-II 14, 15, 35, 52, 195, 198

AVANCE-III 14, 17, 35, 195, 205

AV-II 14

AV-III 14

Bfs 187

binary mode 235

BIOS 148

Boot Disk 216

boot partition 216

boot.ini 216

Bootparam 187

bootparam 35

Browsing options 231

Bruker
DHCP Server 209

tftpd32 212

Bruker addresses 291

Bruker FLEXlm License Server 187

Bruker Utilities 52, 96, 104, 107, 131, 132,
194, 206, 214

Bruker_default_av500 25, 94

Bruker_default_avanceII300 25, 94

BSMS 99

BSMS shuttle 100

BSMS tool 214

bsmsdisp 104

BSMS-Keyboard 99

BsmsSaveUsrNvm.txt 111, 113

C
Carriage Returns 236

cat 251

CCU 36, 44, 48, 168, 195, 198, 200, 201, 205

cf 24, 26, 50, 75, 87, 195, 198

classic logon screen 258

clipboard 243, 248

COM2 200
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command
acquisition 198

cf 25, 42, 94

configuration 94

date 250, 251

default
DONEINDEX
configuration 42, 198

expinstall 42

Command Prompt 36, 41, 42, 69, 70, 163,
169, 190, 232, 246, 250, 251, 260, 285, 286

compiler 58

Compress attribute 235, 236

Computer Name 149, 163

configuration
Bruker_default_av500 25

Bruker_default_avanceII300 25, 94

datastation 25, 94

default 94

directory 86

name 28, 81, 92

confout.txt 114

Control Panel 245

copy 251

Counted license 67

cp 251

CPU 13

creating an image 226

critical updates 278

cron 86, 94

cron check 29, 85, 93

Ctrl+Alt+Delete 133

cu 200

cut & paste 261, 262

cygwin 58

cygwin1.dll 58

D
DAEMON line 67

datastation

printer 28, 82, 92

selection in expinstall 28, 81

default configuration 25

Bruker_default_av500 25, 94

Bruker_default_avanceII300 25, 94

De-install 145

del 215, 249, 251

deli 215

delp 215

Demo license 64, 67, 70, 71

deselect 261

Developer license 64

DHCP 159

DHCP Server 209

diff 251

Disk Administrator 154

DISKLESS 44, 52

DISKLESS package 36, 38, 144, 188

display resolution 14

DNS 157, 159

Documentation 98

Domain 45, 172, 173, 270

Domain account 42, 172, 174

Domain Administrator 172, 173

Domain NMR Superuser 174

Domain user 172

domainname 157, 158, 159, 202

double-paned window 229

Download 150, 151, 177, 214

E
ECLB board 100

edhead 28, 83
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edlock 28, 85

edprosol 28, 84

edscon 28, 85

configuration script 129

Windows XP SP2 272

firmware 27, 79, 104
DONEINDEX
edsolv 28, 83

ELCB board 106

restore user configuration 111

save user configuration 110

Enhanced Metafile 243

Ethernet adapter 42

Ethernet cable 198

Ethernet card 14, 65, 66, 69, 157

ethernet card
half duplex 203

ethernet-service-tools 106, 205

Event Viewer 188

Events 188

exam1d_1h 26, 75, 87

Excel 179

expinstall 24, 27, 50, 79, 90, 94

expinstall command 26

Explorer 70, 163, 246, 259, 286

F
FAT filesystem 153, 215, 232, 255

FEATURE line 66, 67, 70, 191, 192

file 42

file extensions 70, 231, 261

filesystem
FAT16 153

FAT32 153

NTFS 153

find command 251

Find program 231, 232

firewall 130, 199, 208, 269, 270

alerts 277

configuration for NFS Server 38

Firmware Update for boards with
ethernet connection 106

Firmware Update for boards without
ethernet connection 104

Flexlm license manager 18, 65, 67, 70, 71,
72, 189, 192

Floating license 65, 66, 67, 163, 191

focus 246

ftp 143, 232, 235

Full license 64, 70, 71

Full Name 134, 137

full-screen 248

G
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